Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8

Forced Induction - V8 V8 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 06-20-2013, 03:37 PM   #1
Speed Kills
Live to Drive
 
Drives: 2010 IBM RS/SS, 2010 Charger RT
Join Date: May 2010
Location: Los Angeles
Posts: 168
A/C belt shredding - see post #11 for updated details.

Brothers and Sisters - I need some help ... (I tried searching all the possible combinations of my issues, but to no avail...)

Luke at Blu 808 (great shop, great guy - highly recommended to any NorCals!) installed a Maggie 2300 on my buddy's 2011 L99. He keeps shredding a/c belts (on #3). Luke and Blu 808 have taken very good care of him, but wanted to see if I could help end the madness. Anyone else have this issue and know how to resolve it? Any guidance is greatly appreciated!!

Thanks,
Speed

Last edited by Speed Kills; 07-31-2013 at 11:53 PM.
Speed Kills is offline   Reply With Quote
Old 06-20-2013, 06:29 PM   #2
bigsquirrel
My car runs on acorns....
 
bigsquirrel's Avatar
 
Drives: 2010 SS RS Inferno Orange
Join Date: Feb 2010
Location: Albuquerque
Posts: 1,345
Dumb question, I'm sure they are great guys. Are they installing it properly? It's a stretch to fit and there are tons of ways to get it on there but if you stretch it to much they will shred again real quick. (Actually mean that they kind of fall apart from the inside out.)
__________________
My car runs on acorns, the tears of ricers and these other slightly less important things...

2.9 Polished Whipple, Kooks LT 1 7/8 headers, HiFlow Cats, Kooks Sleeper catback, Cooling Mist Methanol Injection, PFADT Sport Sways, PFADT Springs, PFADT rear trailing arms, ADM intake, JDP stainless brake lines, Jegs Catch can, Stock SS wheels widened to 10 3/4, Hawks HPS Pads, Pedders Rear Subframe Bushing Inserts, BMR Center Brace, MSD BAP, AAC side markers, Emblem Pro's Custom Lighted Door Sills, Dash-Floor-Cupholder ABL lighting and other stuff....
bigsquirrel is offline   Reply With Quote
Old 06-20-2013, 08:44 PM   #3
SSMickey
SECC
 
SSMickey's Avatar
 
Drives: 2010 IBM 2SS
Join Date: Feb 2010
Location: Columbia S.C.
Posts: 1,428
Is the belt alignment good?
__________________
Vengeance Stage II Cam, Halltech CAI, RX Catch Can, Full ARH Exhaust, QTP Cutouts, Powerbond 25% Underdrive, MGW Shifter, MTI Drop Springs, Forgeline RB3C Wheels, 3.91 gears, Night Owl LED Control System
SSMickey is offline   Reply With Quote
Old 06-20-2013, 09:58 PM   #4
dan0617
 
dan0617's Avatar
 
Drives: 2011 Inferno Orange SS Convertible
Join Date: Apr 2012
Location: Tyrone, PA
Posts: 622
I shredded one when I was bone stock. Put on an aftermarket belt and all is good. Was told the factory belts were bad but after shredding just one I went aftermarket.
__________________
2011 SS IOM Vert. ECS Vortech 13.5 psi, Water/Meth, 125 shot, 2800 stall, LT headers, Zex 125 shot, Drag radials, Drag alignment. Details in Garage. I hack it up, Ted tunes it in.
dan0617 is offline   Reply With Quote
Old 06-20-2013, 10:03 PM   #5
Speed Kills
Live to Drive
 
Drives: 2010 IBM RS/SS, 2010 Charger RT
Join Date: May 2010
Location: Los Angeles
Posts: 168
Quote:
Originally Posted by bigsquirrel View Post
Dumb question, I'm sure they are great guys. Are they installing it properly? It's a stretch to fit and there are tons of ways to get it on there but if you stretch it to much they will shred again real quick. (Actually mean that they kind of fall apart from the inside out.)
To the best of my knowledge, yes the install is correct and proper. Like I said, not my car, but Luke at 808 stands by his work. Perhaps other members who have used them can chime in ...

Quote:
Originally Posted by SSMickey View Post
Is the belt alignment good?
Yes.
Speed Kills is offline   Reply With Quote
Old 06-20-2013, 10:44 PM   #6
Speed Kills
Live to Drive
 
Drives: 2010 IBM RS/SS, 2010 Charger RT
Join Date: May 2010
Location: Los Angeles
Posts: 168
Quote:
Originally Posted by dan0617 View Post
I shredded one when I was bone stock. Put on an aftermarket belt and all is good. Was told the factory belts were bad but after shredding just one I went aftermarket.
What type of belt did you go with?
Speed Kills is offline   Reply With Quote
Old 06-20-2013, 11:28 PM   #7
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 12,021
Quote:
Originally Posted by Speed Kills View Post
Brothers and Sisters - I need some help ... (I tried searching all the possible combinations of my issues, but to no avail...)

Luke at Blu 808 (great shop, great guy - highly recommended to any NorCals!) installed a Maggie 2300 on my buddy's 2011 L99. He keeps shredding a/c belts (on #3). Luke and Blu 808 have taken very good care of him, but wanted to see if I could help end the madness. Anyone else have this issue and know how to resolve it? Any guidance is greatly appreciated!!

Thanks,
Speed
3 years ago my car was doing that too. I think when Ted jumped off the gas suddenly the belt would pop off. He would need to chime in to state exactly what causes it. Driving on the street no problems at all but when it's at the track or on the dyno we remove the a/c belt.
Supercharged SS is offline   Reply With Quote
Old 06-21-2013, 05:24 AM   #8
Motion427
Account Suspended
 
Drives: 2010 2SS/RS Red Jewel L99
Join Date: Jun 2011
Location: NB,Canada
Posts: 840
Quote:
Originally Posted by Supercharged SS View Post
3 years ago my car was doing that too. I think when Ted jumped off the gas suddenly the belt would pop off. He would need to chime in to state exactly what causes it. Driving on the street no problems at all but when it's at the track or on the dyno we remove the a/c belt.
That's cheating you know.lol....
Motion427 is offline   Reply With Quote
Old 06-21-2013, 05:42 AM   #9
MA2010SS
 
Drives: 2010 Camaro SS
Join Date: Aug 2010
Location: Somerset MA
Posts: 510
Had the same problem with the AC belt also after 1000 miles it flipped and shredded at the track. Replaced it with an aftermarket one not a problem since with plenty of track time also.
__________________
2010 Camaro SS Whipple SC, CAI Inc Intake, JRE 4.11 Gears, TSP 1 7/8" LT headers no cats, 3" magnaflow exhaust, HPT, RX Catch Can, LSR Toe Rods, LSR Trailing Arms, ALKY Control Meth, McLeod RXT Twin Disc, DSS 1000HP alxes, DSS aluminum DS, ZL1 fuel pump, Tuned by SLOWHAWK Performance Bridgewater MA 577RWHP
MA2010SS is offline   Reply With Quote
Old 06-21-2013, 10:28 AM   #10
dan0617
 
dan0617's Avatar
 
Drives: 2011 Inferno Orange SS Convertible
Join Date: Apr 2012
Location: Tyrone, PA
Posts: 622
Quote:
Originally Posted by Speed Kills View Post
What type of belt did you go with?
Got it from Autozone, not sure what brand.
__________________
2011 SS IOM Vert. ECS Vortech 13.5 psi, Water/Meth, 125 shot, 2800 stall, LT headers, Zex 125 shot, Drag radials, Drag alignment. Details in Garage. I hack it up, Ted tunes it in.
dan0617 is offline   Reply With Quote
Old 07-31-2013, 11:52 PM   #11
Speed Kills
Live to Drive
 
Drives: 2010 IBM RS/SS, 2010 Charger RT
Join Date: May 2010
Location: Los Angeles
Posts: 168
Update-
The belt is shredding as a result of the a crank pulley wobble. The factory pulley has been replaced and the problem still exists. The local dealership will not warranty the problem. Is this wobble common? Here is a pic of the belt and the place where it splits.

Look closely by the lettering on the belt. I've been told this could be a manufacturing defect and might require engine replacement - not sure if this is true.

Any guidance is appreciated. Sorry to bump an older thread, but I'm staying with my buddy who owns the car and he and I are going to another dealership on Friday to see what the deal is. Wanted to be armed with as much info as possible.
Speed Kills is offline   Reply With Quote
Old 08-01-2013, 12:56 AM   #12
Jayrcr3

 
Jayrcr3's Avatar
 
Drives: 2011 IOM 2SS/RS
Join Date: Dec 2010
Location: Chatham, Illinois
Posts: 751
If the pulley is wobbling around, you either have a bent pulley, or a bent crank. My guess is its a bent crank, and that's why they don't want to warranty it. If the car is basically stock I would start fighting with GM about it.



Sent from my HTC One X using Tapatalk 4 Beta
__________________
American Racing 1 7/8" Headers and Hi-Flow Cats, CAI cold air intake, Flowmaster AT exhaust, Vengeance Racing Stage 2 cam, VMax ported throttle body, TEA valve springs and titanium retainers, Trick Flow hardened pushrods, 180* T-stat, Comp Trunion kit, ZL1 Fuel Pump, ADM Fuel Pump Control Module, 20% window tint, Whipple Supercharger. Tuned by Mike Norris Motorsports. 656rwhp/584rwtq @10 PSI.
Jayrcr3 is offline   Reply With Quote
Old 08-01-2013, 01:00 AM   #13
Jayrcr3

 
Jayrcr3's Avatar
 
Drives: 2011 IOM 2SS/RS
Join Date: Dec 2010
Location: Chatham, Illinois
Posts: 751
Quote:
Originally Posted by Jayrcr3 View Post
If the pulley is wobbling around, you either have a bent pulley, or a bent crank. My guess is its a bent crank, and that's why they don't want to warranty it. If the car is basically stock I would start fighting with GM about it.

Edit: Sorry, I went back and read through the entire post. Your likely in trouble with the warranty.

Sent from my HTC One X using Tapatalk 4 Beta


Sent from my HTC One X using Tapatalk 4 Beta
__________________
American Racing 1 7/8" Headers and Hi-Flow Cats, CAI cold air intake, Flowmaster AT exhaust, Vengeance Racing Stage 2 cam, VMax ported throttle body, TEA valve springs and titanium retainers, Trick Flow hardened pushrods, 180* T-stat, Comp Trunion kit, ZL1 Fuel Pump, ADM Fuel Pump Control Module, 20% window tint, Whipple Supercharger. Tuned by Mike Norris Motorsports. 656rwhp/584rwtq @10 PSI.
Jayrcr3 is offline   Reply With Quote
Old 08-01-2013, 12:51 PM   #14
victoryred1ss
 
victoryred1ss's Avatar
 
Drives: 2010 SS M6
Join Date: Oct 2009
Location: Utah
Posts: 554
I have seen a couple Camaros bone stock come in with the belt coming apart in the same spot. I would try an aftermarket belt as said above
__________________
TVS 2300 721RWHP 686RWTQ
Built by Me
Suspension done by JDP
Tune done by JRE
victoryred1ss is offline   Reply With Quote
Old 08-01-2013, 08:44 PM   #15
CausticGuy
 
Drives: 2010 Chevrolet Camaro SS/RS
Join Date: Apr 2011
Location: Norton Shores
Posts: 205
My dealership replaced mine under warranty, said they heard it was a batch of bad belts on '10s
CausticGuy is offline   Reply With Quote
Old 08-02-2013, 05:40 AM   #16
dan0617
 
dan0617's Avatar
 
Drives: 2011 Inferno Orange SS Convertible
Join Date: Apr 2012
Location: Tyrone, PA
Posts: 622
It's pretty hard to bend the crank. Did someone jack your car up off the ground by the pulley? I can't imagine it is a bent crank.
__________________
2011 SS IOM Vert. ECS Vortech 13.5 psi, Water/Meth, 125 shot, 2800 stall, LT headers, Zex 125 shot, Drag radials, Drag alignment. Details in Garage. I hack it up, Ted tunes it in.
dan0617 is offline   Reply With Quote
Old 08-06-2013, 12:48 PM   #17
TimSS
 
TimSS's Avatar
 
Drives: 2011 Camaro 2SS RS
Join Date: Nov 2010
Location: Bunker Hill, WV
Posts: 83
I had to go into the dealership 3 times because of my A/C belt squealing and wearing as it was walking itself off the pulley. The first two times, they said it was stretched and just replaced the belt, the last time they cut the belt off (and left it off) and ordered a new balancer and put it on with a new belt. I haven't had a problem since and it was covered under warranty! I guess we'll see what happens after I start puttin miles on it.
TimSS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.