Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vitesse Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8

Forced Induction - V8 V8 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 06-21-2013, 06:36 PM   #1
zslewis
 
zslewis's Avatar
 
Drives: 2010 TT Camaro SS
Join Date: Mar 2011
Location: Augusta GA
Posts: 268
RPM issue

Only posting this here cause i have twin turbo and maybe someone here can help me...

So I have a front mount twin turbo system that the RPMs are basically stuttering between the 2-3k range... If I keep pressing the gas eventually it will power through. Someone was telling a friend of mine that if you tank the MAF off and do something to it, that it will fix this issue. He said that you had to remove a flap... well I dont see any obvious flap on the MAF... Granted I will get the car retuned because I have had issues with the car ever since i let HPS put the system in and cant get them to fix it. Long story...

Has anyone ever heard about doing this or know what I am talking about?
__________________
2010 Twin Turbo Camaro SS
RWHP: TBD TQ: TBD

Zach
zslewis is offline   Reply With Quote
Old 06-21-2013, 07:00 PM   #2
dan0617
 
dan0617's Avatar
 
Drives: 2011 Inferno Orange SS Convertible
Join Date: Apr 2012
Location: Tyrone, PA
Posts: 624
Do you have a crankcase evac setup? Make sure you do.

Could also be in the tune. Nothing needs cut off your MAF.
__________________
2011 SS IOM Vert. ECS Vortech 14 psi, Water/Meth, Wideband with Firewire to SCT, 2800 stall, LT headers, Drag radials, Drag alignment, Cradle Bushings. Details in Garage. I hack it up, Ted tunes it in.
dan0617 is offline   Reply With Quote
Old 06-21-2013, 08:05 PM   #3
blake-b

 
blake-b's Avatar
 
Drives: Black 2010 2SS/RS LS3
Join Date: May 2010
Location: Kansas City, MO
Posts: 1,573
also check your grounds... my car wouldn't rev above 2500 and would buck and kick wildly like I was learning to drive a stick for the first time. Turned out to be a loose ground on the passenger side head.
blake-b is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.