Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 06-23-2013, 06:43 PM   #1
eclipsen
 
Drives: 2010 Camaro 2SS/RS
Join Date: Sep 2009
Location: Lititz, PA
Posts: 74
Weird Handling issues with Pedders

I recently installed Pedders ZL1 spec sways (FE4 conversion) and XA coilovers on my 2010 SS. I already had a full bushing kit installed. I have the coilovers set to 10 front, 8 rear (from full soft).

When the car goes over some road to road transitions while turning, the inside rear wheel loses contact with the road surface causing it to spin. And the rear end seems unsettled on bumpy cornering. I tried disconnecting the rear sway with no change in behavior. I then put the coilovers to 0 front and rear. While this helped a great deal, I still get the inside rear wheel contact issue.

Has anybody else had similar issues? With the coilovers at 0, the suspension still seems rather stiff and there is NO bouncing.
__________________
2010 Camaro 2SS/RS, 6M, ADM Race scoop, CAI intake, VMAX TB, Kooks LTs, Solo Mach X, MGW Shifter, Dynotech driveshaft, 1LE 3.91 gears with JRE updates, BMR bushings/Toe/Trailing Arms, Pedders ZL1 sways and XA Coilovers, Heritage Grill, Yenko side stripes, SS emblems, Havoc Rear Spoiler.
eclipsen is offline   Reply With Quote
Old 06-24-2013, 09:55 AM   #2
Iron Lung Jimmy
 
Drives: Iron Lung, Jimmy
Join Date: Jun 2009
Location: Louisiana
Posts: 322
Several of us have had similar issues. Here's mine:

http://www.camaro5.com/forums/showthread.php?t=283942

I think the deal is that your car is now STIFF and it's not all that hard to unweight a wheel. I have gotten used to it and learned to mostly drive around it. So while it annoyed the crap out of me at first now it's just normal and the handling improvement is well worth the compromised civility.
Iron Lung Jimmy is offline   Reply With Quote
Old 06-25-2013, 05:36 PM   #3
JusticePete
CamaroCross Founder
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,706
Quote:
Originally Posted by Iron Lung Jimmy View Post
Several of us have had similar issues. Here's mine:

http://www.camaro5.com/forums/showthread.php?t=283942

I think the deal is that your car is now STIFF and it's not all that hard to unweight a wheel. I have gotten used to it and learned to mostly drive around it. So while it annoyed the crap out of me at first now it's just normal and the handling improvement is well worth the compromised civility.
We know it is not the sway bar becuase we did a test with eclipsen. He removed one sway bar link and the car drove the same way. It is my guess we have a bind in the rear suspension for whatever reason. Eclipsen and I are trying to get him to on of my super dealers that not only install suspensions but actually build race car suspensions. It is an unusual issue and one that we want resolved by an expert.
__________________
JusticePete is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.