Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals


Reply
 
Thread Tools
Old 07-02-2013, 11:15 PM   #113
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
testing my new GoPro, since i messed up on our cruise day with my roommate's old one and didn't get any video at all...so, if anybody wants to see a drive to work and back...

__________________
Build thread linked in the pic...



Last edited by OzzySS; 07-03-2013 at 12:14 AM.
OzzySS is offline   Reply With Quote
Old 07-16-2013, 11:12 PM   #114
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
eagerly awaiting delivery of my pfadt tri-y headers this week. Matt over at FSP told me they were delayed due to exhaust clamps, but still went out last week. hoping tomorrow, maybe??

finally got my clutch reservoir too...i know, i've put this one off for a long time...but i finally got it, and now i need to decide when to install. this week, obviously, since i'm on leave through the rest of the week...
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-17-2013, 01:24 AM   #115
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,688
Great build! I love seeing yellow Camaros that don't have the cliche bumblebee theme. Yours for sure looks great! Keep up the great work!
__________________
Aubrey64 is offline   Reply With Quote
Old 07-17-2013, 01:36 AM   #116
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
Thanks, I keep telling myself the next mod will be the last, but...apparently I'm a liar and a sucker
even with all that I've done, I still get the bumblebee comments...
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-17-2013, 02:36 PM   #117
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
Happy birthday to me!
these things really quite good-looking





even Ginger was happy!


now...do i try to put it on a lift today???
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-17-2013, 03:07 PM   #118
tramtwo


 
tramtwo's Avatar
 
Drives: 2013 1LE
Join Date: Jul 2011
Location: N'Awlinz
Posts: 6,306
Quote:
Originally Posted by OzzySS View Post
Happy birthday to me!
these things really quite good-looking





even Ginger was happy!


now...do i try to put it on a lift today???

stop dickin around and get these installed... going to love 'em
the rear o2 sensors are a bear... kickin' everybody's ass... good news is you don't need them on the new set up. I plugged my bungs on the high flow cats... M15 x 1.5 (same size as some oil drain plugs)
__________________
tramtwo is offline   Reply With Quote
Old 07-17-2013, 07:19 PM   #119
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
Planning for tomorrow...either Newb or one of my work buddies is gonna come with and double check me, since I've never done headers myself. Gonna go out tonight and get the various little extras needed. I also got my clutch separator kit to do as well
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-17-2013, 07:37 PM   #120
SUKXOST
Do you even lift, bro?
 
SUKXOST's Avatar
 
Drives: 2013 1LE Camaro
Join Date: Aug 2012
Location: Sumter, SC
Posts: 3,158
build is looking good man
__________________
My 1LE (645WHP/597WTQ) build/journal Thread:
1st ever 1LE COTW http://www.camaro5.com/forums/showthread.php?t=255461
SUKXOST is offline   Reply With Quote
Old 07-18-2013, 12:36 AM   #121
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
thanks...saw you did the red lights for the DIC. i still haven't done it myself, i feel like i'm gonna break that gauge bezel when i'm trying to pop it off...got any tips for that?
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-18-2013, 09:55 PM   #122
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
newb and i got the pfadt tri-y's installed this morning...took just under 4 hours. loving the new sound...couple of minor issues tho.
- immediately threw a CEL, even though the thread announcing the pre-orders said they wouldn't throw codes. not a huge deal, at this point i was planning to tune afterwards anyway...
- fitment wasn't as great as advertised. it was still good, but there was a firewall bolt underneath that was going to be beating the passenger side cat (fixed with a hacksaw blade), and there's a little nub on the steering that's rubbing the driver's side rear tube when i turn. so i'm about to go fix that.
these fitment issues could be things caused just by every car being a little different, and are still relatively minor in the long run, but newb said he didn't have anything like that with his kooks.
oh well, i'm not unhappy. should be an easy fix. and i still saved ~$150 going this route.
pics and vids will follow soon.
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-18-2013, 09:57 PM   #123
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
also, big thanks to Newb for providing the knowledge this morning! it would have taken me considerably longer, since i'd never done headers myself, and the only photo in the instructions was showing to knock off the nub prior to putting the HFCs on
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-18-2013, 10:03 PM   #124
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335

passenger side...


driver side...


this was just close enough to be annoying...and not enough room to work a whole hacksaw, so i had to use just the blade


__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
Old 07-18-2013, 10:08 PM   #125
tramtwo


 
tramtwo's Avatar
 
Drives: 2013 1LE
Join Date: Jul 2011
Location: N'Awlinz
Posts: 6,306
Kewl... I had to slide the rubber boot up on the steering knuckle to keep my dynatechs from burning it up. You could run with that cell without hurting anything.

Bet you are really loving the sound now!!!!

Sent from my DROID RAZR using Tapatalk 2
__________________
tramtwo is offline   Reply With Quote
Old 07-18-2013, 10:13 PM   #126
OzzySS

 
OzzySS's Avatar
 
Drives: 2013 2SS/1LE, 2004 Cavalier
Join Date: Sep 2012
Location: jax, FL
Posts: 1,335
Quote:
Originally Posted by tramtwo View Post
Kewl... I had to slide the rubber boot up on the steering knuckle to keep my dynatechs from burning it up. You could run with that cell without hurting anything.

Bet you are really loving the sound now!!!!

Sent from my DROID RAZR using Tapatalk 2
Hell yea I love the sound...just took a closer look and I'm gonna have to do the same thing with my steering issue, I think...I thought my steering felt different, turns out it's the whole rubber piece rubbing, not just the metal nub...
Attached Images
 
__________________
Build thread linked in the pic...


OzzySS is offline   Reply With Quote
 
Reply

Tags
1le, 2013, npp, ozzyss, rally yellow

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.