Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
autoguy
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 10-23-2012, 09:21 PM   #120
redredrage
 
redredrage's Avatar
 
Drives: 2010 Camaro SS manual all stock
Join Date: Jun 2012
Location: Royal Oak, MI
Posts: 160
Fixed on warranty, oil pump relief valve was sticking because of a scared up bore and was causing intermittent oil flow to engine.


GM has some replacing to do
redredrage is offline   Reply With Quote
Old 10-25-2012, 10:33 PM   #121
epkmvuoq
 
Drives: 2ss red m6
Join Date: Dec 2009
Location: grosse tete
Posts: 215
Quote:
Originally Posted by Russell James View Post
I'd push the issue and ask for a diagnosis. Technically, if it is a defective oil pump - it should be covered. If it is damage caused by your modifications, then it should not be covered. Seeing how there is a bulletin, and an ass load of oil pump failures on Camaros.... one might logically at least think a factory defect is possible. The - calibration police - though will turn a blind eye to any such possibility and void your warranty without even investigating/diagnosing.

The trouble is finding someone that knows how to read the actual warranty book and M/M Act. The FTC has clearly interpretted the M/M Act as meaning - the warranty cannot be voided for aftermarket parts, and to deny warranty coverage the manufacturer has to show how the aftermarket part caused the failure.

What they will show you is a theory, and the door. Then when you take the pump out yourself on your own dollar - the mtherfcking pressure relief valve will be stuck. I'd love to hear an explanation of how a calibration change caused an oil pump to fail. But they've gone with that arguement on many occasions.
By the time you hire a attorney you lose even if you win !!!
epkmvuoq is offline   Reply With Quote
Old 10-25-2012, 11:21 PM   #122
camarostar2010
 
Drives: 2011 SS
Join Date: Nov 2011
Location: new jersey
Posts: 373
I had this happen...my advice..why replace a shitty product with the same. Save your marbles get the upgraded oil pump, belt tensioner and all the other goodies..if u can get cammed while you are at it...real talk
camarostar2010 is offline   Reply With Quote
Old 11-13-2012, 01:43 PM   #123
cmat043
 
Drives: 2010 Camaro 2SS
Join Date: Nov 2012
Location: Houston, Tx
Posts: 3
The Ballad of my Failed Fuel Pump:

Chorus: I park my car on Friday night.
I start my car for the first time on Monday morning.
I get the "LOW OIL PRESSURE - TURN OFF ENGINE"
I have my car towed to dealership.
Dealership cannot duplicate problem.
The car runs with oil pressure 10-15 up to 50 psi all week.

The service manager told me that the relief valve sticks in these cars, but he's never heard of this happening????

(Chorus)

They cannot give me a loaner because I had it in there for 2 whole weeks with them trying to diagnose the problem.

So, I started a case with GM. Hopefully something gets done, because I sure don't want it to get to the point where.... well I don't want to say it because it might come true.

(Chorus)

That's right, I've had it in there 3X and they still won't do anything. I'm screwed
cmat043 is offline   Reply With Quote
Old 11-13-2012, 03:48 PM   #124
mikeSS


 
mikeSS's Avatar
 
Drives: 2013 E92 M3, 2015 c7
Join Date: Nov 2009
Location: MI
Posts: 7,381
Quote:
Originally Posted by cmat043 View Post
The Ballad of my Failed Fuel Pump:

Chorus: I park my car on Friday night.
I start my car for the first time on Monday morning.
I get the "LOW OIL PRESSURE - TURN OFF ENGINE"
I have my car towed to dealership.
Dealership cannot duplicate problem.
The car runs with oil pressure 10-15 up to 50 psi all week.

The service manager told me that the relief valve sticks in these cars, but he's never heard of this happening????

(Chorus)

They cannot give me a loaner because I had it in there for 2 whole weeks with them trying to diagnose the problem.

So, I started a case with GM. Hopefully something gets done, because I sure don't want it to get to the point where.... well I don't want to say it because it might come true.

(Chorus)

That's right, I've had it in there 3X and they still won't do anything. I'm screwed
just let the engine blow, then tell them to fix it.
__________________
2010 camaro cammed- sold
2013 E92 V8 M3 DCT ZCP
2015 C7 Z51
mikeSS is offline   Reply With Quote
Old 07-01-2013, 05:50 PM   #125
Secret Squirrel
 
Secret Squirrel's Avatar
 
Drives: 1965 Chevelle Malibu
Join Date: Jan 2012
Location: San Antonio, Tx
Posts: 471
I literally just had this happen 10 minutes ago. 20k miles on the car. This is BS! Trying to get this figured out now.
__________________
Secret Squirrel is offline   Reply With Quote
Old 07-01-2013, 06:56 PM   #126
Secret Squirrel
 
Secret Squirrel's Avatar
 
Drives: 1965 Chevelle Malibu
Join Date: Jan 2012
Location: San Antonio, Tx
Posts: 471
Thieves at the dealership want to charge me $1700 to replace an oil pump that they know was already faulty. Unbelievable. I just made an appointment at the best performance shop in town here to have it replaced with a ported pump for $600 out the door.
__________________
Secret Squirrel is offline   Reply With Quote
Old 07-04-2013, 06:24 PM   #127
Secret Squirrel
 
Secret Squirrel's Avatar
 
Drives: 1965 Chevelle Malibu
Join Date: Jan 2012
Location: San Antonio, Tx
Posts: 471
So here's a question...What if it isn't the sensor, and it isn't the pump? What other possibilities?
__________________
Secret Squirrel is offline   Reply With Quote
Old 07-14-2013, 03:48 AM   #128
Gen5SS
 
Drives: 2010 SS/RS 6 Spd Manual IOM
Join Date: Aug 2009
Location: North Las Vegas
Posts: 150
Add me to the list, happened on startup in the garage thankfully.
__________________
2010 2SS/RS, 417 stroker, 4.0 Callies crank and rods, JRE pistons w/hellfire nitrous top rings, Kooks 1 7/8 LT, Kooks 3" Exhaust, CAI Intake and Scoop, Cam SullivanGM W/ Hardened PR, Stock Heads. Dual Springs, Mcleod RXT Clutch, Hurst LL W/ Cruise Momentary, GM 3.91 gears, Nitrous Outlet direct port 200 shot, Dedicated Fuel Cell(C16), LNC2000 and NOS Mini controller, BMR suspension w/Bushings, Pfadt Drop, Pfadt Diff Bushings, 1400hp DSS Axles, DSS driveshaft, Solid Engine Mounts, Razzi Body Kit, Speedhut Gauges,T-REX Phantom Grills (Black) 533RWHP/500RWTQ N/A, 724RWHP/816RWTQ 200 Shot
Gen5SS is offline   Reply With Quote
Old 07-16-2013, 10:54 PM   #129
Gen5SS
 
Drives: 2010 SS/RS 6 Spd Manual IOM
Join Date: Aug 2009
Location: North Las Vegas
Posts: 150
I installed the melling 10296 and I now have better oil pressure than I did before, they really should fix the sticking pressure relief valve issue on these pumps.
__________________
2010 2SS/RS, 417 stroker, 4.0 Callies crank and rods, JRE pistons w/hellfire nitrous top rings, Kooks 1 7/8 LT, Kooks 3" Exhaust, CAI Intake and Scoop, Cam SullivanGM W/ Hardened PR, Stock Heads. Dual Springs, Mcleod RXT Clutch, Hurst LL W/ Cruise Momentary, GM 3.91 gears, Nitrous Outlet direct port 200 shot, Dedicated Fuel Cell(C16), LNC2000 and NOS Mini controller, BMR suspension w/Bushings, Pfadt Drop, Pfadt Diff Bushings, 1400hp DSS Axles, DSS driveshaft, Solid Engine Mounts, Razzi Body Kit, Speedhut Gauges,T-REX Phantom Grills (Black) 533RWHP/500RWTQ N/A, 724RWHP/816RWTQ 200 Shot
Gen5SS is offline   Reply With Quote
Old 11-03-2013, 01:22 PM   #130
Chupacabra
 
Drives: 2010 Camaro SS
Join Date: Nov 2013
Location: Baton Rouge
Posts: 1
Just happened to my 2010 Camaro SS for the third time friday. First two times it said no oil pressure it was under warranty, now this third time it is doing the exact same thing, but I'm past the bumper to bumper warranty. I hope they do the right thing and repair it free of charge as this is a known issue. Fingers crossed, I'll find out Monday morning.
Chupacabra is offline   Reply With Quote
Old 11-03-2013, 02:53 PM   #131
POWERFREAK
I.AM.
 
POWERFREAK's Avatar
 
Drives: 2010 2SS/RS/M6
Join Date: Oct 2008
Location: NY
Posts: 2,400
Quote:
Originally Posted by Chupacabra View Post
Just happened to my 2010 Camaro SS for the third time friday. First two times it said no oil pressure it was under warranty, now this third time it is doing the exact same thing, but I'm past the bumper to bumper warranty. I hope they do the right thing and repair it free of charge as this is a known issue. Fingers crossed, I'll find out Monday morning.
It should be covered under your drivetrain warranty.
__________________
2010 R6P-2SS/RS/LS3 - IBM w/ silver rally stripes, FOR SALE!

NY5thgen.com
POWERFREAK is offline   Reply With Quote
Old 11-03-2013, 07:12 PM   #132
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,978
Quote:
Originally Posted by Chupacabra View Post
Just happened to my 2010 Camaro SS for the third time friday. First two times it said no oil pressure it was under warranty, now this third time it is doing the exact same thing, but I'm past the bumper to bumper warranty. I hope they do the right thing and repair it free of charge as this is a known issue. Fingers crossed, I'll find out Monday morning.
Chupacabra,

Apologies to hear of the oil pressure concerns with your Camaro. I'd appreciate any updates you can provide regarding your service visit. If additional assistance is needed, feel free to let me know.

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
Old 04-19-2014, 11:44 PM   #133
tonyG
 
Drives: 2011 2SS/RS
Join Date: Sep 2013
Location: Kentucky
Posts: 71
I'm here to join the failed oil pump club! Really can't believe that at 12,500mi I'm already having problems. First the steering pump at 10k miles, now the oil pump issue. My car is stuck at a friends house and I won't be able to do anything until Monday morning. Drove it all day and seemed fine (although I wasn't laying attention to the oil psi) came home for about an hr started it up and I get the message "low oil pressure shut off engine" turned it off checked the oil and it was fine so I started it again and it ran fine but it seemed like the oil psi was slighter lower than normal. Got to my friends house, hung out for a few hrs and when I started it it gave me the message to shut down again. Left it alone and got a ride home...
tonyG is offline   Reply With Quote
Old 04-20-2014, 10:13 AM   #134
Genersis 1000
 
Drives: 2015 2LT/RS LFX Velvet Blue
Join Date: Apr 2014
Location: winslow maine
Posts: 7
what engines are having oil pump problem. Is it the V6
Genersis 1000 is offline   Reply With Quote
Old 04-20-2014, 01:35 PM   #135
tonyG
 
Drives: 2011 2SS/RS
Join Date: Sep 2013
Location: Kentucky
Posts: 71
Quote:
Originally Posted by Genersis 1000 View Post
what engines are having oil pump problem. Is it the V6
I believe mainly the v8s. Based on a majority of post 10-11' models seem to be the issue I believe
tonyG is offline   Reply With Quote
Old 04-22-2014, 02:10 AM   #136
WHAMMO

 
WHAMMO's Avatar
 
Drives: LS2 Fbody
Join Date: Apr 2012
Location: Canada
Posts: 1,514
They all have this problem; 2010-2013!! Corvette and Camaro. I read on a couple of forums ans bunch of 2013' had the no oil pressure issue. Its a serious problem. Melling oil pump FTW!!!
__________________
4th Gen SS/LS2 SB/LS3 heads/N20
WHAMMO is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GM's OLM & synthetic oils. duder4thgen Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 1 03-24-2010 12:37 PM
The BEST Break for a new car. "very long" Darin Morgan General Automotive + Other Cars Discussion 346 02-04-2010 07:49 PM
Stock Injectors vs Magnuson Kit Injectors Mark-HD Forced Induction - V8 24 01-27-2010 09:04 PM
Camaro ls3 news...true or false? Dark Knight Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 74 06-05-2008 06:29 PM


All times are GMT -5. The time now is 11:40 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.