Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
B&M
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 06-03-2013, 08:46 PM   #15
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 9,248
Quote:
Originally Posted by ICT USA-1 View Post
I just got back from my dealer (Davis-Moore in Wichita, Ks). I took my 2013 2LT/RS in because the dash was starting to bubble above the radio.

What a horrible service department. They had my car for seven and a half hours and then called and said it was done. I walked in and sat in the car for less than a minute and found that the glue was still not sticking.

I went back inside and talked to the service advisor. I showed it to him and all he could say was "I don't know what to do, maybe Chevrolet will come out with a TSB".

So after spending over $30000 on a new car and having it less than two months, I am supposed to just wait for Chevrolet to come out with a TSB?

It's bad enough that they did not check to see if it was really fixed, but then to tell me to wait for a TSB. I guess I will need to find a new dealership.
Oh no!

Sorry to hear about the dash. Please feel free to send me your VIN and the name of the dealership. I may be able to look into this and see what can be done. Looking forward to your contact.

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
Old 06-03-2013, 08:51 PM   #16
Ladykiller
 
Drives: 2013 Camaro ZL1
Join Date: May 2013
Location: Illinois
Posts: 92
I'll never go back to Davis-Moore either. Their finance department has SHADY characters and will try to screw you over the best they can.
Ladykiller is offline   Reply With Quote
Old 06-03-2013, 09:04 PM   #17
MR.Sarge
 
MR.Sarge's Avatar
 
Drives: 2015 2SS/RS 1LE
Join Date: Nov 2011
Location: Windsor, ON
Posts: 467
Quote:
Originally Posted by ICT USA-1 View Post
Mine is not that bad and I can live with it, but shouldn't have to.
I am not sure you can see it from the picture, but if you push down on it you can feel the dash move and when you let up it sounds like the glue is not sticking.

With all of the issues on the 2012's you would think that they would have resolved this.

Attachment 518663
Mine is doing the same thing and in the same area as well... driver side corner of the infotainment screen. Bringing mine in with a printout of the TSB so they can replace it. can clearly see it when you press it down and can also hear the glue release on mine.
MR.Sarge is offline   Reply With Quote
Old 06-04-2013, 12:18 PM   #18
Dznts
Anabolic Connoisseur
 
Dznts's Avatar
 
Drives: Sold - Blown Camaro 2SS/RS LS3
Join Date: Sep 2010
Location: Oklahoma
Posts: 22,061
http://www.camaro5.com/forums/showthread.php?t=215707 there is a new peice that will resolve this issue. just had mine replace about a month ago and have had no issues
__________________
Dznts is offline   Reply With Quote
Old 06-05-2013, 12:58 PM   #19
ICT USA-1
 
ICT USA-1's Avatar
 
Drives: '13 Camaro 2LT/RS
Join Date: Apr 2013
Location: Wichita, Ks
Posts: 17
Quote:
Originally Posted by Dznts View Post
http://www.camaro5.com/forums/showthread.php?t=215707 there is a new peice that will resolve this issue. just had mine replace about a month ago and have had no issues
How long did it take for the glue to setup on yours? I took it to a different dealership, and they are saying that the glue has not setup yet. It was done two days ago. I would think it would have to be setup by now.
ICT USA-1 is offline   Reply With Quote
Old 06-05-2013, 04:38 PM   #20
Dznts
Anabolic Connoisseur
 
Dznts's Avatar
 
Drives: Sold - Blown Camaro 2SS/RS LS3
Join Date: Sep 2010
Location: Oklahoma
Posts: 22,061
looks like they dont know what they are talking about. there should be no bubbles no matter what.
__________________
Dznts is offline   Reply With Quote
Old 07-06-2013, 06:32 PM   #21
Camero5
Hide! My wife's coming!
 
Camero5's Avatar
 
Drives: 2013 Chevrolet Camaro ZL1
Join Date: Jun 2011
Location: Las Colinas, TX
Posts: 1,443
Got mine replaced today with no issues or hassles. They mentioned a TSB on it and had the part in stock. Took them a few hours but looks so much better than it did before. Mine was coming apart around the radio and bubbles on top. They only replaced leather panel and not the entire dash like some mentioned early in the year
__________________
2013 Camaro ZL1 Convertible CRT - 630 RWHP / 620 RWTQ - ADM Performance Built/Tuned - ZL-700 Package - LS9 CAM - Lingenfelter CNC Ported Heads - Stainless Power Headers
Camero5 is offline   Reply With Quote
Old 07-06-2013, 08:49 PM   #22
skywarp
 
skywarp's Avatar
 
Drives: 2010 camaro transformers edition
Join Date: Dec 2012
Location: clinton tn
Posts: 77
my dash was splitting where the passenger air bag is I took it to the dealer and asked them to good will the dash a week later I had a brand new dash installed. they should good will the dash replacement it will not cost you any thing but a full day with out your Camaro.
__________________
SSGT USAF
skywarp is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.