Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Circle-D
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-05-2013, 01:43 PM   #15
two_wheel_mayhem
Would rather be riding
 
two_wheel_mayhem's Avatar
 
Drives: No car no more
Join Date: Jul 2009
Location: Indiana
Posts: 2,751
I believe it is the traction control too. It always cuts the throttle for longer than it needs to.
__________________
No dog in this fight anymore.
5th Gen owner 2009-2016.
two_wheel_mayhem is offline   Reply With Quote
Old 05-06-2013, 08:37 PM   #16
ccbrian
 
ccbrian's Avatar
 
Drives: Rally Yellow 2011 SS Camaro
Join Date: May 2013
Location: United States
Posts: 2
Perhaps do you have a custom air intake recently installed, if so sometimes it can feel a lot like you've lost power. Or perhaps your air intake has gotten pretty dirty and you should clean it.
ccbrian is offline   Reply With Quote
Old 07-08-2013, 09:29 AM   #17
Matster

 
Matster's Avatar
 
Drives: 2010 2SS/RS IOM/IOM #3625
Join Date: Jun 2008
Location: Greater Toronto Area
Posts: 1,896
Most likely the traction control. Had mine into the shop a few weeks back as I was concerned it might be a fuel issue, as in not getting enough. Most of the time on the street I leave all the nanny stuff turned on so when the guy sitting on my shoulder with the horns says "do it" the car has the halo and says no.

Now this isn't a subtle loss of power, this is a bang your head between the head rest and the steering wheel thing, violent. Usually when it starts making peak torque (3750rpm/737 ft lbs of torque) and the wheels start spinning.

I took it to my tuner/shop and we had already somewhat come to the conclusion that the issue was the TC. He took it out and data logged it and it did the same thing to him (thank God, not a driver error issue). He then tried it with the TC off and had no issues with power loss.
__________________
666 EVIL RWHP BUILT AND TUNED BY SHIFTED PERCEPTIONS INC.(SPi)

416 Forged Stroker, E-Force Supercharger, Blower Cam, Rotofab CAI, Stainless Works 2" LT Headers and 3" Exhaust, LPE ZR1 Twin Disc Clutch, DSS 1400 HP Axles, Pfadt Performance Kit Stage 3.
Matster is offline   Reply With Quote
Old 07-08-2013, 01:46 PM   #18
tk3c-pyce
 
Drives: 2010 Camaro SS
Join Date: Oct 2010
Location: Bulgaria
Posts: 20
If you didn't get any error msgs like "Engine power reduced", then it would be the traction control. If you have a DTC light, then it's another story.
tk3c-pyce is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:25 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.