Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics


Reply
 
Thread Tools
Old 07-12-2013, 07:27 AM   #155
Hercules
 
Drives: 13 ZL1 1091, 04 Ram 2500, 12 CX9
Join Date: Jul 2012
Location: Lancaster, PA
Posts: 559
Quote:
Originally Posted by Normagene View Post
I noticed some of the hoses have check valves in them, does the ZL1 need the two hoses with the check valves? Just wondering, the hoses I received Do Not have the check valves.
the check valves on the RX cans are located in the top of the can. You probably received one piece of 3/8 fuel line and it a cut to fit piece. My only problem was getting the fitting that you ordered from Jegs. I ended up getting mine from advance auto for 2.99 . I just wish the "T" fitting on the roto-fab would've had 3/8 on one end and 1/2 on the other.
Hercules is offline   Reply With Quote
Old 07-12-2013, 03:51 PM   #156
Normagene


 
Normagene's Avatar
 
Drives: 2013 Ashen Gray M6 ZL1
Join Date: Sep 2012
Location: South Eastern, Mass
Posts: 2,585
The install is done! So here's how it all went. Got the wrong bracket, but it didn't matter because I didn't install to the radiator shroud. Instead I used the threaded hole (there are two, I used the one furthest to the left) in the crossbeam below the radiator. Placed the can in the highest bracket position so I have plenty of room underneath to open/close the drain. Also it didn't come with enough hose so I needed an additional two feet of 3/8th and I also had to get a one foot piece of 1/2 inch hose since the Roto Fab "T" is 1/2 inch. Plus a hose connector reducer 1/2 to 3/8th which was another six bucks from JEGs. So like an additional $12 to do the install

Once I had everything I needed, it went in super easy. Probably like 15 minutes. Here's a few pictures, I wanted everything to show as little as possible. Oh, I still need two Black Zip Ties. Had to use white ones, that's all I had on hand, but will replace those ASAP.
Name:  ImageUploadedByTapatalk1373662277.978270.jpg
Views: 550
Size:  141.6 KB
Name:  ImageUploadedByTapatalk1373662287.099187.jpg
Views: 556
Size:  203.5 KB
Name:  ImageUploadedByTapatalk1373662297.181983.jpg
Views: 549
Size:  204.2 KB
Name:  ImageUploadedByTapatalk1373662305.886951.jpg
Views: 555
Size:  198.2 KB
Normagene is offline   Reply With Quote
Old 08-29-2013, 07:42 AM   #157
Normagene


 
Normagene's Avatar
 
Drives: 2013 Ashen Gray M6 ZL1
Join Date: Sep 2012
Location: South Eastern, Mass
Posts: 2,585
Took my ZL1 in yesterday for its second Oil Change at the dealership. Had my catch can on for 500 miles or so, opened the drain and Not One Drop. NOTHING, Nada, Zip, the drain hose still looks brand new. I was expecting a few drops at least, but nothing came out. Any opinions? Just not enough mileage on her, I know 500 ain't much, but I thought I'd at least get a drop or two or something starting to make its way down the hose??? Oh well, next oil change if I get nothing I'll know Houston We Have A Problem!


Sent from my iPad using Tapatalk - now Free
Normagene is offline   Reply With Quote
Old 08-29-2013, 08:09 AM   #158
bumblebeecamaro
Car Lover By Nature
 
Drives: Mini Cooper S
Join Date: Dec 2009
Location: Central FL
Posts: 2,302
Quote:
Originally Posted by Normagene View Post
Took my ZL1 in yesterday for its second Oil Change at the dealership. Had my catch can on for 500 miles or so, opened the drain and Not One Drop. NOTHING, Nada, Zip, the drain hose still looks brand new. I was expecting a few drops at least, but nothing came out. Any opinions? Just not enough mileage on her, I know 500 ain't much, but I thought I'd at least get a drop or two or something starting to make its way down the hose??? Oh well, next oil change if I get nothing I'll know Houston We Have A Problem!


Sent from my iPad using Tapatalk - now Free
you should have had something in the can if it's working like it's suppose to. I've got the Moroso can and I opened it after only 50 miles and this is what the can already caught. I would imagine 500 miles would bring plenty more.

__________________
bumblebeecamaro is offline   Reply With Quote
Old 08-29-2013, 10:05 AM   #159
ZL1Reaper
 
ZL1Reaper's Avatar
 
Drives: '13 Silver Ice Metallic ZL1
Join Date: Jul 2012
Location: Carlsbad, CA
Posts: 326
Quote:
Originally Posted by Normagene View Post
Took my ZL1 in yesterday for its second Oil Change at the dealership. Had my catch can on for 500 miles or so, opened the drain and Not One Drop. NOTHING, Nada, Zip, the drain hose still looks brand new. I was expecting a few drops at least, but nothing came out. Any opinions? Just not enough mileage on her, I know 500 ain't much, but I thought I'd at least get a drop or two or something starting to make its way down the hose??? Oh well, next oil change if I get nothing I'll know Houston We Have A Problem!


Sent from my iPad using Tapatalk - now Free
It depends how hard you've driven your car on those 500 miles.
I only had a little bit in the can after two drag races. And so far, since I bought my can (over 6000 miles ago), I have not reached 1 oz of oil yet.
ZL1Reaper is offline   Reply With Quote
Old 08-30-2013, 06:36 PM   #160
Normagene


 
Normagene's Avatar
 
Drives: 2013 Ashen Gray M6 ZL1
Join Date: Sep 2012
Location: South Eastern, Mass
Posts: 2,585
Quote:
Originally Posted by bumblebeecamaro View Post
you should have had something in the can if it's working like it's suppose to. I've got the Moroso can and I opened it after only 50 miles and this is what the can already caught. I would imagine 500 miles would bring plenty more.

That's a nice can, like the way you can open it up. What's the rest of it look like, and can you see the guts of it? My RX can is solid, screw valve with a drain hose dead center bottom. Maybe I shoulda blown some air into it in case it was clogged up or use my small shop vac and see if it can pull anything out.


Sent from my iPad using Tapatalk - now Free
Normagene is offline   Reply With Quote
Old 08-30-2013, 06:53 PM   #161
TomF1
 
TomF1's Avatar
 
Drives: 2013 CRT ZL1
Join Date: Jul 2012
Location: Whitby, Ontario
Posts: 237
Moroso

Quote:
Originally Posted by Normagene View Post
Took my ZL1 in yesterday for its second Oil Change at the dealership. Had my catch can on for 500 miles or so, opened the drain and Not One Drop. NOTHING, Nada, Zip, the drain hose still looks brand new. I was expecting a few drops at least, but nothing came out. Any opinions? Just not enough mileage on her, I know 500 ain't much, but I thought I'd at least get a drop or two or something starting to make its way down the hose??? Oh well, next oil change if I get nothing I'll know Houston We Have A Problem!
I have the Moroso can. Put it on about 2,500 km ago and today I did my 2nd oil change @ 7,288km

I got less than an ounce, maybe a out 3/4 ounce
I figured that's good news
1. It works 😄
2. I'll only need to drain it every oil change
TomF1 is offline   Reply With Quote
Old 08-30-2013, 10:02 PM   #162
OldScoolCamaro


 
Drives: Camaro's, always have, always will.
Join Date: Oct 2010
Location: Home of the brave
Posts: 4,851
....a catch can that has three fittings, such as the RX ZL1 product....the center fitting is the engine block oil source <valley>, the outside fittings have the check valves and are the vacuum sources from the intake fitting on the SC and CAI assembly T fitting. Boy I messesd that all up initially. I'll just give up trying to explain stuff....LOL.
__________________
In Scott We Trust...all others must show proof.

Last edited by OldScoolCamaro; 09-09-2013 at 05:58 PM.
OldScoolCamaro is offline   Reply With Quote
Old 08-31-2013, 07:56 AM   #163
Normagene


 
Normagene's Avatar
 
Drives: 2013 Ashen Gray M6 ZL1
Join Date: Sep 2012
Location: South Eastern, Mass
Posts: 2,585
Quote:
Originally Posted by OldScoolCamaro View Post
....a catch can that has three fittings, such as the RX ZL1 product....the center fitting is the engine vacuum source <intake manifold>, the outside <outboard> fittings are the supply side fittings, meaning, they have the check valves and draw the oil into the can from the engine block and CAI assembly.
Not sure what that means? 500 miles on my can and not a drop of oil, nothing at all came out. I have the three valve RX can, and I did my connections just like in this diagram.


Sent from my iPad using Tapatalk - now Free
Normagene is offline   Reply With Quote
Old 08-31-2013, 08:51 AM   #164
Cybeast
 
Cybeast's Avatar
 
Drives: 2013 Victory Red ZL1 #1562
Join Date: Jan 2013
Location: Iowa
Posts: 75
Is the center fitting on the can on the lower fitting on engine?
Cybeast is offline   Reply With Quote
Old 08-31-2013, 08:58 AM   #165
jbotta

 
jbotta's Avatar
 
Drives: Camaro ZL1
Join Date: Jan 2012
Location: Dyer, IN
Posts: 1,132
Quote:
Originally Posted by Cybeast View Post
Is the center fitting on the can on the lower fitting on engine?
Yes, It sure is.
jbotta is offline   Reply With Quote
Old 09-08-2013, 08:45 PM   #166
98on20s
 
Drives: 2013 ZL1
Join Date: Mar 2010
Location: Sonoma
Posts: 61
I finally received my dual catch can last week that I had AN fittings put on from RX. I have a Roto-Rab intake system on my 2013 ZL1. Is there any photos of anyone has a dual catch can set up with Roto-Fab? I need to know how I hook up the last hose to the intake. I have a dual house bib connector for the vacuum connection from Roto-Fab intake kit. Do I need a special fitting to attach the AN hose to the intake vacuum inlet?
98on20s is offline   Reply With Quote
Old 09-08-2013, 08:57 PM   #167
OldScoolCamaro


 
Drives: Camaro's, always have, always will.
Join Date: Oct 2010
Location: Home of the brave
Posts: 4,851
Quote:
Originally Posted by Normagene View Post
Took my ZL1 in yesterday for its second Oil Change at the dealership. Had my catch can on for 500 miles or so, opened the drain and Not One Drop. NOTHING, Nada, Zip, the drain hose still looks brand new. I was expecting a few drops at least, but nothing came out. Any opinions? Just not enough mileage on her, I know 500 ain't much, but I thought I'd at least get a drop or two or something starting to make its way down the hose??? Oh well, next oil change if I get nothing I'll know Houston We Have A Problem!


Sent from my iPad using Tapatalk - now Free
....no oil in mine after 200 miles.
Quote:
Originally Posted by bumblebeecamaro View Post
you should have had something in the can if it's working like it's suppose to. I've got the Moroso can and I opened it after only 50 miles and this is what the can already caught. I would imagine 500 miles would bring plenty more.
...that depends on alot.
Quote:
Originally Posted by Normagene View Post
Not sure what that means? 500 miles on my can and not a drop of oil, nothing at all came out. I have the three valve RX can, and I did my connections just like in this diagram.


Sent from my iPad using Tapatalk - now Free
...the center fitting on the catch can, the one in the middle is, the engine block. The outboard ones have the check valves and go to the SC and CAI. I fixed my first thread. Boy did I mangle words up....sorry for the confusion! LOL.
__________________
In Scott We Trust...all others must show proof.

Last edited by OldScoolCamaro; 09-09-2013 at 05:56 PM.
OldScoolCamaro is offline   Reply With Quote
Old 09-08-2013, 09:50 PM   #168
98on20s
 
Drives: 2013 ZL1
Join Date: Mar 2010
Location: Sonoma
Posts: 61
Is there photos where I connect the three hoses?
98on20s is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.