Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Rick@Livernois
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 07-14-2013, 10:58 AM   #171
jsharp
NOW CAMMED & SUPERCHARGED
 
jsharp's Avatar
 
Drives: 2010 Camaro 2SS/RS Black w/ IOM
Join Date: Oct 2008
Location: Ar
Posts: 2,329
I never fixed mine. I just pressure wash time to time and keep eye on oil. The way I see it is if there is never any on the ground in my shop and oil level is good then it cannot be to harmful. I will get mine fixed when I go with a different block. I do not trust the dealer to take my stuff apart and chase an oil leak. Mine has oil on both sides of pan and on rear main area and film on the front of trans from leaking. So who knows where it is actually coming from but its slow!
__________________
Livernois Motorsports: Maggie 2300 7psi, Livernois 2C cam/L99 to LS3 Conversion, Ported TB, Rotofab w/adm race scoop, adm trans cooler,Kooks headers no cats, Kooks 3" exhaust. METCO breather. Precision 2400 Vigilante TC. Eibach Lowering Springs & Swaybars. BMR Trailing arms, BMR Rear Cradle Bushings, BMR Toe Rods, BMR Differential bushings. Vossen CV3 20's w/ 305 Nitto 555R@25psi. Zl1 front bumper. OE Zl1 Hood and matte black insert. 556RWHP/500RWTQ L99
jsharp is offline   Reply With Quote
Old 07-15-2013, 12:24 PM   #172
nyadk5thgen
 
nyadk5thgen's Avatar
 
Drives: 2010 2SS/RS LS3 M6 JRE cam & tune
Join Date: Mar 2013
Location: Adirondack region, NY
Posts: 82
Quote:
Originally Posted by jsharp View Post
I never fixed mine. I just pressure wash time to time and keep eye on oil. The way I see it is if there is never any on the ground in my shop and oil level is good then it cannot be to harmful. I will get mine fixed when I go with a different block. I do not trust the dealer to take my stuff apart and chase an oil leak. Mine has oil on both sides of pan and on rear main area and film on the front of trans from leaking. So who knows where it is actually coming from but its slow!
I with ya on that.....nothing on the floor......when i go under the car i give it a good wipe. Not letting the dealer touch it as it isnt worth the worry and the headache of what could happen at the dealer. to minor, i leave it alone!
nyadk5thgen is offline   Reply With Quote
Old 07-15-2013, 02:31 PM   #173
Blackkaz04
 
Drives: In the market
Join Date: Sep 2010
Location: Tucson
Posts: 622
Quote:
Originally Posted by nyadk5thgen View Post
I with ya on that.....nothing on the floor......when i go under the car i give it a good wipe. Not letting the dealer touch it as it isnt worth the worry and the headache of what could happen at the dealer. to minor, i leave it alone!
Name:  image.jpg
Views: 550
Size:  94.7 KB

Where do you guys think its leaking from now....dealer replaced the oil cooler gasket in the line and tightened the oil cooler bolts....
Blackkaz04 is offline   Reply With Quote
Old 07-15-2013, 02:32 PM   #174
Blackkaz04
 
Drives: In the market
Join Date: Sep 2010
Location: Tucson
Posts: 622
This is in 3 days time
Blackkaz04 is offline   Reply With Quote
Old 07-15-2013, 03:17 PM   #175
nyadk5thgen
 
nyadk5thgen's Avatar
 
Drives: 2010 2SS/RS LS3 M6 JRE cam & tune
Join Date: Mar 2013
Location: Adirondack region, NY
Posts: 82
Quote:
Originally Posted by Blackkaz04 View Post
Attachment 533388

Where do you guys think its leaking from now....dealer replaced the oil cooler gasket in the line and tightened the oil cooler bolts....
hard to tell from that pic but if not from the oil cooler itself (which sometimes they replace the cooler to get it to stop leaking) , its then would be coming from the back upper part of the pan and running down which you cant even see with the tranny in place
nyadk5thgen is offline   Reply With Quote
Old 07-16-2013, 06:48 PM   #176
Blackkaz04
 
Drives: In the market
Join Date: Sep 2010
Location: Tucson
Posts: 622
It's at the dealer. Should know something by lunchtime tomorrow
Blackkaz04 is offline   Reply With Quote
Old 07-17-2013, 02:55 PM   #177
Blackkaz04
 
Drives: In the market
Join Date: Sep 2010
Location: Tucson
Posts: 622
The say its coming from the oil pan....they are going to replace it tomorrow. I hope everything comes apart and goes back together!!! Nervous...
Blackkaz04 is offline   Reply With Quote
Old 07-17-2013, 03:48 PM   #178
nyadk5thgen
 
nyadk5thgen's Avatar
 
Drives: 2010 2SS/RS LS3 M6 JRE cam & tune
Join Date: Mar 2013
Location: Adirondack region, NY
Posts: 82
Quote:
Originally Posted by Blackkaz04 View Post
The say its coming from the oil pan....they are going to replace it tomorrow. I hope everything comes apart and goes back together!!! Nervous...
May the force be with you Obi-one
nyadk5thgen is offline   Reply With Quote
Old 07-31-2013, 07:47 PM   #179
JNDS'2010
 
Drives: 2010 CGM L99 1SS/RS
Join Date: Jul 2013
Location: HERMITAGE, PA.
Posts: 6
Hi everyone new to the forum, I think I have the same problem as everyone else here. Just contemplating taking it to the dealership as well. Mine only has 7,700 miles. Love my car but not to happy about an oil leak so soon.
JNDS'2010 is offline   Reply With Quote
Old 07-31-2013, 11:20 PM   #180
Red Jewel RS

 
Red Jewel RS's Avatar
 
Drives: 2013 Camaro ZL1 Blue Ray Metallic
Join Date: Apr 2010
Location: Billings, MT
Posts: 795
Sorry to hear about your oil leak but, Welcome to Camaro5!!
Hope you get it fixed.
__________________
Red Jewel RS is offline   Reply With Quote
Old 08-01-2013, 09:36 AM   #181
IrocJack


 
IrocJack's Avatar
 
Drives: 2010 2LT/RS RJT
Join Date: Nov 2010
Location: Maryland
Posts: 2,702
I take it this is a V8 problem?
IrocJack is offline   Reply With Quote
Old 08-01-2013, 11:12 AM   #182
Hannibal
 
Hannibal's Avatar
 
Drives: Camaro SS & ZL1
Join Date: Sep 2011
Location: Southeast USA
Posts: 527
Quote:
Originally Posted by IrocJack View Post
I take it this is a V8 problem?
For the most part, yes. The V6 guys/gals get the timing chain/oil burning issue instead.
Hannibal is offline   Reply With Quote
Old 08-01-2013, 09:09 PM   #183
JNDS'2010
 
Drives: 2010 CGM L99 1SS/RS
Join Date: Jul 2013
Location: HERMITAGE, PA.
Posts: 6
Thanks for the welcome Red Jewel RS. Just tightened up all the bolts on the oil cooler and all the oil pan bolts that I could get too. Took in for a road test for about 25 to 30 min. I'll check it tomorrow after I get out of work to see if it did the trick. Keeping my fingers crossed cause I really would rather not take it to the dealership.
JNDS'2010 is offline   Reply With Quote
Old 08-14-2013, 02:12 PM   #184
HP_atTheWheels
 
HP_atTheWheels's Avatar
 
Drives: 06 Vette
Join Date: Oct 2012
Location: FL
Posts: 231
Having this issue on my 2010 SS, I came home after being out of town for a week and noticed the oil spots under the car. She has been at the dealership since Monday, they have replaced the line, and the gasket. I was supposed to be picking her up today, instead I just got a call saying she is still leaking and they need more time to find out what's wrong. At least I can be thankful they are being thorough. I was told it wasn't covered under warranty. They told me they called GM though and GM said if I paid $100.00 flat fee they would eat the rest of the cost. Any of you had a similar situation with the charges?
HP_atTheWheels is offline   Reply With Quote
Old 08-14-2013, 06:04 PM   #185
JNDS'2010
 
Drives: 2010 CGM L99 1SS/RS
Join Date: Jul 2013
Location: HERMITAGE, PA.
Posts: 6
Sorry to here your having the same problem HP. I just dropped mine off at the dealership today. won't hear anything from them til tomorrow they said. They told me mine would be covered under the powertrain warranty.
JNDS'2010 is offline   Reply With Quote
Old 08-14-2013, 07:04 PM   #186
HP_atTheWheels
 
HP_atTheWheels's Avatar
 
Drives: 06 Vette
Join Date: Oct 2012
Location: FL
Posts: 231
Quote:
Originally Posted by JNDS'2010 View Post
Sorry to here your having the same problem HP. I just dropped mine off at the dealership today. won't hear anything from them til tomorrow they said. They told me mine would be covered under the powertrain warranty.
Thanks for the info. I thought it should be covered under the powertrain as well. I had them run my vin and the bumper to bumper expired Sep of last year but my power train is still good. Think I will call GM myself and see what they say. Good luck with yours, hopefully they get it fixed and right the first time.
HP_atTheWheels is offline   Reply With Quote
Old 08-14-2013, 10:12 PM   #187
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,978
HP_atTheWheels,

If you would like for us to look into your warranty coverage, we're happy to do so. Please send us the last 8 digits of your VIN and we'll get you more details.

Sarah (Assisting William)
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY: Camaro Oil Change adub4185 Camaro DIY & HOW-TO instructions & discussions 180 04-23-2014 07:11 PM
best synthetic oil to use hollywoodjose Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 130 01-26-2014 09:51 AM
GM's OLM & synthetic oils. duder4thgen Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 1 03-24-2010 12:37 PM
Aftermarket cooling The_Stache Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 6 01-11-2010 06:40 AM
Major U.S. oil source is tapped KILLER74Z28 Off-topic Discussions 32 10-30-2007 10:47 AM


All times are GMT -5. The time now is 05:12 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.