Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
HRE Wheels
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications


Reply
 
Thread Tools
Old 07-17-2013, 09:04 PM   #15
BaylorCamaro
Track > 1/4 Mile
 
BaylorCamaro's Avatar
 
Drives: 2016 C7 Z51
Join Date: Sep 2009
Location: League City, TX
Posts: 6,053
Quote:
Originally Posted by Joebot8484 View Post
I installed a Roto-Fab and JBA Mid pipes with high flow cats and made 545 hp on the dyno with no tune. I'm currently happy.
Very nice, I'll need to look into this.
__________________
BaylorCamaro is online now   Reply With Quote
Old 07-17-2013, 09:28 PM   #16
BaylorCamaro
Track > 1/4 Mile
 
BaylorCamaro's Avatar
 
Drives: 2016 C7 Z51
Join Date: Sep 2009
Location: League City, TX
Posts: 6,053
Quote:
Originally Posted by NVmyZL1 View Post
If I were you, I'd spend my money taking a HPDE instruction course before making mods. Unless you have previous experience with a high horsepower car, going from a v6 to a zl1 is likely a recipe for disaster even with all the nannies.
Good point and typically I would agree. However the V6 I had was around 360 rwhp with far less sophisticated suspension than the Z. I've also driven a track prep GT3RS and Ferrari F430, granted the Ferrari I haven't really "raced" just driven hard.

So the Z is the highest hp vehicle I've driven but not the only performance oriented vehicle.

I'm not looking for a huge power adder right now, just something that will set it apart from a completely stock ZL1.

Currently I'm thinking a Roto-fab CAI with the intake box paint matched and carbon fiber tube. Should look good.

I'd don't like spending money on mods that don't some sort of performance value (hp, braking, weight reduction, etc). So a decent looking CAI seems like a happy medium for the first mod.
__________________
BaylorCamaro is online now   Reply With Quote
Old 07-17-2013, 10:05 PM   #17
white ZL1

 
Drives: none
Join Date: Aug 2011
Location: DFW area
Posts: 1,846
Quote:
Originally Posted by BaylorCamaro View Post
I think I've read somewhere that it's around 135* ?
It's actually at 104*!

white ZL1 is offline   Reply With Quote
Old 07-17-2013, 10:36 PM   #18
BaylorCamaro
Track > 1/4 Mile
 
BaylorCamaro's Avatar
 
Drives: 2016 C7 Z51
Join Date: Sep 2009
Location: League City, TX
Posts: 6,053
Quote:
Originally Posted by white 2SS/RS View Post
It's actually at 104*!
Well that sucks!
__________________
BaylorCamaro is online now   Reply With Quote
Old 07-18-2013, 09:26 AM   #19
sportyb24
Romanian Outlaw
 
sportyb24's Avatar
 
Drives: 13 ZL1 , 14 Silverado Crew Cab
Join Date: Apr 2010
Location: Texas Baby
Posts: 1,082
Are u in Waco ? Or you just went to Baylor?
__________________
[/SIGPIC]2013 Camaro ZL1 M6
sportyb24 is offline   Reply With Quote
Old 07-18-2013, 11:56 AM   #20
BaylorCamaro
Track > 1/4 Mile
 
BaylorCamaro's Avatar
 
Drives: 2016 C7 Z51
Join Date: Sep 2009
Location: League City, TX
Posts: 6,053
Quote:
Originally Posted by sportyb24 View Post
Are u in Waco ? Or you just went to Baylor?
I lived in Waco for a little bit and yes I graduated from Baylor. I'm in Kemah (SE Houston) now.
__________________
BaylorCamaro is online now   Reply With Quote
Old 07-18-2013, 01:07 PM   #21
sportyb24
Romanian Outlaw
 
sportyb24's Avatar
 
Drives: 13 ZL1 , 14 Silverado Crew Cab
Join Date: Apr 2010
Location: Texas Baby
Posts: 1,082
Oh ok.. Yeah I was wondering if there were any other Zl1's running around Waco ..
__________________
[/SIGPIC]2013 Camaro ZL1 M6
sportyb24 is offline   Reply With Quote
Old 07-18-2013, 01:48 PM   #22
BaylorCamaro
Track > 1/4 Mile
 
BaylorCamaro's Avatar
 
Drives: 2016 C7 Z51
Join Date: Sep 2009
Location: League City, TX
Posts: 6,053
Quote:
Originally Posted by sportyb24 View Post
Oh ok.. Yeah I was wondering if there were any other Zl1's running around Waco ..
I highly doubt that there are many, lol.
__________________
BaylorCamaro is online now   Reply With Quote
Old 07-18-2013, 04:12 PM   #23
RexZL1
 
RexZL1's Avatar
 
Drives: 2013 ZL1
Join Date: Jun 2013
Location: Austin
Posts: 124
I live in Austin, and the other day it rained and was overcast all day so the temp stayed about 77. I noticed a BIG difference in pull compared to days prior when it was 102. I just got my car a couple of months ago, can't wait until November, should rock then. Seems like all the mods to cool are either hard to do yourself, or pretty invasive. I want to keep the warranty for now. I did put a Roto-Fab CIA on it, but prob need to put the big gulp on or another ducting device to get the benefit of it. Do high flow cats affect the warranty.
RexZL1 is offline   Reply With Quote
Old 07-18-2013, 06:23 PM   #24
fourcammer
 
Drives: 7331
Join Date: Nov 2011
Location: tejas
Posts: 122
Quote:
Originally Posted by white 2SS/RS View Post
It's actually at 104*!

thanks for the info . this what I was wanting to find out.
fourcammer is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:14 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.