Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals


Reply
 
Thread Tools
Old 07-13-2013, 07:53 PM   #103
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 11,962
Nice looking trailer!!
Supercharged SS is offline   Reply With Quote
Old 07-13-2013, 10:07 PM   #104
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Quote:
Originally Posted by Supercharged SS View Post
Nice looking trailer!!
Thanks! I was hoping to w/the trailer i'd make it to Camaro5 fest, but my car isn't going to be ready.

-Pat
__________________
PMJ is offline   Reply With Quote
Old 07-17-2013, 12:36 AM   #105
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Have I mentioned how much I hate water pumps!

Got my Meziere electric water pump in the mail today...excited to get my car back on the road...only to find out, I'm pretty sure it doesn't fit. I started another thread, but appears the whipple vacuum actuator for the bypass valve prevents it from going into place.

Water pumps suck!
Attached Images
 
__________________
PMJ is offline   Reply With Quote
Old 07-26-2013, 01:54 AM   #106
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
I found out Whipple makes an offset bypass valve bracket to allow the Meziere electric pump to fit (costs $250). Unfortunately I found out late and already returned the pump. Maybe a 2nd time future upgrade.

I attached pictures of my 4th try with the water pump. This time I had a machine shop tap a hole in each side of the pulley slightly into the shaft. Then they put in a set screw and that's that...hopefully this is a good fix and my pulley doesn't fall off again!

So the great news is my car is running again! And my Bogarts showed up today! I'll have my tires mounted this weekend and then all I need is a tune and maybe install my RX Chiller and I should be set to get into the 10s!!!

.
Attached Images
   
__________________
PMJ is offline   Reply With Quote
Old 07-26-2013, 11:45 PM   #107
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
I had my slicks and skinnies mounted on my new bogarts today! Unfortunately discovered one of the rear bogarts were damaged in shipping (dent on the front rim). Talked to Rich and he is going to get it fixed, but if they can't fix the rim, I'll have to wait 2 more months before they get another rim built.

On a brighter note, I have a tuning apt w/Patrick G tomorrow evening. Road trip to Victoria! I'm excited about that. Expecting to fix my lean tip in and some of my idle issues. Hope the water pump stays together.

Also, Blake (Whipped416) talked me into a smaller pulley, so I installed a 2.875" today...love it! Seeing 17# of boost now. Can't wait to see numbers tomorrow!
__________________
PMJ is offline   Reply With Quote
Old 07-27-2013, 01:45 AM   #108
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 11,962
Quote:
Originally Posted by PMJ View Post
I had my slicks and skinnies mounted on my new bogarts today! Unfortunately discovered one of the rear bogarts were damaged in shipping (dent on the front rim). Talked to Rich and he is going to get it fixed, but if they can't fix the rim, I'll have to wait 2 more months before they get another rim built.

On a brighter note, I have a tuning apt w/Patrick G tomorrow evening. Road trip to Victoria! I'm excited about that. Expecting to fix my lean tip in and some of my idle issues. Hope the water pump stays together.

Also, Blake (Whipped416) talked me into a smaller pulley, so I installed a 2.875" today...love it! Seeing 17# of boost now. Can't wait to see numbers tomorrow!
Just so you know you can straighten the Bogarts yourself. You don't need to send it back to Rich. I've seen Ups deliver square wheels to Ted that they just straighten out and use.
Supercharged SS is offline   Reply With Quote
Old 07-27-2013, 12:05 PM   #109
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Quote:
Originally Posted by Supercharged SS View Post
Just so you know you can straighten the Bogarts yourself. You don't need to send it back to Rich. I've seen Ups deliver square wheels to Ted that they just straighten out and use.
Thanks Jamie! I'll try that first.
__________________
PMJ is offline   Reply With Quote
Old 07-30-2013, 12:51 AM   #110
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Patrick G Tune

I made it to Victory for tuning, unfortunately my water pump failed yet again...that's another story. I did find out Ligenfelter sells a GM water pump w/10 rib pulley for $650...well worth it!

Anyway, had to revert back to stock throttle body...turns out I need an additional piece from Whipple before the TPiS will function correctly. So potentially still some power left on the table.

2 dyno sheets from Mustang Dyno. One w/straight 93 octane and the other has 50/50 93 & Shell URT 105. (I can't wait until I can get URT Advanced again...)

Unfortunately car is out of commission once again due to water pump.

I'm expecting another bump with the TPiS properly installed. Also I need to get my super chiller installed...that will help as well. I'm getting lots of mixed reviews, but a few I know that have it, love it...my IATs are outrageous, so hoping it works some magic for me. Then I'll re-dyno at my local shop to get a true comparison of improvements.

.
Attached Images
  
__________________
PMJ is offline   Reply With Quote
Old 07-30-2013, 09:04 PM   #111
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
My water pump is on the way from Whipple along with the 102mm TB adapter...I couldn't help myself...a 2.75" pulley is also coming...now I'll really be maxed out... (short of nos)

Man, sooner or later I've got to make it back out to the track...time to stop modding and start driving ...(or should I say learning how to drive).
__________________
PMJ is offline   Reply With Quote
Old 08-27-2013, 11:22 PM   #112
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Ready to race!

I think I'm finally ready to race. I've been struggling with my RX Supper chiller install for number of weeks now. But I have gotten pretty efficient at evac'ing and recharging my own AC system . I don't think the RX chiller can handle my heat, they are supposed to send me a larger chiller unit next week (we'll see). Right not my coolant is around 75-80*, but my IATs still run around 150 (down from about 165).

Somewhere along the line, but car has started to eat my 10 rib belts. It was either after I install my water pump from Whipple and my 2.75" pulley. Ripped 1 in half a few weeks back and did some damage to my hood liner. I rerouted the belt slightly and when I checked today, I noticed I was running a 9 rib belt (pretty sure it had 10 ribs when I installed it) .

I did resolve my KR on quick shifts. I had to slow down the throttle opening rate from 100% down to 2%...hmm...but it seems to do the trick...no more knocking.

My bogarts are all mounted and ready to go...I installed a tire rack in the garage today for storage (sorry for bad pic).
Name:  tirerack.jpg
Views: 292
Size:  123.9 KB

Only things I have left are
  • maybe hex vents
  • bigger chiller
  • figure out what is eating my 10 rib belts...
I tried to dyno last Friday, but at 108* in the shop, it was a disaster (813 whp...was expecting closer to 850). I'll schedule another day when it gets down to the 80s.

Next track day is scheduled for 9/14...hope I don't break anything before I get there
__________________
PMJ is offline   Reply With Quote
Old 09-04-2013, 09:14 PM   #113
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 337
Quote:
Originally Posted by PMJ View Post
I hollowed out my cats this morning...another PITA job. I thought it would be 15 min or so per cat...took closer to 1 1/2 hours each...another bushing type job.

For some reason I for got to take an after pic, but they essentially look nice and clean in the middle.

.
I been meaning to ask (And have ask many times!) this question several times, I hear they only rob 3-4 hp, but the tone must certainly be different?
Now that you did it what differences did you notice- sound, power, anything?

P.S.
I see you got it over 800rwhp!
Haven't been on the forum as often, have to catch up!
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport swaybars w/HD adjustable links. Monster LT1-S twin, clutch, Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60'.
10 2SS/RS 6M is offline   Reply With Quote
Old 09-04-2013, 10:14 PM   #114
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Quote:
Originally Posted by 10 2SS/RS 6M View Post
I been meaning to ask (And have ask many times!) this question several times, I hear they only rob 3-4 hp, but the tone must certainly be different?
Now that you did it what differences did you notice- sound, power, anything?

P.S.
I see you got it over 800rwhp!
Haven't been on the forum as often, have to catch up!
Yes, I finally broke 800 at 107*F ambient temp...I'm looking forward to dynoing/racing on a sub 80* day. Maybe in October...

I didn't notice anything significant on the high flow cat to no cats mod. My primary reason for making the change was the concern of melting the cats at my current power and causing flow problems. Everyone I talked to said I needed to lose the cats at my power level. There may have been a slight increase in sound, but again not noticeable...it was loud before and still loud.
__________________
PMJ is offline   Reply With Quote
Old 09-13-2013, 12:46 AM   #115
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
New Shoes! Ready to dance...

Just put on my new track shoes for the first time (thanks to a little help from Jamie). Had to cut off the skates up front. And now I'm almost ready to go to the track Saturday.

Name:  newshoes.jpg
Views: 306
Size:  118.4 KB

Name:  newshoesrear.jpg
Views: 294
Size:  99.2 KB

Name:  newshoesfront.jpg
Views: 297
Size:  102.9 KB

Supposed to be in the 80s Saturday night in Seally, TX. I hope the rain holds off. Should be good enough weather for me to break into the 10s for the first time.

I'm expect 17.5+# of boost, so should be running around 830-850 whp.

I found out my belts are shredding because my balancer is recessed about 1 rib behind the rest of my 10 rib pulleys. So I took a new belt, cut 1 rib off, so now i'm running a 9 rib belt...and it appears to be riding just fine. We'll see how it holds up at the track.

My hex vents showed up today (install pending), and I'm still waiting on my larger chiller. The current chiller helps, but not anywhere close to what I was expecting.
__________________
PMJ is offline   Reply With Quote
Old 09-13-2013, 08:24 AM   #116
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 337
Quote:
Originally Posted by PMJ View Post
Just put on my new track shoes for the first time (thanks to a little help from Jamie). Had to cut off the skates up front. And now I'm almost ready to go to the track Saturday.

Attachment 555442



Attachment 555443

Attachment 555444

Supposed to be in the 80s Saturday night in Seally, TX. I hope the rain holds off. Should be good enough weather for me to break into the 10s for the first time.

I'm expect 17.5+# of boost, so should be running around 830-850 whp.

I found out my belts are shredding because my balancer is recessed about 1 rib behind the rest of my 10 rib pulleys. So I took a new belt, cut 1 rib off, so now i'm running a 9 rib belt...and it appears to be riding just fine. We'll see how it holds up at the track.

My hex vents showed up today (install pending), and I'm still waiting on my larger chiller. The current chiller helps, but not anywhere close to what I was expecting.
With that amount of horsepower you should have no problem running 10's, hope it all works out for you, wheels look great! Post some video's, Good Luck!
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport swaybars w/HD adjustable links. Monster LT1-S twin, clutch, Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60'.
10 2SS/RS 6M is offline   Reply With Quote
Old 09-13-2013, 09:32 AM   #117
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Quote:
Originally Posted by 10 2SS/RS 6M View Post
With that amount of horsepower you should have no problem running 10's, hope it all works out for you, wheels look great! Post some video's, Good Luck!
I guess it's all on the driver now. Thanks! I hope to get some videos and will post.
__________________
PMJ is offline   Reply With Quote
Old 09-14-2013, 05:52 PM   #118
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 392
Time to race! First time to the track on the trailer...

__________________
PMJ is offline   Reply With Quote
Old 09-14-2013, 08:19 PM   #119
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 337
Quote:
Originally Posted by PMJ View Post
Time to race! First time to the track on the trailer...

Nice! You still have it street legal right?
It is a lot better to trailer it to the track anyway to race to keep it cool and not have your street tires there, etc..
POST!
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport swaybars w/HD adjustable links. Monster LT1-S twin, clutch, Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60'.
10 2SS/RS 6M is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.