Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 09-07-2013, 03:11 PM   #1
Rucom197
Mike
 
Rucom197's Avatar
 
Drives: 2011 SS Camaro
Join Date: Aug 2013
Location: Long Island, NY
Posts: 47
Installed CAI Intake..Less Responsive! WHY??

I Just installed a Cold Air Induction Intake on my 2011 SS (M6) Camaro. I Checked the MAF and I have a "weak sensor" (Went online and ordered a "strong sensor" should be here in a few days) so maybe this is the problem. I also did some reading up on the forums about the fuse pull. As we speak the fuses are out of the box and I am going to let the car sit for a few hours. Has anyone else had this problem? I could just be losing my mind but for a mod that is said to give some RWHP I felt nothing!

Thanks everyone!

PS: I have had the car for almost 10 days now and I am OBSESSED!
__________________

Last edited by Rucom197; 09-07-2013 at 03:23 PM.
Rucom197 is offline   Reply With Quote
Old 09-07-2013, 03:13 PM   #2
SSCam77
 
Drives: 427
Join Date: Jan 2010
Location: GTA
Posts: 21
Did you do any tuning after the intake install?
__________________
SSCam77 is offline   Reply With Quote
Old 09-07-2013, 03:22 PM   #3
Rucom197
Mike
 
Rucom197's Avatar
 
Drives: 2011 SS Camaro
Join Date: Aug 2013
Location: Long Island, NY
Posts: 47
No tuning. As of right now the only thing that is on this car is the Cat-Back system that came with the car and the Intake that I just installed. The Vmax throttle body is on back order and the air scoop and bottle relocate should be here any day. So it's not like this car is getting to much air, unless the weak MAF really does make a difference.
__________________
Rucom197 is offline   Reply With Quote
Old 09-07-2013, 03:27 PM   #4
rozay
 
rozay's Avatar
 
Drives: camaro 2LS LFX A6
Join Date: Jun 2013
Location: South Florida
Posts: 617
do the fuse pull
__________________
Niche 20x10.5, BMR 1.25 springs, GFX splitter,1LE Diffuser w/ 3.5 quad tips
rozay is offline   Reply With Quote
Old 09-07-2013, 03:29 PM   #5
DARK AGE 53

 
DARK AGE 53's Avatar
 
Drives: 2010 SS
Join Date: Aug 2006
Location: Mi./Al.
Posts: 829
Do you find the car less responsive then what you were hoping for, or is less responsive then what it was prior to the install?
__________________
POW/MIA - YOU ARE LOST BUT NOT FORGOTTEN IN SOUTHEAST ASIA
DARK AGE 53 is offline   Reply With Quote
Old 09-07-2013, 03:32 PM   #6
Rucom197
Mike
 
Rucom197's Avatar
 
Drives: 2011 SS Camaro
Join Date: Aug 2013
Location: Long Island, NY
Posts: 47
Less responsive then before. Last night around midnight it was low 60's here on LI and the car was flying! After installed it today the temp was high 70's so I doubt this is a factor as well. Just trying to think of everything here, hopefully the fuse pull will work. If not I will give this new MAF a try when I get it in a few days.
__________________
Rucom197 is offline   Reply With Quote
Old 09-07-2013, 03:35 PM   #7
rozay
 
rozay's Avatar
 
Drives: camaro 2LS LFX A6
Join Date: Jun 2013
Location: South Florida
Posts: 617
most likely itll be a fuse pull or the weak MAF. ur on the right track
__________________
Niche 20x10.5, BMR 1.25 springs, GFX splitter,1LE Diffuser w/ 3.5 quad tips
rozay is offline   Reply With Quote
Old 09-07-2013, 03:40 PM   #8
DARK AGE 53

 
DARK AGE 53's Avatar
 
Drives: 2010 SS
Join Date: Aug 2006
Location: Mi./Al.
Posts: 829
Go back and double check your install, check all your wires, hose fittings, clamps and look for any air obstruction in the system.
__________________
POW/MIA - YOU ARE LOST BUT NOT FORGOTTEN IN SOUTHEAST ASIA
DARK AGE 53 is offline   Reply With Quote
Old 09-07-2013, 03:57 PM   #9
DARK AGE 53

 
DARK AGE 53's Avatar
 
Drives: 2010 SS
Join Date: Aug 2006
Location: Mi./Al.
Posts: 829
You might also want to check your MAF Sensor, it may have become dirty from your hands or oiled from you new filter. To clean your Maf get some CRC MAF Cleaner, if you're unsure how to clean it here's a video that might help
__________________
POW/MIA - YOU ARE LOST BUT NOT FORGOTTEN IN SOUTHEAST ASIA
DARK AGE 53 is offline   Reply With Quote
Old 09-07-2013, 06:16 PM   #10
JCunningham


 
JCunningham's Avatar
 
Drives: 2012 SIM 2SS/RS M6
Join Date: Jun 2013
Location: USA
Posts: 4,319
How many tanks of 91 or 93 have you run through it. If your only on your 1st tank you might still have 87 in there. run 2 tanks of 93 to get out all the 87 the dealer put in it. Put your new strong MAF in Then do the fuse pull over night. Check to see if your filter was over oiled if its a oiled filter. Mine was and covered the MAF causing bucking.
__________________
2012 2SS/RSM6SIM, Painted CarbonFlash rallystripes, Elite CC&CAOS 3.91gears,dyno J&JSpeedshop NewEra ported TB,CAI intake,Apex Scoop,Heritage Grill, PatG CamMotion cam,0%Fluidampr,Melling296 Oilpump, KatechC5R chain, CloyesLS7damper,PAC1205x springs and pushrods, Straubtrunions. ImprovedRacing oil baffle, crankscraper,MonsterBillet releasebearing,18"remotebleeder,ARH1 7/8"LTheaders cats,TWMfullShifter,BMRsways,links,trailing arms,toerods,delrin cradle bushings,BK039rear control bushings,front bushings. Idealclutch master,Tick clutchline, ForgstarF14,Invos,SoloMach-XL exhaust
JCunningham is offline   Reply With Quote
Old 09-07-2013, 07:09 PM   #11
Danthaman
 
Drives: 2011 SS/RS
Join Date: Aug 2013
Location: East Texas
Posts: 75
Its you MAF. Weak ones are less responsive. You will notice it more when you add CAI, TB. When you put the new "strong" MAF sensor in should feel a difference in throttle response
Danthaman is offline   Reply With Quote
Old 09-07-2013, 07:16 PM   #12
Danthaman
 
Drives: 2011 SS/RS
Join Date: Aug 2013
Location: East Texas
Posts: 75
Chase with Apex-Speed had a good forum on this.
Danthaman is offline   Reply With Quote
Old 09-07-2013, 09:02 PM   #13
DARK AGE 53

 
DARK AGE 53's Avatar
 
Drives: 2010 SS
Join Date: Aug 2006
Location: Mi./Al.
Posts: 829
Quote:
Originally Posted by Danthaman View Post
Its you MAF. Weak ones are less responsive. You will notice it more when you add CAI, TB. When you put the new "strong" MAF sensor in should feel a difference in throttle response
I don't think a stronger MAF is going to cure his problem, the reason I say that is because he states "Less responsive then before".
__________________
POW/MIA - YOU ARE LOST BUT NOT FORGOTTEN IN SOUTHEAST ASIA
DARK AGE 53 is offline   Reply With Quote
Old 09-07-2013, 09:28 PM   #14
cybergrayls3
 
Drives: 2010 camaro 2ss/rs..m6..CGM
Join Date: Apr 2011
Location: I40-NC
Posts: 352
Quote:
Originally Posted by DARK AGE 53 View Post
I don't think a stronger MAF is going to cure his problem, the reason I say that is because he states "Less responsive then before".
The weak MAF will become more of an issue once modifications are done that increase airflow. He has increased airflow with the CAI. The weak air meter cannot respond/keep up with the additional airflow. Thus the car probably is not adding enough fuel or its slow to do so since the weak MAF is not catching this additional aiflow..this will result in sluggish throttle response, and overall less responsive feeling. The additional airflow these mods create will only improve throttle response and power if the PCM can detect this additional flow so it can change other parameters to match the airflow. If it cant detect this airflow due too a weak/dirty/failing MAF then you are SOL my friend
__________________
-Lethal Racing NF cam
-Kooks LT's/high flow cats
-Borla ATAK catback
-CAI cold air intake (black)/Apex scoop
-LSR shifter
-Rick Crawford intake manifold
-Monster level 3 clutch
cybergrayls3 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:18 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.