Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JDP Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals

Member Car Journals Want to keep a long term Camaro project journal to share with the community? Use this forum to create a single thread which you can update over time to document the progress.

Reply
 
Thread Tools
Old 07-08-2013, 12:15 AM   #101
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
My Water Pump woes continue

I was all excited to go see Patrick G in Victoria today to hopefully correct my lean tip in as I shift gears, but I didn't make it out of the drive way.

The shaft on my water pump snapped . The good news is I was still in my drive way, and not half way to Victoria (2 1/2 hr trip)...always a silver lining.

Unfortunately this is the 2nd time my water pump pulley has fallen off since I upgraded to the 10-rib kit. I'm clearly not competent in water pump pulleys. You are supposed to remove the original pressed on pulley that is not intended to be removed. Then press on the new pulley. I thought I had it right the first time (on my second pump...I destroyed the first pump trying to press on the pulley). About a month later it fell off. .

Bound and determined to not let that happen again, I asked my friend for some ideas and we decided to drill a hole in the shaft, tap it and bold the pulley on...sounded like a good idea, but kept breaking taps...so we decided to pin the pulley (drilling straight through the side). In hind site, drilling out the shaft to tap it clearly messed with the integrity...I wish we had thought to pin it first...I think it would have held. As is it lasted around 2 months including a trip to the track and many daily driver miles.

Mike at Whipple also offered to install it is I sent him the pump and pulley...I think I'm going to take him up on that this time. But because I'm impatient. I'm also going to order an electric water pump...the idler pulley it comes with is plenty big for 10 rib, and supposed to add another 10-15hp .

Meziere Electric Water Pump in the mail.

.
Attached Images
  
__________________
PMJ is offline   Reply With Quote
Old 07-13-2013, 07:46 PM   #102
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Trailer

I bought a trailer so when I get my bogarts I'll be ready to go back and forth to the track... I'd include pictures w/my car, but I'm still waiting on my water pump . I hate not driving my car...

The fenders are not removable, but they measure 9" higher than the deck and it looks like my doors have 10" clearance, but it does drop closer to the hinges. This is with my street tires, so I'm hoping for the same clearance with the slicks and skinnies...we'll see.
Attached Images
  
__________________
PMJ is offline   Reply With Quote
Old 07-13-2013, 07:53 PM   #103
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 12,003
Nice looking trailer!!
Supercharged SS is offline   Reply With Quote
Old 07-13-2013, 10:07 PM   #104
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Quote:
Originally Posted by Supercharged SS View Post
Nice looking trailer!!
Thanks! I was hoping to w/the trailer i'd make it to Camaro5 fest, but my car isn't going to be ready.

-Pat
__________________
PMJ is offline   Reply With Quote
Old 07-17-2013, 12:36 AM   #105
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Have I mentioned how much I hate water pumps!

Got my Meziere electric water pump in the mail today...excited to get my car back on the road...only to find out, I'm pretty sure it doesn't fit. I started another thread, but appears the whipple vacuum actuator for the bypass valve prevents it from going into place.

Water pumps suck!
Attached Images
 
__________________
PMJ is offline   Reply With Quote
Old 07-26-2013, 01:54 AM   #106
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
I found out Whipple makes an offset bypass valve bracket to allow the Meziere electric pump to fit (costs $250). Unfortunately I found out late and already returned the pump. Maybe a 2nd time future upgrade.

I attached pictures of my 4th try with the water pump. This time I had a machine shop tap a hole in each side of the pulley slightly into the shaft. Then they put in a set screw and that's that...hopefully this is a good fix and my pulley doesn't fall off again!

So the great news is my car is running again! And my Bogarts showed up today! I'll have my tires mounted this weekend and then all I need is a tune and maybe install my RX Chiller and I should be set to get into the 10s!!!

.
Attached Images
   
__________________
PMJ is offline   Reply With Quote
Old 07-26-2013, 11:45 PM   #107
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
I had my slicks and skinnies mounted on my new bogarts today! Unfortunately discovered one of the rear bogarts were damaged in shipping (dent on the front rim). Talked to Rich and he is going to get it fixed, but if they can't fix the rim, I'll have to wait 2 more months before they get another rim built.

On a brighter note, I have a tuning apt w/Patrick G tomorrow evening. Road trip to Victoria! I'm excited about that. Expecting to fix my lean tip in and some of my idle issues. Hope the water pump stays together.

Also, Blake (Whipped416) talked me into a smaller pulley, so I installed a 2.875" today...love it! Seeing 17# of boost now. Can't wait to see numbers tomorrow!
__________________
PMJ is offline   Reply With Quote
Old 07-27-2013, 01:45 AM   #108
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 12,003
Quote:
Originally Posted by PMJ View Post
I had my slicks and skinnies mounted on my new bogarts today! Unfortunately discovered one of the rear bogarts were damaged in shipping (dent on the front rim). Talked to Rich and he is going to get it fixed, but if they can't fix the rim, I'll have to wait 2 more months before they get another rim built.

On a brighter note, I have a tuning apt w/Patrick G tomorrow evening. Road trip to Victoria! I'm excited about that. Expecting to fix my lean tip in and some of my idle issues. Hope the water pump stays together.

Also, Blake (Whipped416) talked me into a smaller pulley, so I installed a 2.875" today...love it! Seeing 17# of boost now. Can't wait to see numbers tomorrow!
Just so you know you can straighten the Bogarts yourself. You don't need to send it back to Rich. I've seen Ups deliver square wheels to Ted that they just straighten out and use.
Supercharged SS is offline   Reply With Quote
Old 07-27-2013, 12:05 PM   #109
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Quote:
Originally Posted by Supercharged SS View Post
Just so you know you can straighten the Bogarts yourself. You don't need to send it back to Rich. I've seen Ups deliver square wheels to Ted that they just straighten out and use.
Thanks Jamie! I'll try that first.
__________________
PMJ is offline   Reply With Quote
Old 07-30-2013, 12:51 AM   #110
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Patrick G Tune

I made it to Victory for tuning, unfortunately my water pump failed yet again...that's another story. I did find out Ligenfelter sells a GM water pump w/10 rib pulley for $650...well worth it!

Anyway, had to revert back to stock throttle body...turns out I need an additional piece from Whipple before the TPiS will function correctly. So potentially still some power left on the table.

2 dyno sheets from Mustang Dyno. One w/straight 93 octane and the other has 50/50 93 & Shell URT 105. (I can't wait until I can get URT Advanced again...)

Unfortunately car is out of commission once again due to water pump.

I'm expecting another bump with the TPiS properly installed. Also I need to get my super chiller installed...that will help as well. I'm getting lots of mixed reviews, but a few I know that have it, love it...my IATs are outrageous, so hoping it works some magic for me. Then I'll re-dyno at my local shop to get a true comparison of improvements.

.
Attached Images
  
__________________
PMJ is offline   Reply With Quote
Old 07-30-2013, 09:04 PM   #111
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
My water pump is on the way from Whipple along with the 102mm TB adapter...I couldn't help myself...a 2.75" pulley is also coming...now I'll really be maxed out... (short of nos)

Man, sooner or later I've got to make it back out to the track...time to stop modding and start driving ...(or should I say learning how to drive).
__________________
PMJ is offline   Reply With Quote
Old 08-27-2013, 11:22 PM   #112
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Ready to race!

I think I'm finally ready to race. I've been struggling with my RX Supper chiller install for number of weeks now. But I have gotten pretty efficient at evac'ing and recharging my own AC system . I don't think the RX chiller can handle my heat, they are supposed to send me a larger chiller unit next week (we'll see). Right not my coolant is around 75-80*, but my IATs still run around 150 (down from about 165).

Somewhere along the line, but car has started to eat my 10 rib belts. It was either after I install my water pump from Whipple and my 2.75" pulley. Ripped 1 in half a few weeks back and did some damage to my hood liner. I rerouted the belt slightly and when I checked today, I noticed I was running a 9 rib belt (pretty sure it had 10 ribs when I installed it) .

I did resolve my KR on quick shifts. I had to slow down the throttle opening rate from 100% down to 2%...hmm...but it seems to do the trick...no more knocking.

My bogarts are all mounted and ready to go...I installed a tire rack in the garage today for storage (sorry for bad pic).
Name:  tirerack.jpg
Views: 204
Size:  123.9 KB

Only things I have left are
  • maybe hex vents
  • bigger chiller
  • figure out what is eating my 10 rib belts...
I tried to dyno last Friday, but at 108* in the shop, it was a disaster (813 whp...was expecting closer to 850). I'll schedule another day when it gets down to the 80s.

Next track day is scheduled for 9/14...hope I don't break anything before I get there
__________________
PMJ is offline   Reply With Quote
Old 09-04-2013, 09:14 PM   #113
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 323
Quote:
Originally Posted by PMJ View Post
I hollowed out my cats this morning...another PITA job. I thought it would be 15 min or so per cat...took closer to 1 1/2 hours each...another bushing type job.

For some reason I for got to take an after pic, but they essentially look nice and clean in the middle.

.
I been meaning to ask (And have ask many times!) this question several times, I hear they only rob 3-4 hp, but the tone must certainly be different?
Now that you did it what differences did you notice- sound, power, anything?

P.S.
I see you got it over 800rwhp!
Haven't been on the forum as often, have to catch up!
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport swaybars w/HD adjustable links. Monster LT1-S twin, clutch, Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60'.
10 2SS/RS 6M is offline   Reply With Quote
Old 09-04-2013, 10:14 PM   #114
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Quote:
Originally Posted by 10 2SS/RS 6M View Post
I been meaning to ask (And have ask many times!) this question several times, I hear they only rob 3-4 hp, but the tone must certainly be different?
Now that you did it what differences did you notice- sound, power, anything?

P.S.
I see you got it over 800rwhp!
Haven't been on the forum as often, have to catch up!
Yes, I finally broke 800 at 107*F ambient temp...I'm looking forward to dynoing/racing on a sub 80* day. Maybe in October...

I didn't notice anything significant on the high flow cat to no cats mod. My primary reason for making the change was the concern of melting the cats at my current power and causing flow problems. Everyone I talked to said I needed to lose the cats at my power level. There may have been a slight increase in sound, but again not noticeable...it was loud before and still loud.
__________________
PMJ is offline   Reply With Quote
Old 09-13-2013, 12:46 AM   #115
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
New Shoes! Ready to dance...

Just put on my new track shoes for the first time (thanks to a little help from Jamie). Had to cut off the skates up front. And now I'm almost ready to go to the track Saturday.

Name:  newshoes.jpg
Views: 193
Size:  118.4 KB

Name:  newshoesrear.jpg
Views: 197
Size:  99.2 KB

Name:  newshoesfront.jpg
Views: 192
Size:  102.9 KB

Supposed to be in the 80s Saturday night in Seally, TX. I hope the rain holds off. Should be good enough weather for me to break into the 10s for the first time.

I'm expect 17.5+# of boost, so should be running around 830-850 whp.

I found out my belts are shredding because my balancer is recessed about 1 rib behind the rest of my 10 rib pulleys. So I took a new belt, cut 1 rib off, so now i'm running a 9 rib belt...and it appears to be riding just fine. We'll see how it holds up at the track.

My hex vents showed up today (install pending), and I'm still waiting on my larger chiller. The current chiller helps, but not anywhere close to what I was expecting.
__________________
PMJ is offline   Reply With Quote
Old 09-13-2013, 08:24 AM   #116
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 323
Quote:
Originally Posted by PMJ View Post
Just put on my new track shoes for the first time (thanks to a little help from Jamie). Had to cut off the skates up front. And now I'm almost ready to go to the track Saturday.

Attachment 555442



Attachment 555443

Attachment 555444

Supposed to be in the 80s Saturday night in Seally, TX. I hope the rain holds off. Should be good enough weather for me to break into the 10s for the first time.

I'm expect 17.5+# of boost, so should be running around 830-850 whp.

I found out my belts are shredding because my balancer is recessed about 1 rib behind the rest of my 10 rib pulleys. So I took a new belt, cut 1 rib off, so now i'm running a 9 rib belt...and it appears to be riding just fine. We'll see how it holds up at the track.

My hex vents showed up today (install pending), and I'm still waiting on my larger chiller. The current chiller helps, but not anywhere close to what I was expecting.
With that amount of horsepower you should have no problem running 10's, hope it all works out for you, wheels look great! Post some video's, Good Luck!
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport swaybars w/HD adjustable links. Monster LT1-S twin, clutch, Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60'.
10 2SS/RS 6M is offline   Reply With Quote
Old 09-13-2013, 09:32 AM   #117
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Quote:
Originally Posted by 10 2SS/RS 6M View Post
With that amount of horsepower you should have no problem running 10's, hope it all works out for you, wheels look great! Post some video's, Good Luck!
I guess it's all on the driver now. Thanks! I hope to get some videos and will post.
__________________
PMJ is offline   Reply With Quote
Old 09-14-2013, 05:52 PM   #118
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Time to race! First time to the track on the trailer...

__________________
PMJ is offline   Reply With Quote
Old 09-14-2013, 08:19 PM   #119
10 2SS/RS 6M
 
10 2SS/RS 6M's Avatar
 
Drives: 2010 Camaro 2SS/RS 6M Black-s/s
Join Date: Oct 2010
Location: Philadelphia, PA
Posts: 323
Quote:
Originally Posted by PMJ View Post
Time to race! First time to the track on the trailer...

Nice! You still have it street legal right?
It is a lot better to trailer it to the track anyway to race to keep it cool and not have your street tires there, etc..
POST!
__________________
SLP- long tube headers, hi flow cats w/full SLP 3'' PowerFlo exhaust incl/X-pipe, 160 degree stat, SLP Blackwing CAI. Dyno tuned by ECS-407/409RWHP&TQ. BMR- trailing arms w/poly knuckle bushings, toe links, cradle bushings and differential bushings. Hurst short throw shifter, DSS- level 4 axles, DSS- aluminum driveshaft, Pfadt- sport swaybars w/HD adjustable links. Monster LT1-S twin, clutch, Prothane motor mounts. Best 1/4 mile so far- 12:70ET @ 112.24 MPH w/ 2.06 60'.
10 2SS/RS 6M is offline   Reply With Quote
Old 09-14-2013, 08:23 PM   #120
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 12,003
Good luck. Let us know how you make out.


It's so much easier to just roll the car off the trailer and be ready to race.
Supercharged SS is offline   Reply With Quote
Old 09-14-2013, 08:52 PM   #121
SilverSlayer-SS
SoCal HT5
 
SilverSlayer-SS's Avatar
 
Drives: 2010 SS , 2014 SS
Join Date: Sep 2011
Location: Muscat-Oman
Posts: 1,330
looks mean !
__________________
SilverSlayer-SS is offline   Reply With Quote
Old 09-15-2013, 08:46 PM   #122
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Quote:
Originally Posted by Supercharged SS View Post
Good luck. Let us know how you make out.


It's so much easier to just roll the car off the trailer and be ready to race.
Well my trailer is a little high maintenance, but I agree it's much better. Especially knowing I have a way home when I break something.

I'll post a video later, but finally got my 10 (10.93@135). 1 year 4 months after driving her home from the dealer. Not bad.

1.6 60', was impressive for me. .2s faster than my best on drag radials. I like the slicks. And definitely room to improve. Never had a clean run. Still getting some boost spike with throttle response set to 1 of 100. I guess it's time to learn to power shift. Everything in my body says when clutch, let off throttle. I have to get over that.

It cooled down for houston, but still hot. My corrected ET is. 10.6. So I have high expectations to get my new 10.5 goal when it cools in oct/nov. But my next event is the Texas mile...

Name:  image.jpg
Views: 170
Size:  69.6 KB
__________________
PMJ is offline   Reply With Quote
Old 09-15-2013, 08:52 PM   #123
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 12,003
Quote:
Originally Posted by PMJ View Post
Well my trailer is a little high maintenance, but I agree it's much better. Especially knowing I have a way home when I break something.

I'll post a video later, but finally got my 10 (10.93@135). 1 year 4 months after driving her home from the dealer. Not bad.

1.6 60', was impressive for me. .2s faster than my best on drag radials. I like the slicks. And definitely room to improve. Never had a clean run. Still getting some boost spike with throttle response set to 1 of 100. I guess it's time to learn to power shift. Everything in my body says when clutch, let off throttle. I have to get over that.

It cooled down for houston, but still hot. My corrected ET is. 10.6. So I have high expectations to get my new 10.5 goal when it cools in oct/nov. But my next event is the Texas mile...

Attachment 556249
Congrats!! One goal at at time or you'll just confuse yourself.

That mph is good for low 10's so it's on you now. Practice and get a lot of seat time.
Supercharged SS is offline   Reply With Quote
Old 09-15-2013, 08:53 PM   #124
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 12,003
Are you shifting early? Or taking to long to shift. The 1/8 mph and time is awful!
Supercharged SS is offline   Reply With Quote
Old 09-15-2013, 09:01 PM   #125
PMJ
Seeking 9s on M6...
 
PMJ's Avatar
 
Drives: 2012 2SS/RS LS3 aka "BlackWidow"
Join Date: May 2012
Location: Houston, TX
Posts: 371
Quote:
Originally Posted by Supercharged SS View Post
Congrats!! One goal at at time or you'll just confuse yourself.

That mph is good for low 10's so it's on you now. Practice and get a lot of seat time.
Yep, as soon as I hit my goal, always setting the next one.

Quote:
Originally Posted by Supercharged SS View Post
Are you shifting early? Or taking to long to shift. The 1/8 mph and time is awful!
I think I hit my rev limiter twice in that pass.

When I went to the 2.75" pulley I had to drop my rev limiter to avoid over spinning the whipple. I didn't have my shift light on.
__________________
PMJ is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.