Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 09-15-2013, 09:19 PM   #26
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
Havent had the time to mess with it further

New wrinkle after runs at wot the car does it

Saving up to replace the trailing arms toe links and all the bushings just going to take a while

So far
Alignment is fine
Nothing's loose

Did notice the wheel shaking today (not terrible) going to have the tires rebalanced even though I'm pretty sure that's not it just to eliminate it
__________________
1969to2010 is offline   Reply With Quote
Old 09-16-2013, 03:30 PM   #27
Black Knight

 
Black Knight's Avatar
 
Drives: Supercharged LS
Join Date: Aug 2012
Location: RGV, Texas
Posts: 854
Hope you can straighten every thing out soon . Good luck
__________________
(click pic for build thread)
Black Knight is offline   Reply With Quote
Old 09-18-2013, 09:56 PM   #28
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,481
Quote:
Originally Posted by 1969to2010 View Post
I had posted my last suspension nightmare a few months ago that turned out to be a trailing arm bushing now another issue awesome ( Ty again JDP )

My car had slight bump steer for a while wasn't too bad hitting bumps and going around curves the car would shimmy kind of like wobble back and fourth motion like a sway

Anyway took the car to Detroit and back for Bbomg5 now the car is 100 times worse cars moving a lot out on the road def not cool.

The car
1SS 76 mil turbo
Pfadt springs 1.25 drop
Sphon tunnel brace
BMR trailing arms
BMR toe rods
BMR full poly subframe bushings
9 inch forgestars 11 inch rears
Pfadt sway bars front and rear
Stock end links
Cars alignment is perfect tire pressures fine
Not a balancing issue bc them it would vibrate and shake

Is it the poly subframe bushings ? i have heard they move.
Any help or ideas would be greatly appreciated
There is no reason to gues at this.

If you think the rear sub-frame bushings are the culprit use a GoPro or similar camera and get a bit of video on the rear sub-frame bushings. Post it here.

If that isn't conclussive we'll point that camera at a few more critial locations until we isolate the issue and identify a fix.
__________________
JusticePete is offline   Reply With Quote
Old 09-18-2013, 11:27 PM   #29
TBone
Negative Camber Junkie
 
TBone's Avatar
 
Drives: 2010 1SS LS3/6MN ABM 1 of 23
Join Date: May 2009
Location: ChiTown, IL
Posts: 1,826
Name:  original.jpg
Views: 259
Size:  173.0 KB

T.
__________________
"Horsepower is something that looks great in a Magazine article, but suspension is what actually gets you around the track fast.." Jack Olsen
The drag strip is like sniffing glue, it's cheap, it's a decent buzz, it doesn't last long and they are all the same.
Road racing is like China White Heroin, the buzz is stronger, the high lasts for hours, it's extremely addictive and they are all different.
I can't wait for my next
Track fix.
DA HAWKS used to OWN DA CUP!!!!!
TBone is offline   Reply With Quote
Old 09-18-2013, 11:31 PM   #30
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
Pete this is the black and white turbo car you saw in Detroit , def going to try that


Sent from my iPhone using Tapatalk 2
__________________
1969to2010 is offline   Reply With Quote
Old 09-19-2013, 05:24 AM   #31
Scott@Bjorn3D


 
Scott@Bjorn3D's Avatar
 
Drives: Kami, 2013 2SS LS3 Luvin
Join Date: Oct 2008
Location: Eufaula, Alabama
Posts: 6,121
Send a message via MSN to Scott@Bjorn3D
Maybe the control arm broke? I know the control arm tab on one of my LCA's broke where the endlink hooks up and the car wabbled all over the place. Looking under the car real quick it looked fine till I inspected the control arm.
Attached Images
  
__________________
2013 2SS, GM Strut Tower Brace, CAI Intake Black, VMAX TB, Elite Catch Can, Hotchkis Chassis Brace, Hurst Shifter, 3.91 1LE Complete Rear End, NPP, 1LE Track Pack,Factory Reproductions Style 41 ZL1 Fitment Wheels 10" on all 4 corners
Scott@Bjorn3D is offline   Reply With Quote
Old 09-19-2013, 09:01 AM   #32
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,481
Quote:
Originally Posted by 1969to2010 View Post
Pete this is the black and white turbo car you saw in Detroit , def going to try that


Sent from my iPhone using Tapatalk 2
:-)

Say hello to Matt for me.
__________________
JusticePete is offline   Reply With Quote
Old 09-19-2013, 09:43 PM   #33
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
Will do Pete and thanks for taking the time to check out the car
Matt's doing ok


Sent from my iPhone using Tapatalk 2
__________________
1969to2010 is offline   Reply With Quote
Old 09-20-2013, 10:35 AM   #34
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,481
Quote:
Originally Posted by 1969to2010 View Post
Will do Pete and thanks for taking the time to check out the car
Matt's doing ok


Sent from my iPhone using Tapatalk 2
He had a headache with his DS vibration, but I think he got it sorted yesterday. next time you see him tell him Pete told you he had one job. Just one job and what did he do??????





__________________
JusticePete is offline   Reply With Quote
Old 12-09-2013, 09:56 PM   #35
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
Just ordered most of my parts just need time to get them installed
Car ran great at the track but it still does it
Cold days it's worse too wot run just let off the gas after the waste gates opened up and it did it really bad

Ordered
Pfadt toe rods trailing arms upper control arm bushings thanks so much Jordan @ jdp motorsports

To pull the whole car apart and not replace the subframe bushings seems silly so I'm saving some money going to change it all out and hopefully get past this
__________________
1969to2010 is offline   Reply With Quote
Old 12-10-2013, 07:32 AM   #36
tanur420
 
Drives: 2011 Camaro SS
Join Date: Apr 2012
Location: Jacksonville FL
Posts: 323
Just a random thought, did you retime bushings when you dropped it?
__________________
tanur420 is offline   Reply With Quote
Old 12-10-2013, 07:38 AM   #37
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
No we didn't time the bushings
The car was dropped more than a year before this started happening and it was fine so I didn't think it's related
__________________
1969to2010 is offline   Reply With Quote
Old 12-10-2013, 06:35 PM   #38
10aSSee D

 
10aSSee D's Avatar
 
Drives: Silver 2010 SS Camaro
Join Date: Jul 2009
Location: TN
Posts: 1,975
Dang man that's an expensive way to try and fix a problem lol.
__________________
MODS:

ADM built 417, 2.9L Whipple with 3.250 pulley, ADM ported and polished LSA heads,ADM stage3 cam,ADM LSA belt drive system,ADM CAI race scoop, ADM dual fuel pumps, ID 850's, BMR full suspension, Gforce 9 inch kit with 3.5 inch driveshaft, Street Slayer twin carbon clutch, Lingenfelter oil seperator. Tuned by built by ADM Performance, 740rwhp,685rwtq
10aSSee D is offline   Reply With Quote
Old 06-07-2014, 04:29 PM   #39
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
Finally got the new parts installed pfadt trailing arms and toe links then had it aligned the car is finally right

The prev bushings look to be the cause,when we took them out they were pretty loose. We had it aligned a ways back and had no improvement. The suspension was moving still. Now with the new parts its solid as a rock .

I have to give a huge thnx to Cisco from newgen customs ny and Jordan from jdp motorosports. Jordan was spot on in his analysis and Cisco spent a lot of time checking the car out. Def above and beyond.

Very happy as the car was close to being set on fire

Final verdict the poly subframe bushings are fine the bushings in the original suspension parts were the issue. To BMRs credit they sent me replacement bushings which will go into a buddy's car up here in NY. Long annoying issue is over.
__________________
1969to2010 is offline   Reply With Quote
Old 06-07-2014, 10:38 PM   #40
OmniCamaro
US Veteran
 
OmniCamaro's Avatar
 
Drives: 2011 Silver Ice Metallic 2SS/RS A6
Join Date: Jan 2011
Location: Bossier City, La
Posts: 1,057
So in conclusion? The BMR subframe inserts were faulty?
__________________
Dear Lord, give me the strength to carry on despite my Camaro addiction!
JRE iTSX tune, full cat-less Dynatech exhaust, CAI intake, Stillen Slotted/Drilled Rotors, RB braided brake lines, BMR lowering springs, 1LE suspension, (reserved for future MODS)
OmniCamaro is offline   Reply With Quote
Old 06-08-2014, 05:20 AM   #41
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
I don't have insets I have full poly subframe bushings which are fine.
The bushings in the trailing arms and toe links was where issue came from. They were bmr parts and bmr sent me replacements which I'm thankful for. But I've gone with pfadt arms and toe links


Sent from my iPhone using Tapatalk
__________________
1969to2010 is offline   Reply With Quote
Old 06-08-2014, 11:40 AM   #42
OmniCamaro
US Veteran
 
OmniCamaro's Avatar
 
Drives: 2011 Silver Ice Metallic 2SS/RS A6
Join Date: Jan 2011
Location: Bossier City, La
Posts: 1,057
Quote:
Originally Posted by 1969to2010 View Post
I don't have insets I have full poly subframe bushings which are fine.
The bushings in the trailing arms and toe links was where issue came from. They were bmr parts and bmr sent me replacements which I'm thankful for. But I've gone with pfadt arms and toe links


Sent from my iPhone using Tapatalk

Thanks for clearing that up for me. Glad you got it all sorted!
__________________
Dear Lord, give me the strength to carry on despite my Camaro addiction!
JRE iTSX tune, full cat-less Dynatech exhaust, CAI intake, Stillen Slotted/Drilled Rotors, RB braided brake lines, BMR lowering springs, 1LE suspension, (reserved for future MODS)
OmniCamaro is offline   Reply With Quote
Old 06-08-2014, 06:09 PM   #43
1969to2010
The Man in Black
 
1969to2010's Avatar
 
Drives: 1969 Camaro 2010 Camaro 1SS
Join Date: Apr 2009
Location: Long Island NY
Posts: 1,971
Thnx !


Sent from my iPhone using Tapatalk
__________________
1969to2010 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.