Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Cam Motion
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis


Reply
 
Thread Tools
Old 09-26-2013, 01:18 PM   #69
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by bigpunn03 View Post
I need both front and rear links for 2010 can you tell me where I can find on the website? Also do you sell bushings for OEM front Sway bar?
Our signature series parts are the best of the best. The part numbers are listed next to the description and picture. They are in stock and ready to ship.

Front with OEM 10mm Studs is CAM-SW-LINK-F-OE



Rear with OEM 10mm Studs is CAM3-SW-LINK-R-OE



JusticePete is offline   Reply With Quote
Old 09-27-2013, 10:35 AM   #70
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by bigpunn03 View Post
I need both front and rear links for 2010 can you tell me where I can find on the website? Also do you sell bushings for OEM front Sway bar?
Thank you for choosing JPSS endlinks for your Camaro!
JusticePete is offline   Reply With Quote
Old 09-29-2013, 02:43 AM   #71
gelboy1015

 
gelboy1015's Avatar
 
Drives: '10 2SS/RS, MKIII Supras
Join Date: May 2010
Location: Houston/Tulsa
Posts: 988
Quick question. I have the rear end links and one of them had the boot come slightly undone and I guess all the grease "leaked" out causing it to become noisy. My question is, can I use a syringe to inject grease into the boot and fix it, or do you guys just sell one of the ends separately?
__________________


2010 Camaro 2SS/RS
- LS3, M6. -
Build Thread/Mods List



gelboy1015 is offline   Reply With Quote
Old 09-29-2013, 12:20 PM   #72
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by gelboy1015 View Post
Quick question. I have the rear end links and one of them had the boot come slightly undone and I guess all the grease "leaked" out causing it to become noisy. My question is, can I use a syringe to inject grease into the boot and fix it, or do you guys just sell one of the ends separately?
How long has it been in service?
JusticePete is offline   Reply With Quote
Old 09-29-2013, 11:02 PM   #73
gelboy1015

 
gelboy1015's Avatar
 
Drives: '10 2SS/RS, MKIII Supras
Join Date: May 2010
Location: Houston/Tulsa
Posts: 988
Quote:
Originally Posted by JusticePete View Post
How long has it been in service?
Around 10k miles, installed them less than a year ago.
__________________


2010 Camaro 2SS/RS
- LS3, M6. -
Build Thread/Mods List



gelboy1015 is offline   Reply With Quote
Old 09-29-2013, 11:08 PM   #74
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by gelboy1015 View Post
Around 10k miles, installed them less than a year ago.
It sounds like warranty replacement. We'll need to know if it is a left or right hand thread ball-joint and the studs size 10 or 12mm. Send me an email with you name, address, phone and email along with your purchase information.

PGB@PeddersUSA.com
JusticePete is offline   Reply With Quote
Old 09-29-2013, 11:27 PM   #75
sycraft
COTW 5/06/2013
 
sycraft's Avatar
 
Drives: 2015 Corvette Stingray Z51-Ho-Vette
Join Date: May 2012
Location: Katy, Texas
Posts: 3,113
Do you have the larger bolts to fit the 1LE struts and sways, I would not want a smaller SS link bolt.
__________________

2015 Corvette Stingray Z51, 7 Speed, Competition Seats, Red Calipers, Carbon Flash Badges and Trim, Adrenaline Red Interior, Custom Stripes, Tint, Lowered on stock bolts, Z06 Grill, Z06 Splitter, Borla Exhaust (soon)
sycraft is offline   Reply With Quote
Old 09-30-2013, 12:14 AM   #76
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by sycraft View Post
Do you have the larger bolts to fit the 1LE struts and sways, I would not want a smaller SS link bolt.
Absolutely. 12mm Studs CAM-SW-LINK-F-12X2 In-Stock.
JusticePete is offline   Reply With Quote
Old 10-08-2013, 10:54 PM   #77
bigpunn03
 
bigpunn03's Avatar
 
Drives: 2010 2LT RS
Join Date: Jun 2010
Location: Ohio
Posts: 101
I just got these installed today. they said they installed them a little shorter than stock. Is this ok and what are the positive and negatives of doing this. My car is lowered on pfadt springs.
bigpunn03 is offline   Reply With Quote
Old 10-08-2013, 11:13 PM   #78
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by bigpunn03 View Post
I just got these installed today. they said they installed them a little shorter than stock. Is this ok and what are the positive and negatives of doing this. My car is lowered on pfadt springs.
With an after market bar, the same as the noise level, none
JusticePete is offline   Reply With Quote
Old 10-16-2013, 04:44 PM   #79
bigpunn03
 
bigpunn03's Avatar
 
Drives: 2010 2LT RS
Join Date: Jun 2010
Location: Ohio
Posts: 101
Pete,

Now instead of clunking noise, I hear a hollow sound like wood hitting over the slightest small bumps. What could this be? I'ts annoying
bigpunn03 is offline   Reply With Quote
Old 10-16-2013, 04:55 PM   #80
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by bigpunn03 View Post
Pete,

Now instead of clunking noise, I hear a hollow sound like wood hitting over the slightest small bumps. What could this be? I'ts annoying
1. Is the noise in the front or rear?
2. Did the noise start immediately upon install or did it take a few days and miles to start?
JusticePete is offline   Reply With Quote
Old 10-17-2013, 06:47 PM   #81
bigpunn03
 
bigpunn03's Avatar
 
Drives: 2010 2LT RS
Join Date: Jun 2010
Location: Ohio
Posts: 101
Quote:
Originally Posted by JusticePete View Post
1. Is the noise in the front or rear?
2. Did the noise start immediately upon install or did it take a few days and miles to start?
Its in both front and rear and yes took 2-3 days. Around 40 miles. Before I put the endlinks on when I hit small bumps it sounded like the car was falling apart underneath.
bigpunn03 is offline   Reply With Quote
Old 10-17-2013, 08:14 PM   #82
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by bigpunn03 View Post
Its in both front and rear and yes took 2-3 days. Around 40 miles. Before I put the endlinks on when I hit small bumps it sounded like the car was falling apart underneath.
If it took a couple of days to start, re-tighten everything. I am thinking one of the lock nuts on the endlink shaft is a bit loose.
JusticePete is offline   Reply With Quote
Old 10-17-2013, 09:16 PM   #83
bigpunn03
 
bigpunn03's Avatar
 
Drives: 2010 2LT RS
Join Date: Jun 2010
Location: Ohio
Posts: 101
Quote:
Originally Posted by JusticePete View Post
If it took a couple of days to start, re-tighten everything. I am thinking one of the lock nuts on the endlink shaft is a bit loose.
can you post a pics of where this would be on both front and rear?
bigpunn03 is offline   Reply With Quote
Old 10-17-2013, 10:01 PM   #84
JusticePete
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Virginia
Posts: 17,601
Quote:
Originally Posted by bigpunn03 View Post
can you post a pics of where this would be on both front and rear?

The jam nuts , lock nuts on the adjustable endlink threaded rods where they butt up to the ball joint aluminum casting.

JusticePete is offline   Reply With Quote
Old 10-25-2013, 12:30 PM   #85
bigpunn03
 
bigpunn03's Avatar
 
Drives: 2010 2LT RS
Join Date: Jun 2010
Location: Ohio
Posts: 101
ok so I took the car back to the shop, they stated that everyone was still tight and in tact. Do you have any other suggestions. They said that they drove it and when going over big bumps is sounds like the car is bottoming out; this is normal because of the drop springs. My issue is going over the slightest crack in the road that's when I hear the hollow knocking sound and it feels like the suspension is loose.
bigpunn03 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5th Gen Suspension -- The Book JusticePete Suspension / Brakes / Chassis 151 05-07-2015 06:52 PM
Engine sounds so quiet jagan323 5th Gen Camaro SS LS LT General Discussions 15 04-14-2010 12:22 AM
Pfadt Racing new Camaro Endlinks available NOW! PfadtRacing Suspension / Brakes / Chassis 28 03-22-2010 01:00 PM
LM Performance, Spohn Camaro 2010 Tubular Rear Trailing Arms w/ Spherical Rod Ends LMPerformance V8 Bolt-Ons & Tunes 0 10-19-2009 02:59 PM
LM Performance, Spohn Camaro 2010 Tubular Rear Toe Links with Spherical Rod Ends. LMPerformance V8 Bolt-Ons & Tunes 0 10-19-2009 02:44 PM


All times are GMT -5. The time now is 05:07 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.