Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Hellion Power Systems
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 10-26-2013, 03:38 PM   #1
LS3 SS

 
LS3 SS's Avatar
 
Drives: 2010 Cyber Grey Camaro SS (LS3)
Join Date: Mar 2010
Location: Clarksville TN
Posts: 2,241
Pedders coil springs squeaking?

Recently I went on a 700 mile trip from TN to VA for school for 2 months. Once I reached Virginia, I mysteriously started hearing a very audible and loud squeaking noise from the rear of the car every time I hit a tiny,small, moderate, or large bump on any paved or unpaved surface. I went to the auto skills center and put my car up on a lift, immediately thinking that it was my rear sway bar making the noise. I figure it needed to be greased, and that was issue.

Well today, I greased both bushings very thoroughly (I didn't use a grease gun, I took the bushings off, greased them by hand, and re-installed them). To my suprise, after greasing them, the noise did not go away. Once I returned back to the hotel, I noticed that whenever I sit down in the car, or get up, you can hear the squeak. Then I decided to push down on my driver's rear quarter panel, and I could get the car to make the squeaking noise at will.

I am almost certain it is one or both of my lowering springs that are making this noise. Is this common? Has anyone ever had their springs make squeaking noises, sort of like an old rusty spring? What can be done to fix this issue? Do I need to disassemble the spring, clean it and put it back on? Thanks.
__________________
PCM of NC '545' Cam/PRC 255s/GM 3.91s/ProCharger D1SC @9psi 669 rwhp/546 rwtq Tuned by Alvin @ PCM of NC
LS3 SS is offline   Reply With Quote
Old 10-27-2013, 10:28 AM   #2
camaro4mybday
"Camaro Joe"
 
camaro4mybday's Avatar
 
Drives: 2010 SILVER ICE 2LT/RS CAMARO
Join Date: Feb 2010
Location: long island ny
Posts: 2,339
Send a message via AIM to camaro4mybday
who did the assembly? make sure the spring isolators were reinstalled correctly in the proper position
camaro4mybday is offline   Reply With Quote
Old 10-27-2013, 10:47 AM   #3
LS3 SS

 
LS3 SS's Avatar
 
Drives: 2010 Cyber Grey Camaro SS (LS3)
Join Date: Mar 2010
Location: Clarksville TN
Posts: 2,241
Quote:
Originally Posted by camaro4mybday View Post
who did the assembly? make sure the spring isolators were reinstalled correctly in the proper position
Dyno Tuned Performance in Virginia Beach, VA did the installation. Everything was installed correctly, I forgot to mention the springs have been on the car for about 35,xxx miles, car currently has 43,xxx and this is the first time I've heard this noise.
__________________
PCM of NC '545' Cam/PRC 255s/GM 3.91s/ProCharger D1SC @9psi 669 rwhp/546 rwtq Tuned by Alvin @ PCM of NC
LS3 SS is offline   Reply With Quote
Old 10-27-2013, 01:27 PM   #4
SPCBA
Blake
 
SPCBA's Avatar
 
Drives: pleather and Chiclets
Join Date: Mar 2012
Location: a VA line somwhere
Posts: 3,723
I am confused do you have coilovers or springs? You might have some debris in the perch or somewhere else. Also if still on stock struts it might have something to do with those.
__________________
SPCBA is offline   Reply With Quote
Old 10-29-2013, 06:24 PM   #5
LS3 SS

 
LS3 SS's Avatar
 
Drives: 2010 Cyber Grey Camaro SS (LS3)
Join Date: Mar 2010
Location: Clarksville TN
Posts: 2,241
Quote:
Originally Posted by SPCBA View Post
I am confused do you have coilovers or springs? You might have some debris in the perch or somewhere else. Also if still on stock struts it might have something to do with those.
I have springs. The technical word for them is "coil springs", which is why I used that word.


The sound has actually gotten worse. Now not only does it squeak, but you can physically hear a metallic clacking, almost like a component of the rear suspension is loose, and slamming against something every time I hit a bump.
__________________
PCM of NC '545' Cam/PRC 255s/GM 3.91s/ProCharger D1SC @9psi 669 rwhp/546 rwtq Tuned by Alvin @ PCM of NC
LS3 SS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.