Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Anthony @ LG Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 10-30-2013, 09:09 AM   #15
f5journal
Senior Camaro Fanatic
 
f5journal's Avatar
 
Drives: 2011 SS/RS manual - White
Join Date: Aug 2010
Location: aiken, sc
Posts: 1,967
Engine failed first...Oil pump failed second...I've read every one of these threads in the past 4 years
__________________
Former '68 and '69 Z/28 Owner...........Now sporting around in a 2011 RS/SS with........Kooks LT's and cats, JRE tune, CAI, scoop, ZL1 Bumper conversion, custom ZL-1 grille, halo harness, Painted silver stripes, GM GFX, black painted lower edge of skirts and rear bumper. MGW shifter.....and now a 3.91 1LE diff
f5journal is offline   Reply With Quote
Old 10-30-2013, 09:22 AM   #16
VADER SS L99


 
VADER SS L99's Avatar
 
Drives: Z71, 2001 Trans Am, 2013 A6 GT 5.0
Join Date: Nov 2009
Location: Edmond, OK
Posts: 2,908
Quote:
Originally Posted by gr8daneh View Post
Thanks! Appreciate the empathy...



CAM Is missing a chunk, not sure that happened first. Comp CAM, Mobil synthetic. Thanks for the wishes.
Underlined in red is a big part of your problem and could be the source. M1 has no business being in a cammed engine. The aftermarket cams just have too fast of a ramp rate and M1 in ANY weight either does not have the film strength or correct amount of ZDDP. There have been too many lifter/cam failures in the last couple of years and almost all of them (including me) had M1 in the crank case. Anyone who reads this should be warned. Don't use M1 of any type or weight no matter what your tuner/builder recommends if you have a aftermarket cam. The oil just is not what it used to be.
__________________
BLK/BLK 1SS/RS Ordered 11-01-2009 Took delivery 12-22-2009. Heads/cam/converter/bolt ons. SOLD Feb 2015 to fund 6th gen LT1 SS with 8L90E.
VADER SS L99 is offline   Reply With Quote
Old 10-30-2013, 09:34 AM   #17
Drew10
Enjoys a good train wreck
 
Drew10's Avatar
 
Drives: 2010 IBM Camaro 2SS/RS
Join Date: Nov 2009
Location: Cincinnati, OH
Posts: 1,801
Sorry to hear of your troubles gr8. There really isn't much going on inside of these pumps for them to be having all these problems. Couple of gears, a spring, check ball is about it. Must be bad materials.

What kind of oil do you guys running cams recommend? I have the G6X3 cam, which is pretty radical, and I would rather be safe than sorry. Does Royal Purple have the additives in it to reduce wear on the cam lobes? I thought about trying Joe Gibbs oil because it has the zink additive in it.
Drew10 is offline   Reply With Quote
Old 10-30-2013, 10:25 AM   #18
SSDan

 
SSDan's Avatar
 
Drives: 2016 1SS 6MT NPP
Join Date: Feb 2010
Location: Leesville, SC
Posts: 1,089
Quote:
Originally Posted by Drew10 View Post
Sorry to hear of your troubles gr8. There really isn't much going on inside of these pumps for them to be having all these problems. Couple of gears, a spring, check ball is about it. Must be bad materials.

What kind of oil do you guys running cams recommend? I have the G6X3 cam, which is pretty radical, and I would rather be safe than sorry. Does Royal Purple have the additives in it to reduce wear on the cam lobes? I thought about trying Joe Gibbs oil because it has the zink additive in it.
Drew - its highly recommended by many on this forum and elsewhere to run an oil that has higher zinc and phosphorus additives (ZDPP) than the current formula for Mobil 1. These additives have anti-wear properties that are good for us guys running higher lift cams. I run Royal Purple "HPS". It has the anti-wear additives. I use RP per my builder's recommendation (Ron @ Vengeance Racing). Joe Gibbs has a good reputation as well.

Others may well jump in with some "RP is crap" comments. While I respect their opinion - I just respect Ron's more. That oil is the only oil he uses in his street builds.

I've been very happy with this oil for about 10K miles now. My valve train is a little less noisy and I have a little less blow by in my catch can. Not sure if those are because of the oil or just there are more miles on the engine and everything is well broken in. But I like the results.
__________________
2016 Camaro 1SS Hyper Blue 6MT NPP

2010 Camaro 2SS Cam/Headers/CAI/3.91 gears
476 rwhp/440 rwtq (sold)
SSDan is offline   Reply With Quote
Old 10-30-2013, 10:44 AM   #19
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,337
Quote:
Originally Posted by BigRed View Post
May I ask why? I'm actually curious due to the fact I'm going in for a Cam install Monday and that's what they said they are going to put in the car.
Vader pretty much summed it up. If you go with a cam then you should also change oil. Amsoil zrod, vr1, joe Gibbs, rp all are good oils.
__________________
2001 ws6, 40k miles, Ls3 416 stroker, short block built by PER the rest by me. LPE Ls3 heads milled to 12-1 comp, FAST 102, NW 102, kooks 2", dual DMH cutouts, Magnaflow C/B, BTR cam + springs. Full UMI suspension.
litle88 is offline   Reply With Quote
Old 10-30-2013, 12:40 PM   #20
JWoj3540
 
JWoj3540's Avatar
 
Drives: 2012 2SS/RS M6
Join Date: Jul 2011
Location: Metro Detroit
Posts: 673
OP, it pains me to hear this...sorry man. On another note, some of you "failure mode" language tells me that you have done a DFMEA or two in your lifetime
JWoj3540 is offline   Reply With Quote
Old 10-30-2013, 03:55 PM   #21
376LS3
Eh, that'll happen
 
376LS3's Avatar
 
Drives: 2010 2SS
Join Date: Apr 2012
Location: Mesa, Arizona
Posts: 1,843
Quote:
Originally Posted by litle88 View Post
Mobil 1 makes me cringe when guys/gals get aggressive cams
That hilarious cause I cringed when I saw that too! I see you recommend RP. Did they change their setup at all? I had read a couple posts on LS1TECH that the oil was too slippery and sometimes actually caused sludge. I switched to Valvoline Synpower since VR1 got pulled from the shelves. So far so good!
__________________
2010 Camaro SS LS3 - No Modz
376LS3 is offline   Reply With Quote
Old 10-30-2013, 04:50 PM   #22
JDP Motorsports

 
JDP Motorsports's Avatar
 
Drives: 2011 Camaro SS/ 2016 Camaro SS
Join Date: Jun 2009
Location: Sandy, Utah
Posts: 3,412
Whenever I get the dreaded call that a customers car has lost oil pressure I cringe.. I've had customers run them for what they think is 30 seconds but the issue is we rely on the warning to alert us opposed to watching the oil pressure; that could be 2 minutes plus of low pressure before a complete pressure loss occurs. This car is very well taken care of so it isn't a maintenance issue.

I've had the stock pumps fail in 100% stock LS cars, in bolt-on LS cars and in LS cars with cam packages. I haven't seen as many until 2010 and we always assumed it was a bad batch from GM; remember there batches are HUGE. We've always replaced the OEM pumps with new OEM units in the 2010 Camaros just to be safe but we've had a few check valves stick this year and we've since gone to the Melling pumps. I talked with our GM rep and they are aware of the issue but in their world it is such a small percentage that it doesn't warrant change; I would disagree.

The scoring on the cam is seen on stock cams as well as aftermarket cams and in this case the cam was pretty mild. I think that the check valve starts to cause lower pressure as it sticks and the first place that suffers from that lack of pressure is the top end. I also think oil should be changed every 3K miles or 3 months; dirty oil can cause these failures as well. I have people tell me their oil is good for 5K miles or their Oil Life Monitor says they have 20% until a change is required; I disagree. The filter only has so much capacity and you can call me old school all day long but I change my oil at no more than 3K miles or 3 months. I'm not saying that is the case here but it is always a good idea.

We've done testing on numerous cam packages in long duration high RPM instances over thousands of miles with Mobil1 and we haven't has issues. I do prefer Red Line personally but it is twice the cost of Mobil1 and I also like the PF48R filters over the PF48. There are other good premium brands out there as well I just prefer Red Line.

She is back together with our Stage II camshaft and new lifters.



I appreciate your support and I'm always happy to answer questions, Dane. I'll let you know when the tuning is buttoned up and she can come back home.

Kind regards,

Jordan Priestley
888.308.6007
__________________

Click HERE to send me a PM | Sales@jdpmotorsports.com | www.jdpmotorsports.com | 801-545-4215
JDP Motorsports is offline   Reply With Quote
Old 10-30-2013, 04:59 PM   #23
strych9
Gone Euro!
 
strych9's Avatar
 
Drives: 6spd Manual Mercedes, Daytona 955i
Join Date: Apr 2012
Location: Omaha, NE
Posts: 3,036
Quote:
Originally Posted by JDP Motorsports View Post
Whenever I get the dreaded call that a customers car has lost oil pressure I cringe.. I've had customers run them for what they think is 30 seconds but the issue is we rely on the warning to alert us opposed to watching the oil pressure; that could be 2 minutes plus of low pressure before a complete pressure loss occurs. This car is very well taken care of so it isn't a maintenance issue.

I've had the stock pumps fail in 100% stock LS cars, in bolt-on LS cars and in LS cars with cam packages. I haven't seen as many until 2010 and we always assumed it was a bad batch from GM; remember there batches are HUGE. We've always replaced the OEM pumps with new OEM units in the 2010 Camaros just to be safe but we've had a few check valves stick this year and we've since gone to the Melling pumps. I talked with our GM rep and they are aware of the issue but in their world it is such a small percentage that it doesn't warrant change; I would disagree.

The scoring on the cam is seen on stock cams as well as aftermarket cams and in this case the cam was pretty mild. I think that the check valve starts to cause lower pressure as it sticks and the first place that suffers from that lack of pressure is the top end. I also think oil should be changed every 3K miles or 3 months; dirty oil can cause these failures as well. I have people tell me their oil is good for 5K miles or their Oil Life Monitor says they have 20% until a change is required; I disagree. The filter only has so much capacity and you can call me old school all day long but I change my oil at no more than 3K miles or 3 months. I'm not saying that is the case here but it is always a good idea.

We've done testing on numerous cam packages in long duration high RPM instances over thousands of miles with Mobil1 and we haven't has issues. I do prefer Red Line personally but it is twice the cost of Mobil1 and I also like the PF48R filters over the PF48. There are other good premium brands out there as well I just prefer Red Line.

She is back together with our Stage II camshaft and new lifters.



I appreciate your support and I'm always happy to answer questions, Dane. I'll let you know when the tuning is buttoned up and she can come back home.

Kind regards,

Jordan Priestley
888.308.6007
Excellent info! I disagree with the film strength argument made by another poster, as Mobil1 has a very high film strength rating. Zinc...could be a factor, but I would be interested to see some analyses. Several big-name performance builders use and recommend Mobil1 with their builds and installs, so it's hard to know who to believe.
__________________
Bye bye, Bumblebee!
---------------------------------------------------------------------------------------
strych9 is offline   Reply With Quote
Old 10-30-2013, 06:17 PM   #24
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,337
What big name performance builders recommend mobil1?
I've heard of redline being good too, no personal experience but I use redline d4 tranny fluid and it's good stuff.

No I'm still not a fan of RP but I've known others here in the area that use it, their formul has changed from what they showed me.
__________________
2001 ws6, 40k miles, Ls3 416 stroker, short block built by PER the rest by me. LPE Ls3 heads milled to 12-1 comp, FAST 102, NW 102, kooks 2", dual DMH cutouts, Magnaflow C/B, BTR cam + springs. Full UMI suspension.
litle88 is offline   Reply With Quote
Old 10-30-2013, 06:41 PM   #25
Irnwkrkev
 
Irnwkrkev's Avatar
 
Drives: 2011 SS/RS LS3
Join Date: Oct 2010
Location: Miami
Posts: 521
Quote:
Originally Posted by litle88 View Post
What big name performance builders recommend mobil1?

A few years ago I read a thread where Slohawk recommended 0W40 Mobile 1 exclusively.

He's not an active member on this board anymore but I believe a certain high post count member from the north east has just started using him to wrench on his car
Irnwkrkev is offline   Reply With Quote
Old 10-30-2013, 06:53 PM   #26
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,337
Lol yea, does he still use it? Lots has changed in the last few years with the Feds made the oil companies take out zinc and zdpp due to "cats" lifespan.
__________________
2001 ws6, 40k miles, Ls3 416 stroker, short block built by PER the rest by me. LPE Ls3 heads milled to 12-1 comp, FAST 102, NW 102, kooks 2", dual DMH cutouts, Magnaflow C/B, BTR cam + springs. Full UMI suspension.
litle88 is offline   Reply With Quote
Old 10-30-2013, 07:00 PM   #27
Irnwkrkev
 
Irnwkrkev's Avatar
 
Drives: 2011 SS/RS LS3
Join Date: Oct 2010
Location: Miami
Posts: 521
Maybe Jamie can let us know
Irnwkrkev is offline   Reply With Quote
Old 10-30-2013, 07:17 PM   #28
litle88
V8 Lounge member #2
 
litle88's Avatar
 
Drives: 2001 Ws6
Join Date: Sep 2009
Location: Burbank,IL
Posts: 6,337
I'll just ask slow hawk tomorrow.
__________________
2001 ws6, 40k miles, Ls3 416 stroker, short block built by PER the rest by me. LPE Ls3 heads milled to 12-1 comp, FAST 102, NW 102, kooks 2", dual DMH cutouts, Magnaflow C/B, BTR cam + springs. Full UMI suspension.
litle88 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.