Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
River City Camaro Customs
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 07-27-2009, 01:45 AM   #1
Paperer
Ragin' Cajun
 
Paperer's Avatar
 
Drives: '02 Camaro SS - '10 CGM 2SS/RS
Join Date: Jul 2008
Location: Texas/Oklahoma
Posts: 1,170
Horrible Brake Squeal

Okay, going down the highway, and all of the sudden, the left brake begins to make an awful squeal as if it's locking up, I'm not far from home, so I turn around. It's just basically screaming the highest pitch you could think of all the way back at any speed.

I park and look at it, then I decide to head to the dealership. I get a quarter mile down the road, and it stops, I drive around some more and everything is good.

Anyone have any idea what could have caused this? It only as about 500 miles on it. You couldn't feel the brake or anything, it wasn't holding back much at all. It was just the highest pitch noise you could think of. A person in front of me pulled over because they thought something was wrong with their vehicle.

I've read that it could be brake dust???

Oh, it's a CGM 2SS/RS
__________________
http://img.photobucket.com/albums/v202/paper2302/Siggy.jpg
Paperer is offline   Reply With Quote
Old 07-27-2009, 09:34 AM   #2
firestone_ss
 
firestone_ss's Avatar
 
Drives: 2010 camaro ss
Join Date: May 2009
Location: Tacoma WA
Posts: 739
my GUESS is you had some type of debri wedged in between the pad and rotor and it worked its way out,rock,pebble dirt that kind of stuff,not uncommon
firestone_ss is offline   Reply With Quote
Old 07-27-2009, 10:19 AM   #3
Mr Twisty


 
Mr Twisty's Avatar
 
Drives: the 2nd amendment home
Join Date: May 2008
Location: OK
Posts: 14,307
That was the LS3 telling you you're hitting the wrong pedal!

OK, seriously, the other response was probably correct. You can keep an eye on that rotor, make sure it isn't wearing strange.
__________________
"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety."
-- Benjamin Franklin
Great Racing Quotes

"Never run out of real estate, traction and ideas at the same time."
"I was doing fine until about mid-corner when I ran out of talent."
"Don't brake until you see God, just don't meet him"
Mr Twisty is offline   Reply With Quote
Old 07-27-2009, 10:55 AM   #4
CamaroSkooter
Retarded One-Legged Owl
 
CamaroSkooter's Avatar
 
Drives: 2010 Black Camaro 2SS
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 9,684
Did your caliper weights fall off?
CamaroSkooter is offline   Reply With Quote
Old 07-27-2009, 12:12 PM   #5
Scott@Bjorn3D


 
Scott@Bjorn3D's Avatar
 
Drives: Kami, 2013 2SS LS3 Luvin
Join Date: Oct 2008
Location: Eufaula, Alabama
Posts: 6,064
Send a message via MSN to Scott@Bjorn3D
I would tonight park the car and let it cool off for 1 hour or so. The crawl down by the wheel and feel the surface front and back of the disk to make sure it did not get a groove cut in it. I have seen small rocks get in between the pad and disc and do some major damage to the disc. If it cut a deep groove in the disk you pad could start forming a groove in it when braking and cause issue and maybe a locked wheel.

Better safe than sorry. Check it.
__________________
2013 2SS, GM Strut Tower Brace, CAI Intake Black, VMAX TB, Elite Catch Can, Hotchkis Chassis Brace, Hurst Shifter, 3.91 1LE Complete Rear End, NPP, 1LE Track Pack,Factory Reproductions Style 41 ZL1 Fitment Wheels 10" on all 4 corners

Last edited by Scott@Bjorn3D; 07-27-2009 at 12:38 PM.
Scott@Bjorn3D is online now   Reply With Quote
Old 07-27-2009, 12:29 PM   #6
coolman
Guest
 

Join Date: Jun 2009
Location: PA
Posts: 4,871
Was the car pulling to one side when this was happening? I know this is a dumb question but did you have the e bake fully released?
coolman is offline   Reply With Quote
Old 07-27-2009, 12:35 PM   #7
Paperer
Ragin' Cajun
 
Paperer's Avatar
 
Drives: '02 Camaro SS - '10 CGM 2SS/RS
Join Date: Jul 2008
Location: Texas/Oklahoma
Posts: 1,170
Yeah, you guys may be right, they've been doing a ton of road work everywhere around here, odds are it was some rock or other debris from all the work they're doing.

I'll go take a peek and see if there's any noticeable wear.
__________________
http://img.photobucket.com/albums/v202/paper2302/Siggy.jpg
Paperer is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Camaro Brembo Big Brake Kit, Installed!! SS Mike Suspension / Brakes / Chassis 125 09-09-2010 12:34 PM
Hawk Performance Brake Pad "Updated" KILLER74Z28 Suspension / Brakes / Chassis 33 03-06-2010 04:32 PM
brake dust ssmike Wheels and Tires Talk Sponsored by The Tire Rack 7 09-05-2009 10:44 PM
brake jobs Iroczlover Off-topic Discussions 16 11-03-2008 09:36 AM


All times are GMT -5. The time now is 02:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.