Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 06-21-2014, 07:03 PM   #1
Bubble85
 
Drives: 2012 SS
Join Date: Sep 2012
Location: Deale, MD
Posts: 261
Grinding/rattling sound

My v3 head unit has started making this grinding/rattling sound. I checked the oil and changed it any ways but there was no sign of any thing wrong there. I pulled the belt and moved the pulley around and it seems like it's loose internally? I have a video I can text or email if any one can help me out. Thanks
Bubble85 is offline   Reply With Quote
Old 06-23-2014, 06:53 AM   #2
Bubble85
 
Drives: 2012 SS
Join Date: Sep 2012
Location: Deale, MD
Posts: 261
Maybe this will help
http://youtu.be/fRln79UC9ok
Bubble85 is offline   Reply With Quote
Old 06-24-2014, 08:26 PM   #3
redirish

 
redirish's Avatar
 
Drives: 10' IOM 2SS/RS/M6
Join Date: Sep 2009
Location: New Jersey
Posts: 1,179
Mine is making some noise but yours is a lot louder. Did you contact Vortech?
__________________
redirish is offline   Reply With Quote
Old 06-24-2014, 09:31 PM   #4
Bubble85
 
Drives: 2012 SS
Join Date: Sep 2012
Location: Deale, MD
Posts: 261
Yes and they said it's probably normal. They said it would be really loud if it was an issue I just know that it's louder than it used to be
Bubble85 is offline   Reply With Quote
Old 06-25-2014, 02:17 PM   #5
bct10985

 
Drives: 2010 2SS LS3, 2013 duramax
Join Date: Nov 2012
Location: Dover, De
Posts: 1,118
Did u pull off the filter and check if the impeller is ok
__________________
ECS Novi 1500 supercharger, FSP cam, Tsp 2" longtubes, Squash dual pumps, Id850s, Aem meth, Jakes stageIII 4L80e, FTI 3600, ZL1 3.73 diff, BMR suspension, 17" weld rts 4.5" M&H skinnies front, carlyle racing 15" conversion mt 325 et street R. 650rwhp mustang dyno. 10.93@125 1.6 60'- m6 stock cam.
bct10985 is offline   Reply With Quote
Old 06-25-2014, 03:46 PM   #6
redirish

 
redirish's Avatar
 
Drives: 10' IOM 2SS/RS/M6
Join Date: Sep 2009
Location: New Jersey
Posts: 1,179
Quote:
Originally Posted by Bubble85 View Post
Yes and they said it's probably normal. They said it would be really loud if it was an issue I just know that it's louder than it used to be
Is there a local performance shop that you can bring your car to to take a look at it?
__________________
redirish is offline   Reply With Quote
Old 06-25-2014, 04:23 PM   #7
Bubble85
 
Drives: 2012 SS
Join Date: Sep 2012
Location: Deale, MD
Posts: 261
Checked and spun impeller everything looks good. My shop is an hour away I didn't want to have to take off work just to have them look at and tell me if I should send it in to vortech but it looks like I'll have to
Bubble85 is offline   Reply With Quote
Old 06-25-2014, 07:44 PM   #8
redirish

 
redirish's Avatar
 
Drives: 10' IOM 2SS/RS/M6
Join Date: Sep 2009
Location: New Jersey
Posts: 1,179
Let me know how you make out
__________________
redirish is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:31 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.