Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Flowmaster Exhaust
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 01-05-2013, 03:13 AM   #301
silverbulletbitit
 
Drives: 2010 Camaro 1Lt
Join Date: Oct 2012
Location: TX
Posts: 1
Anone from Texas?

Has anyone from Texas found an attorney for the problems with the 2010 1Lt yet? I've had an open case for months and it's just recently been closed. I took my car to 2 dealers while under warranty....with engine light on and the airbag light on.....and was told it was just a "sensor" problem. Towed my car over an hour away to a mechanic that has a degree in engineering and he found the problem. GM refuses to pay for these problems. I saved the parts, ran to every dealer they asked, missed work, was out money for rental cars...and the car is still messing up! Not to sound like a broken record from previous post, but problems with:
1.Stabilitrack
2.Check engine light/reduced engine power and car stalling in major traffic
3.Slow start
4.RPM idles high
5.Stalling frequently
6.Paint chips all over the car
7. Strange noise from front of car when I hit a bump, sometimes grinding sometime a bumping.
8. Front end shakes over 50.


Things I have had to pay to replace:
1.GM warranty convered power steering pump 2 months after car was purchased.
2.Gears
3.Actuator Solinoid (related to cam shaft I think)
4.Timing chains
5.Tensioners
6. Rotors had to be turned really soon
7.Purchase of 18 tires!

I'VE PAID OVER $12,000 IN REPAIRS AND PARTS FOR A $26,000 2 YEAR OLD CAR!

I have all records of every oil change, tune-up, tire rotation, and work done on my car. NO modifications. The dealer states they don't have records of ever working on my car, but fortunately I saved the receipts from 2 years ago.

I'm exausted....I'm ready to torch this car! I think this car is beautiful and I love it, if it would only run! I bought it because I am a special needs pediatric nurse, I work in homes with children that are disabled. I work mainly with little boys. When I take those kiddos for a ride in that car, you wouldn't believe the responses I can get from them! It is the most amazing thing to see a child light up ! The kiddos parents see an expression from an otherwise expressionless child....for some of these kids it's a wish come true....I love bringing that joy to them....and a Mustang or Challenger can't do that...I work with Mustang and Challenger nurses...they don't get the Camaro response.

I just want my car to work! I don't know what else steps to take. This car is as well taken care of as one of my kids or patients. I have been methodical with maintainance and cleaning, is there any attorney out there willing to help getting the ball rolling on these problems? Look at all these post! So many people are having the same problems....GM has refused most of us help. What can we do?

PS I would attach pic of the "silver bullet", but the paint is chipped to hell and when the dealer replaced my driver side door they couldn't match the paint so it looks like crap....oh, and a small rock hit the windshield and it immediately cracked, so it has this huge crack across the windshield....think it should be called Frank-en-maro!
silverbulletbitit is offline   Reply With Quote
Old 01-11-2013, 12:03 PM   #302
Kylegrantham
 
Kylegrantham's Avatar
 
Drives: 2012 Camaro 2LT RS
Join Date: Dec 2012
Location: Casper, Wyoming
Posts: 14
Quote:
Originally Posted by electricblue2ss View Post
I need your help and am glad to see all you experts on here. I will try and make this as simple as possible:

Have a 2010 Camaro 2SS, automatic; it was bought with only 10K miles on it. It currently has 41K miles on it, so it has been driven 15K miles a year since buying it. During the 1st 36K miles it behaved fairly well. No major issues, except found that the brakes already had to be replaced @ approx. 30K miles. This included the rotors.

Then, the problems started, shortly after the bumper-to-bumper warranty expired.

Problem # 1: The car was shaking at 30 miles +an hour. If you drove it any faster, it almost became impossible to steer, and it was more apparent as the RPM's increased to 2,000. We took it to the local dealership who had been servicing the car, and they had it for a couple of days before calling us and saying they were suspecting the rear tires. Now, those tires were close to the need of getting replaced, but nowhere bald, and nowhere uneven. It didn't make complete sense, but I went along with it. As I went to get the car, they came back out and said: "We took the car for a test drive with the new tires and it is still shaking." Great!?! I went back home, and the next day I called back. The service contact person said to me that the technician had not taken the actual car apart when diagnosing it; he went on a hunch. They then quoted me another 3 days to do an actual diagnosis and wanted me to pay for it. Wait a minute - they didn't even know if it was a power train warranty covered item, and yet they were ready to start charging me. After two more days they told me they did not have the problem figured out yet, and I grew concerned because we needed the car for transportation. So, I called my insurance company and figured they employed automotive experts. Sure enough, they helped me by bridging me to one of their independent contractors who took me through the entire process of how to move forward. He suggested I have the car towed to another dealership, and start over. I figured it to be a good idea because clearly the other dealership was not with the program. It was towed north of the city, and the expert from our insurance company actually drove up there and inspected the vehicle with the technician. They found the culprit to be the "knuckle" - it was defective and needed to be replaced. It was not a tire issue, whatsoever. Once replaced, the car drove perfectly.

Fast forward to 3 weeks ago -

Problem # 2: The stability track light came on; however, the car seemingly was driving fine. After a few days, more lights came on, including the engine light. I took it back to the dealership that fixed the car for Problem # 1. They called me and told me that the battery needed to be replaced. That seemed a little soon, but I was told that with a bad battery, the lights would often come on even if there were no issues. By putting a battery in to test if other lights came on, they would be able to see if there were other problems. They charged me $ 327 for a new one, including labor. Seemed steep to me. But we know how this goes, right? They have your car, they know you have to work and can't drive around for all these quotes, etc. And, potentially, there were other issues as well. I gave the go-ahead. After the battery had been replaced, another light came on and it I get another call telling me that the speed sensor was defective and that was causing the original stabili-track light to come on. Okay, by the time they were done with all the work, the total charge for the two items was $ 642. This just seems insane to me.

Problem # 3: Yesterday, the engine light came on AGAIN!!! The car wont idle now. It is sputtering and barely seems to hang on when idling. We have been at an intersection and it has died; starting it back up is not a problem, but it is dangerous and not reasonable to already have a problem again. I called the technician back and I brought up the fact that this car was not on a good path. I voiced my concerns and asked him if he didn't think this was a bad sign....he said: "I don't really remember the issues it has had before; I just remember you and the car itself." Oh, really? Because 3 weeks ago when you were wanting to earn our business again, you remembered everything about the "knuckle" issue. All he offered this time was: "I can't help you if you don't bring the car in..." Right, and I can't keep bringing the car in. But, clearly, it has to be checked again before anyone can drive it safely.

So, here are my questions to this group:

1) What qualifies as an "Express Warranty" when it comes to a 2010 Camaro, after the bumper-to-bumper warranty has expired?

2) Is the knuckle, speed sensor, and/or battery considered covered under power train? (From reading the warranty information I can't decipher Yes or No).

3) Would you start a dialoque with GM if you were me? Neither dealership has shown consistent ability to keep this car on the road since the bumper-to-bumper warranty expired. But, they manage to easily charge me.

**I, of course, do not know what Problem # 3 is yet, but I think arming myself with knowledge before going will be better this time.

Thank you for all your help in advance.
Sounds like you've had for a while the same problem I'm having with mine now. Head gasket failure. See thread: http://www.camaro5.com/forums/showthread.php?t=267680
__________________
"Roads? Where we're going, we don't need roads." - Doc Brown

2012 Camaro 2LT RS, County Road 408, 20 miles south of Casper, Wyoming
Kylegrantham is offline   Reply With Quote
Old 01-13-2013, 10:08 PM   #303
Froglevel
Froglevel
 
Drives: 2012 45th Anniversary Coupe
Join Date: Dec 2012
Location: Eastern North Carolina
Posts: 9
Serious problem with GM Dealer Service

Here is how it starts. I have a 2012 45th anniversary ss. I treat this car like a queen and am downright foolish about parking in remote areas so some nimrod in a beater doesn't ding it or get too close. I wash it weekly and am as intimate with the body of this car as I am my wife's. I started having problems with the service tire sensor light coming on. First time I immediately took it to the nearest dealer not sure what the problem was and wanting to be diligent about addressing issues before they got worse. They relearned the sensors and while they install nitrogen. Within a day it started showing the same error. I took it right back and they relearned it again. Over the holidays it came on nearly daily with no rhyme or reason. It might be first thing upon cranking, after 30 minutes of driving, warm days or cold. I took it back this week and they shop foreman stated he needed to drive it with his laptop in the call to delve deeper, but he forgot to charge it and asked I bring it back and drop it off. I did so and they called later stating the left rear sensor was stuck in learn mode so they replaced it. I drove home and parked it the yard. The light did not come on during my trip home. I was happy thinking the issue was resolved. The next day the weather in eastern NC was perfect for a wash and detail. As I made my way to the side that the bad sensor was on I found huge scratches down to the metal. ....I can assure you that was not there previously. I continued cleaning at a low boil. I the began cleaning the rims and found all four rims had terrible scratches in the finish. Now I am at a slightly lower temperature than the face of the sun. Finally i am wiping down the inside of the door sills and see the door sill plate is bent up and peeled away. I spent a great deal of money for this car and treat her like a queen. Now to top it off as I drove to lunch with my wife that damn service tire sensor light came on again. I am now thermonuclear. I am going back to the dealer tomorrow expecting four new rims, a repaint of the damaged area, a replacement sill plate and it wouldn't hurt to throw in some 45th anniversary floor mats to make it up to me. They had to have noticed the scratch, damaged rims, and sill plate, but never said a word. Is this the expected level of service on a $45,000 car? I would have been upset if they discussed this with me when I picked it up if they had admitted the mistakes and offered to make it right, but they merely let me drive off to discover on my own. This has to be the poorest customer service ever.

Kevin Harris
Wilson, NC
Froglevel is offline   Reply With Quote
Old 01-14-2013, 03:59 PM   #304
ahreedjr
 
Drives: 2011 lt1 6cyl auto.
Join Date: Dec 2012
Location: Lititz PA
Posts: 1
I have a 2011 LT1 with auto tranny. I have had in the shop about 4 time talked to Customer Rep a dozen times and the last time I was told the problem (chuggles and vibrates at 1150 to 1250 RPM) is the natural vibration of the engine. Which as an engineer I don't believe. It is embarassing to drive a new shiny Camoro and have a passenger say wht is that noise and vibration. I essentially have given up. I am a life long die hard GM owner (63 years old) but I have lost faith. GM rep and the dealer has been insufferable at times. They truly do not know how to treat a customer (some of them that is and I talked to three customer reps and two service managers at two dealers.
ahreedjr is offline   Reply With Quote
Old 01-23-2013, 04:39 PM   #305
digger13
 
Drives: Black 2011 Camaro SS
Join Date: Jul 2012
Location: Albany GA
Posts: 32
The quality control and the customer service of GM is a joke! Car ran dry on oil twice. Motor made all kinds of racket. Dealer finally changed the oil pump. Then they say there is no damage to the engine even though it was ran without oil. They have no way of telling this. They refuse to check it or to extend the warranty on the motor. There is no way I will put 100k miles on this car within the 5 year powertrain warranty. I have 12k miles on my car now and will have maybe 40k miles at the 5 year warranty mark. I bought this car to pass down to my son when he turns 18 in 10 years but now it seems its getting traded in and I will never touch another GM vehicle. My wife has owned Honda cars for the last 10 years and rarely did anything go wrong, but when they did, Honda STOOD BY their warranty and quickly came up with a solution. When these cars first came out, I had my eyes on them and saved up for 2 years to get one. What a disappointment.
digger13 is offline   Reply With Quote
Old 02-09-2013, 01:25 AM   #306
2012CONVERTIBLE2SS
 
Drives: 2012 Camaro 2SS Convertible
Join Date: Feb 2013
Location: oklahoma
Posts: 1
I need your help!!

I bought my car in April of 2012, a yellow and black 2SS convertible (if my screen name didn't give it away!!). I had to have the HEADS UP DISPLAY replaced at 8k miles because it just went out! Had the carpet replaced because it was cut too short and wouldn't fit under the passenger door sill. Had to have the convertible top replaced just a month ago (8 months old)because there was a 1" circle that was wearing through just above the driver's door. The dealer sublet the convertible top and the first time I put it down the rubber seal between the top and the trunk rolled up and came to rest on the rear window. The passenger side rear window will not roll up all the way and that leaves a 3/4" gap between the two windows. Also, there are wires exposed on both sides of the top, just above the rear windows. The car has been in the shop twice for stalling on acceleration, not every time, but at least a couple of times a month. Have taken it in at least 4 times for the leather bubbling on the dash. The last two issues they can't seem to fix. The stalling issue the are trying to blame on bad gas (below 91 octane) but the only gas I have ever used is 91 octane or higher. The dash bubbling, I was told by the dealer, is a problem that GM is aware of, but has no remedy for. If there is no remedy, shouldn't that fall under the lemon law? I have called the Chevrolet customer service number 1-800-222-1020. I had asked for some trade assistance to get into a different one. I was told that GM would not be able to help.
I was employed at the dealership at the time and knew of a guy that had problems with brake dust on the wheels of his 2010 2SS with 45k miles and GM gave him $5000 in trade assistance toward a 2013 2SS.
I'm getting very frustrated with this whole thing.....like everyone else on here, I LOVE MY CAMARO!!! Don't want another car, just don't think I should be stuck with this one..........$45k for a car that falls apart in less than 8 months?? Can you help me?

P.S.
I almost forgot to mention the paint peeling on the front bumper......a place about 3/4" x 1" rectangle on the passenger side just above the driving light...
2012CONVERTIBLE2SS is offline   Reply With Quote
Old 05-18-2013, 04:05 PM   #307
Mayhem2011
 
Drives: 2011 Camaro convertible
Join Date: May 2013
Location: ohio
Posts: 1
Vert top problems

Camaro Pete I have been having problems with my vert top. You wouldn't believe the problems. I am exhausted by the run around by The whole process. I see you have an escalation process does it really work?
Mayhem2011 is offline   Reply With Quote
Old 08-18-2013, 11:47 PM   #308
xX_BLACK_INFERNO_Xx
 
xX_BLACK_INFERNO_Xx's Avatar
 
Drives: 2011 SS/RS
Join Date: Apr 2013
Location: Turdburg, ms
Posts: 134
anyone still helping out with this escalation process?
xX_BLACK_INFERNO_Xx is offline   Reply With Quote
Old 10-09-2013, 11:12 AM   #309
SSTG

 
SSTG's Avatar
 
Drives: 2014 Z51 Corvette
Join Date: Apr 2011
Location: Ofallon, Mo.
Posts: 5,562
Quote:
Originally Posted by xX_BLACK_INFERNO_Xx View Post
anyone still helping out with this escalation process?
I'd like to know also?
Is this thread dead?
SSTG is offline   Reply With Quote
Old 10-10-2013, 01:16 AM   #310
xX_BLACK_INFERNO_Xx
 
xX_BLACK_INFERNO_Xx's Avatar
 
Drives: 2011 SS/RS
Join Date: Apr 2013
Location: Turdburg, ms
Posts: 134
Seems like it.
xX_BLACK_INFERNO_Xx is offline   Reply With Quote
Old 07-05-2014, 06:30 PM   #311
rmaringa
 
Drives: 2012 Black Camaro
Join Date: Apr 2013
Location: Florida
Posts: 25
GM is just as much at fault as any dealership for not implementing some serious oversights into how their product is sold and handled.
rmaringa is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAMARO WIKI Tran Wiki 49 09-09-2014 06:46 AM
Gran Turismo 5... No Camaro? 5thGenOwner 5th Gen Camaro SS LS LT General Discussions 111 12-06-2011 11:06 AM
Camaro Scotty Camaro inventory - Fly in or we'll ship to you! CamaroScotty Dealer Camaros for Sale 40 05-24-2010 10:52 PM
Major Pedders Event in Houston! Saturday, Jan 30th! Meet DMS Info@PeddersUSA.com USA - Texas 39 02-01-2010 01:48 PM


All times are GMT -5. The time now is 02:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.