Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LLT Engine, Exhaust, and Bolt-Ons

Camaro V6 LLT Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 08-15-2014, 08:25 PM   #1
yab14
 
yab14's Avatar
 
Drives: camaro 14 1LTrs
Join Date: Jul 2014
Location: Wappingers falls
Posts: 25
gmpp muffler gets a thumbs up

I got these mufflers put on today and I think they're awesome!I was really worried about the bad feedback on here.definitely a deeper sound with a nice tone.the only thing that I don't like is that the end of the pipes are flush with the back bumper and u cannot see the chevy symbol on the chrome tips and that might be my fault for not telling the dealer what I wanted. so my question is is that normal or did the dealer cut the pipes too short?
yab14 is online now   Reply With Quote
Old 08-16-2014, 04:49 AM   #2
CamaroLS

 
CamaroLS's Avatar
 
Drives: 2011 Yellow Chevy Camaro LS
Join Date: Feb 2012
Location: Indiana
Posts: 1,179
Good to hear because I been thinking about going with these also!! Will you put up a video of what they sound like and the mods you have? From what videos I have seen they stick out like the OEM factory tips so sounds like they cut off more than they should have.
__________________
Roto-Fab intake, Vmax throttle body, Painted engine and fuse covers, Strut brace, Elite catch can, Custom yellow vinyl dash and door inserts, Center console gauges, Kicker stereo system, ZL1 pedals, ZL1 Rockers, Rear spoiler, SS Brembo brakes, Russell S.S. brake lines, 20" staggered Foose Legend wheels with Nitto Invo tires.
CamaroLS is online now   Reply With Quote
Old 08-16-2014, 10:33 PM   #3
yab14
 
yab14's Avatar
 
Drives: camaro 14 1LTrs
Join Date: Jul 2014
Location: Wappingers falls
Posts: 25
I will try to put up a video of Shortly
yab14 is online now   Reply With Quote
Old 08-20-2014, 06:12 PM   #4
iceman5730
Iceman
 
iceman5730's Avatar
 
Drives: 2011 Camaro 2LT SC/RS CGM
Join Date: Jan 2011
Location: Chilliwack British Columbia Canada
Posts: 573
When mine were install they were also flush with the rear valance. Was okay till I installed the IPF S/C after 1 road course the valance around the tips melted! The dealer replaced the valance and extended the tips All is good now
__________________
iceman5730 is offline   Reply With Quote
Old 08-20-2014, 07:53 PM   #5
yab14
 
yab14's Avatar
 
Drives: camaro 14 1LTrs
Join Date: Jul 2014
Location: Wappingers falls
Posts: 25
Sorry I tryed to upload a video but I can't get it on for some reason.video also doesn't sound the same as in person.there are a couple of videos out there on YouTube
yab14 is online now   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.