Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 03-20-2010, 02:36 PM   #99
Info@PeddersUSA.com

 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,903
Quote:
Originally Posted by pnyklr View Post
Mike,

In all your testing have you guys not experienced the front end noise?

-Funk
We have verified some concerns on the upper spring mounts for the front, but cannot go into this. But that is really it. We have checked hundreds of Camaros.

We have also verified noises related to the upper strut washer contacting the sheet metal when the upper mount begins to fatigue. I made a writeup on this and how to repair it. It is on this forum somewhere.

Mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 03-28-2010, 09:32 PM   #100
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,557
Seven Day Bump

-Funk
pnyklr is offline   Reply With Quote
Old 04-04-2010, 10:32 PM   #101
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,557
Seven Day Bump

-Funk
pnyklr is offline   Reply With Quote
Old 04-15-2010, 01:20 PM   #102
pnyklr

 
Drives: A Gift From My Wife
Join Date: Apr 2009
Location: Powder Springs, GA
Posts: 1,557
Eleven Day Bump

-Funk
pnyklr is offline   Reply With Quote
Old 04-15-2010, 03:56 PM   #103
Skyblu

 
Skyblu's Avatar
 
Drives: 2010 Aqua blue 2SS/RS M6
Join Date: Jul 2009
Location: Florida
Posts: 991
i still have the noise, they told me twice at two different dealers they wouldn't do anything about it, I'm more concerned with my tranny being in pieces as we speak a the deal for a knocking noise. Once I get that worked out, I'll throw the front end thing out to this new 3rd dealer I have taken my car to.
Skyblu is offline   Reply With Quote
Old 04-15-2010, 04:37 PM   #104
qbert48

 
qbert48's Avatar
 
Drives: 2SS SIM
Join Date: Apr 2009
Location: texas panhandle BFE
Posts: 1,128
subscribed I've got the clunk sound too:(
__________________
2SS RS SIM gray leather stick shift ground FX
thank you gary richards @ classic chevy in sugarland

welcome home
1100 4-27-09
6000 6-27-09


yes i got to the dance late don't hate me
qbert48 is offline   Reply With Quote
Old 04-15-2010, 06:44 PM   #105
Moorepheus

 
Drives: 2013 Dodge Charge R/T Plus AWD
Join Date: Jul 2009
Location: Niagara Falls, NY
Posts: 1,307
Wonder if my rattling noise from under the car is the same issue. Anyway. Dealer has her now looking for the problem
Moorepheus is offline   Reply With Quote
Old 04-15-2010, 07:15 PM   #106
Jarhead
Semper Fi Camaro
 
Jarhead's Avatar
 
Drives: 2010 1SS/RS Aqua Blue LS3 Gauge PKG
Join Date: Jan 2010
Location: Shelby NC
Posts: 423
I had a sway bar that wasn't tightened down correctly. It sounds like what the OP was explaining. It only happened to me on small bumps at slow speeds. Dealer found it and corrected it. Nothing since then for me.
__________________
Jarhead is offline   Reply With Quote
Old 04-16-2010, 12:52 AM   #107
qbert48

 
qbert48's Avatar
 
Drives: 2SS SIM
Join Date: Apr 2009
Location: texas panhandle BFE
Posts: 1,128
my baby only "clunks" sometimes when i back out of the driveway and not so much now
__________________
2SS RS SIM gray leather stick shift ground FX
thank you gary richards @ classic chevy in sugarland

welcome home
1100 4-27-09
6000 6-27-09


yes i got to the dance late don't hate me
qbert48 is offline   Reply With Quote
Old 04-16-2010, 08:45 PM   #108
camarorick

 
camarorick's Avatar
 
Drives: .
Join Date: Jan 2008
Location: .
Posts: 2,166
I brought my car in this morning, and had the service advisor go for a drive with me. He heard the noise immediately, and asked for me to leave the car for the technicians to look at. I then received a call telling me that they punched in my issues on the "GM" computer, and the recommendation of the GM Engineers USA is to replace both struts. They also pointed out that " some noise in the front suspension on Camaro is normal ". The struts are on back order, and should be received in a few weeks. I'll let you guys know what the outcome is once they're installed :emoticon7:
camarorick is offline   Reply With Quote
Old 04-17-2010, 02:20 PM   #109
AZ5G
AZ5G
 
AZ5G's Avatar
 
Drives: 2010 Transformer Ed. 1SS M6
Join Date: Nov 2009
Location: Arizona
Posts: 81
I also have some interesting noises coming from the front end. Anyone installed any aftermarket coilovers, reusing the upper stock mounts, and still have the issues?? I'm considering the BC's, but would hate to end up right where I started...Thx...DD
AZ5G is offline   Reply With Quote
Old 04-17-2010, 04:17 PM   #110
Info@PeddersUSA.com

 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,903
Quote:
Originally Posted by camarorick View Post
I brought my car in this morning, and had the service advisor go for a drive with me. He heard the noise immediately, and asked for me to leave the car for the technicians to look at. I then received a call telling me that they punched in my issues on the "GM" computer, and the recommendation of the GM Engineers USA is to replace both struts. They also pointed out that " some noise in the front suspension on Camaro is normal ". The struts are on back order, and should be received in a few weeks. I'll let you guys know what the outcome is once they're installed :emoticon7:
Can you get a copy of the bulletin or PI they are referring to, or at least a number.

thanks
mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
Old 04-17-2010, 11:37 PM   #111
camarorick

 
camarorick's Avatar
 
Drives: .
Join Date: Jan 2008
Location: .
Posts: 2,166
Quote:
Originally Posted by dms View Post
Can you get a copy of the bulletin or PI they are referring to, or at least a number.

thanks
mike
dms
Hey Mike, I found a number on my work order... PIE0054A Document ID 2426027 (9090) E9500. I don't know if there are different numbers in Canada, let us know if this helps !? Hopefully you can find more info
camarorick is offline   Reply With Quote
Old 04-18-2010, 11:09 AM   #112
Info@PeddersUSA.com

 
Info@PeddersUSA.com's Avatar
 
Drives: 5th Gen Rental
Join Date: Aug 2007
Location: New England
Posts: 1,903
Quote:
Originally Posted by camarorick View Post
Hey Mike, I found a number on my work order... PIE0054A Document ID 2426027 (9090) E9500. I don't know if there are different numbers in Canada, let us know if this helps !? Hopefully you can find more info
thanks for the info. Will see what I can find

mike
dms
Info@PeddersUSA.com is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CAMARO WIKI Tran Wiki 55 03-28-2017 01:04 PM
FOUND PETITION TO GET RID OF FRONT PLATES The_Beast_ USA - California 90 03-29-2012 01:54 AM
New Camaro photoshop with beefier front end, drop and smoked wheels Tran Camaro Photoshops / Renderings Forum 60 10-25-2010 07:02 PM
2010 Camaro SS -- New closeup of front end: Photos only. Tran Camaro Photos | Spyshots | Video | Media Gallery 1 07-17-2008 11:09 PM
2 more 2009 Camaro spy pics - fuel door location shown! (+ front headlights closeup) HooliganZ Camaro Photos | Spyshots | Video | Media Gallery 369 07-02-2008 10:09 PM


All times are GMT -5. The time now is 12:49 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.