Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
B&M Racing
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 03-23-2011, 04:14 PM   #1
Cal 20112SS
 
Drives: 2011 2SS/RS
Join Date: Jul 2010
Location: USA
Posts: 552
Foreign language on DIC?

Remote started the SS today and I was greeted by some foreign language??
I played around with it for a few minutes but couldn’t get it back to English.
USA is selected but still displays in what appears to be German?



Cal 20112SS is offline   Reply With Quote
Old 03-23-2011, 04:44 PM   #2
The IOM Ninja
Account Suspended
 
Drives: 10' IOM 2SS/RS, 13' GB Shelby GT500
Join Date: Sep 2010
Location: Sherwood Park, AB
Posts: 2,181
Nope, what you have selected changes the gauges and all information displayed, in between US format A.K.A (MPG, Miles/Hour, Fahrenheit, ETC.) Canadian Metric and what you need to do is go into vehicle settings via the radio Config Button, there you will find your information pertaining to vehicle language settings. Hope this helps, I would post photos but I'm at work and my car is at home. PM me if you need any help at all!
The IOM Ninja is offline   Reply With Quote
Old 03-23-2011, 05:06 PM   #3
Cal 20112SS
 
Drives: 2011 2SS/RS
Join Date: Jul 2010
Location: USA
Posts: 552
That's strange. I was nowhere near the radio to change the language. Thanks! I'll have to check that out.
Cal 20112SS is offline   Reply With Quote
Old 09-15-2014, 06:24 PM   #4
camarosspower

 
camarosspower's Avatar
 
Drives: 2010 camaro ss
Join Date: Jun 2010
Location: Port Arthur, Tx
Posts: 2,239
I know this thread is old but it just happened to me. What's weird is that it just changed on the dash and not on the radio. Help anybody?
camarosspower is offline   Reply With Quote
Old 09-15-2014, 08:05 PM   #5
bkscott

 
bkscott's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Dec 2009
Location: Grand Prairie, Texas
Posts: 1,593
Mine did that a few months ago, on a very cold morning. After 3 starting cycle it went back to English.
__________________
94 Firebird Formula (Drowned 08/30/05)
2010 IBM 2SS/RS 6M Arrived 3/25/10.

ADM CAI, Borla Type S Cat Back, VMAX Ported TB, LG Short Throw Shifter, 1LE Shocks, Hotchkis Sway Bars, Whiteline Cradle Bushing Inserts, Custom Powdercoated ZL1's ,Michelin Pilot Supersports, Stainless Power Headers, Solo J Pipes, AAC LED Sidemarkers, ZL1 Rockers, SLP Splitter, ADM Stage II Cam,ZL1 Diffuser,Vitesse Throttle Controller.

bkscott is offline   Reply With Quote
Old 09-15-2014, 08:08 PM   #6
camarosspower

 
camarosspower's Avatar
 
Drives: 2010 camaro ss
Join Date: Jun 2010
Location: Port Arthur, Tx
Posts: 2,239
I started my car back again and it went back to English. I wonder what causes this
camarosspower is offline   Reply With Quote
Old 09-16-2014, 01:43 PM   #7
Ragnar
Destroyed by flooding
 
Ragnar's Avatar
 
Drives: Wife's car
Join Date: Mar 2014
Location: Louisiana
Posts: 4,678
camarosspower, it would appear that your DIC is multi-lingual!
Ragnar is offline   Reply With Quote
Old 09-16-2014, 02:03 PM   #8
Wabbit

 
Wabbit's Avatar
 
Drives: 2013 2LT/RS SIM/Grey lnt/Sun/Nav
Join Date: Jul 2012
Location: In my car as much as I can
Posts: 777
Happened a few months ago on mine. Got a laugh at it and took pictures of all the displays. After sitting overnight, turned on in the morning as English again.
__________________
Rally Stripes - Check
Hockey Stripes - Check
Gills - Check
Ambient Lighting - Saving my $$$ now
Wabbit is offline   Reply With Quote
Old 09-16-2014, 02:14 PM   #9
nickswe
A Swede lost in Texas
 
Drives: Camaro ZL1 2014 Black M6
Join Date: Apr 2013
Location: Dallas, TX
Posts: 489
Read this: http://www.moderncamaro.com/forum/v6...-angry-me.html

I wish I could change my language to Swedish. But I guess that is not possible, not even if I go to Chevrolet and ask them to install Swedish? That would make my car more worth the bucks when I bring it with me back home next year.

I prefer english myself, but the typical Swede won't.
__________________
Former owner of a 2012 Camaro SS 45th Anniversary Edition.

Currently driving a 2014 Camaro ZL1 Coupe.
nickswe is offline   Reply With Quote
Old 09-16-2014, 05:30 PM   #10
camarosspower

 
camarosspower's Avatar
 
Drives: 2010 camaro ss
Join Date: Jun 2010
Location: Port Arthur, Tx
Posts: 2,239
Yea I guess it is. I'm just hoping that its just a glitch and not something wrong with the wiring
camarosspower is offline   Reply With Quote
Old 09-16-2014, 05:41 PM   #11
len_eng
 
Drives: 2015 2LT/RS Crystal Red, 1994 Z28,
Join Date: Jan 2013
Location: Sharon, Ma
Posts: 96
This happened to me last year on a cold morning. It went back to English the next time I drove the car. It has not happened again. It was pretty funny.
len_eng is offline   Reply With Quote
Old 05-22-2015, 10:26 AM   #12
mobilin
 
mobilin's Avatar
 
Drives: 2015 Stingray and 2SS
Join Date: Apr 2009
Location: Northern Virginia
Posts: 211
Send a message via AIM to mobilin Send a message via MSN to mobilin Send a message via Yahoo to mobilin
Sorry for digging up an old thread... but figure it's best track these issues in one thread.

On my Red Camaro (2010) with just over 90K miles my just did this same thing a couple of days ago. I wasn't near the settings that would change it so it seems like there is a glitch somewhere. I just recently started leaving the car outside, I know bad Camaro owner, lol. So I hope it's not something that got moisture in it and it's going to fail since I'm out of warranty. The next day when I went out it was back to English.
__________________
Mosaic Black Metallic (Adrenaline Red interior) 31 Oct
Hot Red Camaro 2SS RS 17 Oct 2015 (SS 199) 31 Oct traded 64k miles
Torch Red Stingray 2LT Z51 16 Mar 2015 Delivered (NCM) (NO ECAR)
Black LS Purchased 07/20/13 (SYFY 2) - 21 Oct Given to daughter for 16th Birthday
Red 2LT Delivered 06/24/09 20 days (SYFY) traded 17 Oct 15 99,986 miles
mobilin is offline   Reply With Quote
Old 10-18-2017, 08:27 PM   #13
Dudeman5K
 
Drives: 2018 Chevrolet Camaro RS
Join Date: Oct 2017
Location: North Carolina
Posts: 1
New Camaro-Strange Computer Goings On

Hey All! First post on the forums-A proud 2018 Camaro RS owner since September 6th. Apologies for resurrecting a dead thread-however here in Eastern NC the temp dropped some 20 plus degrees last night. When I started my car this morning my computer dash started showing me all option available on Chevrolet vehicles including deisel exhaust fluid level (recently traded in my 2500 HD). I went into options and first listing was in Arabic.

I have a total of 1305 miles on my Camaro and was totally surprised by this. My gas mileage has been an average of 28.9 mpg (all back roads to work and “ahem” 55 mph zones) and this morning it shot to 23.5.

Parked car at work and hit the net and found these here forums. I went outside and restarted Camaro and all is good!

I love my car! Took 45 years to get to my Camaro-can’t believe I waited this long!
Dudeman5K is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Canadian Built Camaro, Foreign Cars and US Jobs alfie43 General Automotive + Other Cars Discussion 86 09-12-2010 10:22 PM
Perceptions Die... OK Say Again Y Foreign is Better Cmicasa the Great XvX General Automotive + Other Cars Discussion 428 11-09-2009 05:04 PM
American V.S. Foreign Milk 1027 General Automotive + Other Cars Discussion 15 12-03-2008 12:28 AM


All times are GMT -5. The time now is 01:31 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.