Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum


Reply
 
Thread Tools
Old 02-14-2013, 07:33 PM   #155
jhiiidoc
 
jhiiidoc's Avatar
 
Drives: 2010 Camaro 2SS/RS SLP Supercharged
Join Date: Feb 2012
Location: Central Florida
Posts: 318
I've had mine in now for six months...I've had no issues with it except when I use the remote start...Occasionally I have to shut off the engine to kill the key chime, then open and close the door to reset it. Small thing...Everyone that sees it loves it. Good luck.
jhiiidoc is offline   Reply With Quote
Old 02-15-2013, 12:19 AM   #156
Drago77
Treasure Coast Camaro 5
 
Drago77's Avatar
 
Drives: SW 11' 2SS/RS LS3 Vert, Blk/Blk
Join Date: Feb 2009
Location: Port Saint Lucie, Florida
Posts: 4,553
Quote:
Originally Posted by jhiiidoc View Post
I've had mine in now for six months...I've had no issues with it except when I use the remote start...Occasionally I have to shut off the engine to kill the key chime, then open and close the door to reset it. Small thing...Everyone that sees it loves it. Good luck.
Ditto...

I get the occassional "ghost chime" and reduced key fob distance... not n issue since I taped off the annoying speaker and don't need the fob more than 5-10 feet away... love it!
Drago77 is offline   Reply With Quote
Old 02-15-2013, 06:23 AM   #157
Rizzo
 
Drives: 2012 Camaro ZL-1 SIM
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 454
I have contacted Scosche repeatedly over the last 6 months. They are not able to reproduce any of these issues.

I guess we are all flukes?
__________________
=================================================
Rizzo is offline   Reply With Quote
Old 02-15-2013, 12:46 PM   #158
wreckedmycar
 
Drives: Black 1LT/RS
Join Date: Nov 2009
Location: El Paso texas
Posts: 28
Send a message via Yahoo to wreckedmycar
Ive been having issues 1 and 3 after 2 months of installing the kit. What is the email to scosche so i can get inform them and hopefully get a replacement kit. besides those two annoying issues i absolutely love my scosche kit
wreckedmycar is offline   Reply With Quote
Old 02-15-2013, 01:19 PM   #159
Rizzo
 
Drives: 2012 Camaro ZL-1 SIM
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 454
Quote:
Originally Posted by wreckedmycar View Post
Ive been having issues 1 and 3 after 2 months of installing the kit. What is the email to scosche so i can get inform them and hopefully get a replacement kit. besides those two annoying issues i absolutely love my scosche kit
I could only find their online help:
http://www.scosche.com/contacts
__________________
=================================================
Rizzo is offline   Reply With Quote
Old 02-16-2013, 09:52 PM   #160
wreckedmycar
 
Drives: Black 1LT/RS
Join Date: Nov 2009
Location: El Paso texas
Posts: 28
Send a message via Yahoo to wreckedmycar
Thanks Rizzo!!! I noticed on the pictures that were embedded a couple pages back in the thread that had a USB cable connected to the scosche kit USB input. What is that? i left mine without anything connected
wreckedmycar is offline   Reply With Quote
Old 02-18-2013, 09:17 AM   #161
Rizzo
 
Drives: 2012 Camaro ZL-1 SIM
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 454
Quote:
Originally Posted by wreckedmycar View Post
Thanks Rizzo!!! I noticed on the pictures that were embedded a couple pages back in the thread that had a USB cable connected to the scosche kit USB input. What is that? i left mine without anything connected
I think that may be to do the firmware updates.
__________________
=================================================
Rizzo is offline   Reply With Quote
Old 02-28-2013, 01:04 PM   #162
5th_GEN_SS
Junkie
 
5th_GEN_SS's Avatar
 
Drives: SIM 2SS/RS M6
Join Date: Sep 2008
Location: Cleveland, Ohio
Posts: 1,657
Were these early production kits that have had the issue or is it through the batch?
__________________
"Letty" Murdered out 2013 Camaro 1LE. (Old car SIM 2010 2SS/RS)
5th_GEN_SS is offline   Reply With Quote
Old 02-28-2013, 03:25 PM   #163
Rizzo
 
Drives: 2012 Camaro ZL-1 SIM
Join Date: Sep 2008
Location: San Antonio, TX
Posts: 454
Quote:
Originally Posted by 5th_GEN_SS View Post
Were these early production kits that have had the issue or is it through the batch?
Not sure...I RMA-ed one and it was a little better, but still has the distance issue and the trunk unlock issue.
__________________
=================================================
Rizzo is offline   Reply With Quote
Old 02-28-2013, 03:47 PM   #164
5th_GEN_SS
Junkie
 
5th_GEN_SS's Avatar
 
Drives: SIM 2SS/RS M6
Join Date: Sep 2008
Location: Cleveland, Ohio
Posts: 1,657
Well I just got a used one... He claims no issue guess we will see.
Paid 450 for the kit and headunit with harnesses
__________________
"Letty" Murdered out 2013 Camaro 1LE. (Old car SIM 2010 2SS/RS)
5th_GEN_SS is offline   Reply With Quote
Old 02-28-2013, 10:52 PM   #165
Drago77
Treasure Coast Camaro 5
 
Drago77's Avatar
 
Drives: SW 11' 2SS/RS LS3 Vert, Blk/Blk
Join Date: Feb 2009
Location: Port Saint Lucie, Florida
Posts: 4,553
Got mine Dec 12. Distance and trunk issues, but that all...
Drago77 is offline   Reply With Quote
Old 03-12-2013, 05:56 PM   #166
SS Drifter
 
Drives: 2010 2SS/RS L99
Join Date: Nov 2009
Location: California
Posts: 588
It would be nice if the manufacturer would actully announce when all issues are resolved and the unit is working as well as stock. It won't be buying a Scocshe for the Camaro until there is an official statement from the CEO.
SS Drifter is offline   Reply With Quote
Old 03-12-2013, 10:29 PM   #167
Drago77
Treasure Coast Camaro 5
 
Drago77's Avatar
 
Drives: SW 11' 2SS/RS LS3 Vert, Blk/Blk
Join Date: Feb 2009
Location: Port Saint Lucie, Florida
Posts: 4,553
Quote:
Originally Posted by SS Drifter View Post
It would be nice if the manufacturer would actully announce when all issues are resolved and the unit is working as well as stock. It won't be buying a Scocshe for the Camaro until there is an official statement from the CEO.
Then you won't ever be buying one my friend. To make an announcement like that would mean they're acknowledging their mistakes/flaws and opening themselves up to replacing/repairing all existing units... financial disaster.

Its like anything else; gotta weigh the good with the bad, and your own particular needs... just keep in mind; very few people go outta their way to argue how GOOD something is; but almost everyone is quick to vent by any means if they're dissatisfied.

I personally love my Scosche and the pros far outweighed the cons in my application.
Drago77 is offline   Reply With Quote
Old 03-12-2013, 10:38 PM   #168
darkrider01
Aural Assault Vehicle
 
darkrider01's Avatar
 
Drives: 2010 IBM 2SS/RS, 2015 Sierra Denali
Join Date: Jun 2011
Location: Garner, NC
Posts: 787
Quote:
Originally Posted by Drago77 View Post
Then you won't ever be buying one my friend. To make an announcement like that would mean they're acknowledging their mistakes/flaws and opening themselves up to replacing/repairing all existing units... financial disaster.

Its like anything else; gotta weigh the good with the bad, and your own particular needs... just keep in mind; very few people go outta their way to argue how GOOD something is; but almost everyone is quick to vent by any means if they're dissatisfied.

I personally love my Scosche and the pros far outweighed the cons in my application.
I'll second that. I have a short remote range - I can totally deal with that since I think it looks soo much better than the metra kit.
__________________
My amplifier pop/click/thump solution thread
Power Mods * K&N Typhoon CAI, Flowmaster American Thunder cat-back exhaust, Hurst Short Throw Shifter Exterior Mods * Black Phantom Grille * 22" T.I.S. 537MS wheels w/ Nitto INVO rubber * OEM body kit Suspension Mods * BC Racing Coilovers * Lakewood Strut Tower Brace Audio Mods * Stinger SPP 2250 Battery * Mosconi 6to8v8 w/ RCD * Pioneer AVH-X7500BT * Scosche Dash Kit * 2 - Mosconi AS200.4 * 2 - JL Audio 13W6v2 * Focal 165KRX2 Power (active) * Mosconi Gladen One 240.2 * Rockford Fosgate Power T1692
darkrider01 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:55 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.