Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
HeadlightArmor
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 08-17-2010, 11:23 AM   #1
Ronn

 
Ronn's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Northern Ontario
Posts: 1,175
Brought car to dealer for repair, clutch doesn't feel the same

I brought my car in because it had an oil leak at the back of the engine on the oil pan gasket. So a new cover and gaskets were ordered. They had to drop the tranny so everything was disconnected.

I went in last night to pick it up and pushed in the clutch, the first top half of the clutch pedal travel felt like nothing. Before bringing it in it was nice and stiff right from the top, I maybe had like 1/4 inch of free play (if that)

The mechanic didn't bleed the system so he did that today. I talked to him a little earlier and he told me that he got a few air bubbles out of it but nothing major. He said the pedal is better than last night. I'll have to wait and see how it is when I pick it up.

My question is, how much free travel do you guys have on your clutch pedals? Also, if anyone has had similar work done and got their car back with a different clutch feel. Much appreciated.
__________________
1SS / RS / M6 / IOM / Black rally stripes / Polished wheels

It's a high school prom, it's a Springsteen song, it's a ride in a Chevrolet...
Ronn is offline   Reply With Quote
Old 08-17-2010, 11:37 AM   #2
ZZcamaro


 
Drives: 2SS w/ ZZ427 Package!!
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 2,706
My personal car is all modified so it may not help, but My clutch begins to travel as soon as I touch the pedal.... well at least within the first inch...

As for the stock car, I would say yes he did not bleed the system... and I think I had less than 2 inches of travel before my stock clutch began to release.
ZZcamaro is offline   Reply With Quote
Old 08-17-2010, 10:45 PM   #3
Ronn

 
Ronn's Avatar
 
Drives: 2010 Camaro
Join Date: Mar 2010
Location: Northern Ontario
Posts: 1,175
Update, the clutch pedal feels great now. Much better than the other night before bleeding the system. No play at the top and the pedal doesn't stick. I like the point where it engages a little more now.
__________________
1SS / RS / M6 / IOM / Black rally stripes / Polished wheels

It's a high school prom, it's a Springsteen song, it's a ride in a Chevrolet...
Ronn is offline   Reply With Quote
Old 08-20-2010, 12:36 AM   #4
ZZcamaro


 
Drives: 2SS w/ ZZ427 Package!!
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 2,706
Glad to hear it worked itself out... I figured it was the bleeding of the system. ENJOY!!
ZZcamaro is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Washing/Detailing for Newbies MRK III Z28 Cosmetic Maintenance: Washing, Waxing, Detailing, Bodywork, Protection 116 12-12-2014 06:21 AM
Oil Change Ramp mjlash22 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 17 01-21-2010 11:40 PM
YOUR WARRANTY INFORMATION Kwaz1335 5th Gen Camaro SS LS LT General Discussions 2 11-02-2009 06:23 PM
Tired of Waiting - Pics of My New Hyundai Genesis Coupe camaropete 5th Gen Camaro SS LS LT General Discussions 101 08-26-2009 10:31 PM


All times are GMT -5. The time now is 04:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.