Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 08-21-2010, 07:13 PM   #1
xpanda305x
Banned
 
Drives: Dark Knight
Join Date: Nov 2009
Location: Gunshine State
Posts: 3,162
whining noise when steering the wheel?

what can cause this? maybe power fluid pump or fluid needed??? anyone? i its weird..
xpanda305x is offline   Reply With Quote
Old 08-21-2010, 08:26 PM   #2
Kwaz1335
The Kwaz
 
Drives: Black 2010 Camaro 2SS/RS
Join Date: Mar 2009
Location: Long Island NY
Posts: 261
Send a message via AIM to Kwaz1335
Check you power steering fluid levels. Under your hood while looking at your motor on the right side you will see a black box thing with a logo of a steering wheel on it. If your levels are low..fill I back up and if it continues to whine...check your levels again. If they are low you have a leak in your system. If your levels are fine but your pump is still whining have your power steering pump replaced as the pump is bad.
__________________
Ordered:3/13/09
1100: 3/13/09
3300: 5/12/09
Picked up and brought home 6/26/2009
2010 Black on Black SS/RS Camaro
Silver stripe package
Ground effects package
6 Speed Manual Transmission with Hurst short throw, Magnuson Supercharger, SLP loudmouth 1 kit.
Kwaz1335 is offline   Reply With Quote
Old 08-22-2010, 12:35 AM   #3
xpanda305x
Banned
 
Drives: Dark Knight
Join Date: Nov 2009
Location: Gunshine State
Posts: 3,162
^ will do first thing in the morning capt!
xpanda305x is offline   Reply With Quote
Old 08-22-2010, 01:17 AM   #4
nards444

 
nards444's Avatar
 
Drives: 1SS/RS Black
Join Date: May 2009
Location: New york
Posts: 2,128
power steering fluid, or pump is defective
__________________
2010 1SS/RS Black, CGM stripes, polished Rims, Tinted windows, Hurst shifter
nards444 is offline   Reply With Quote
Old 08-22-2010, 03:45 PM   #5
Motorhead79
 
Motorhead79's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: May 2010
Location: Camano Island, WA
Posts: 258
I just started hearing the same thing, my fluid was actually low. I serviced the system and it still whines. I just happened to glance down at the lower cross member in the engine bay to check the condition of the hoses and found a bad fitting, all my fluid was on the lower cross member.
Motorhead79 is offline   Reply With Quote
Old 08-22-2010, 03:47 PM   #6
KeepItGreasey
So It'll Go Down Easy
 
KeepItGreasey's Avatar
 
Drives: Camaro SS/RS
Join Date: Aug 2010
Location: Long Beach, CA
Posts: 900
had the same problem. fluid was low. where did it go? i don't know. the dealer topped it off and told me they didn't find a leak. i'll have to give it a good look at for myself.
KeepItGreasey is offline   Reply With Quote
Old 08-22-2010, 05:26 PM   #7
Cal 20112SS

 
Cal 20112SS's Avatar
 
Drives: 2011 2SS/RS
Join Date: Jul 2010
Location: USA
Posts: 1,247
Mine sounds like it's releasing air out of the wheel?? I turn it slightly and it stops.
Cal 20112SS is offline   Reply With Quote
Old 08-23-2010, 04:28 AM   #8
Big Brunsy


 
Big Brunsy's Avatar
 
Drives: Silverado
Join Date: Jan 2010
Location: Le Mars, Iowa
Posts: 2,292
I had the same thing, pump had a leak in it....only the problem wasn't so much the fluid getting out (resivor was full), it was the air getting in. Trapped air in the system caused me to not have any power steering. The fix was they replaced the pump.
__________________
Big Brunsy is offline   Reply With Quote
Old 08-24-2010, 07:15 PM   #9
Peter W.
 
Drives: 2011 Camaro 2SS
Join Date: Jul 2010
Location: New Jersey
Posts: 8
I have the same problem. I have like a slight whisteling sound but it goes away when I turn the wheel. I brought the car in for my first oil change and addressed this issue to the dealership. They said they started an L99 on the lot and it did the same thing, they said it was normal. Are they Bullshitting me?
Peter W. is offline   Reply With Quote
Old 09-13-2010, 12:27 AM   #10
Motorhead79
 
Motorhead79's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: May 2010
Location: Camano Island, WA
Posts: 258
I actually found the problem with mine a couple weeks ago, actually about a day after i posted my last message. Wouldn't ya know it the power steering line that runs along the bottom portion of the engine mount where the line goes from being a flex line to the steel line had burst. Not bad though but it did let go, so that day I set an Appointment with the local dealer told them the problem, they had me in the next day. (BTW the factory line was made by Yokahama) It was covered under warranty, and to top it off they replaced it with a CSM line (Used on Corvettes) I was concerned that the system was going to wine after they changed the line cause when i was low on fluid I serviced it up with DOT4 ATF Fluid (NON synthetic BTW States that in the manual) and it still whined. Well the Dealer told me that when the fluid got low it got air in the System so they bled it and all was well!

Last edited by Motorhead79; 09-13-2010 at 12:28 AM. Reason: typo
Motorhead79 is offline   Reply With Quote
Old 05-21-2012, 12:38 PM   #11
Maker
Nice to meet you.
 
Maker's Avatar
 
Drives: '11 Black 1SS/RS
Join Date: Jul 2011
Location: Massachusetts
Posts: 181
they just told me they are going to replace my entire rack
Maker is offline   Reply With Quote
Old 07-23-2012, 08:40 AM   #12
spd2612
TRI-COUNTY CAMAROS
 
spd2612's Avatar
 
Drives: Black SS2/RS LS3
Join Date: Jun 2011
Location: FT. Myers FL.
Posts: 668
GM is aware of this issue. I just went to dealer with my 2011 ss2 I didn't think the noise was a big issue, I went in to get 4 new tires and a alignment
I was told they would get me a car, they opened a ticket with GM and they said replace the rack.
__________________
CAI, MGW Short Throw,Concept SMD Sidemarker lights, LED Sequential Tail Lights, MSD Digital Shift Light, LPE LNC-2000, LPE CTAP-001, 1 7/8 Long Tubes, 3 inch Stainless exhaust header back, X Pipe, Cat Delete, Solo J-Pipe Mod, Powder Coated Wheels, FSP Custom Grind Comp Cam's, VMax TB., PFADT TL, TA, SF Bushings LPW Diff Cover, DSS Axles & aluminum drive shaft, ES Diff Bushings JRE Posi Mod, Billet caps, 3:91 gears Mantic ER2 Clutch
spd2612 is offline   Reply With Quote
Old 07-23-2012, 11:13 AM   #13
Maker
Nice to meet you.
 
Maker's Avatar
 
Drives: '11 Black 1SS/RS
Join Date: Jul 2011
Location: Massachusetts
Posts: 181
well, are they replacing the rack with a new version of the rack? mine was replaced and now i hear the noise again. if they are replacing it with the same faulty parts, what's the point? i love this car to death, but i am not going to endure this lunancy. how many times can they fix it?

what if they put a new steering wheel in like from the '13 model? is anyone with the newer wheel design having this issue?
Maker is offline   Reply With Quote
Old 07-23-2012, 12:01 PM   #14
spd2612
TRI-COUNTY CAMAROS
 
spd2612's Avatar
 
Drives: Black SS2/RS LS3
Join Date: Jun 2011
Location: FT. Myers FL.
Posts: 668
I didn't like the design of the 2012 steering wheel, did they change it again in 13 ?
GM told them to replace the rack so Im guessing its a new design. I have a 2011 ss2 rs
I love the car I was just going in to buy tires didn't know I had a issue just a slite squeak
I got 26000 miles out of the Perili tires so I am sticking with them
__________________
CAI, MGW Short Throw,Concept SMD Sidemarker lights, LED Sequential Tail Lights, MSD Digital Shift Light, LPE LNC-2000, LPE CTAP-001, 1 7/8 Long Tubes, 3 inch Stainless exhaust header back, X Pipe, Cat Delete, Solo J-Pipe Mod, Powder Coated Wheels, FSP Custom Grind Comp Cam's, VMax TB., PFADT TL, TA, SF Bushings LPW Diff Cover, DSS Axles & aluminum drive shaft, ES Diff Bushings JRE Posi Mod, Billet caps, 3:91 gears Mantic ER2 Clutch
spd2612 is offline   Reply With Quote
Old 07-23-2012, 12:47 PM   #15
Sikoriko

 
Sikoriko's Avatar
 
Drives: 2011 V6 IOM
Join Date: Jul 2012
Location: San Diego
Posts: 1,345
mine was from my wife
Sikoriko is offline   Reply With Quote
Old 07-24-2012, 10:26 AM   #16
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,209
Quote:
Originally Posted by spd2612 View Post
GM is aware of this issue. I just went to dealer with my 2011 ss2 I didn't think the noise was a big issue, I went in to get 4 new tires and a alignment
I was told they would get me a car, they opened a ticket with GM and they said replace the rack.
I apologize for the frustration you experienced. Have you already received your vehicle with the repair? Please let us know how your service went!

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is online now   Reply With Quote
Old 07-24-2012, 11:46 AM   #17
spd2612
TRI-COUNTY CAMAROS
 
spd2612's Avatar
 
Drives: Black SS2/RS LS3
Join Date: Jun 2011
Location: FT. Myers FL.
Posts: 668
No estero bay chevy took care of it, squeak is gone They always take good care of me there
spd2612 is offline   Reply With Quote
Old 10-19-2012, 10:17 AM   #18
Neto1978
 
Drives: 2011 camaro ss victory red
Join Date: Jul 2012
Location: Sp-brazil
Posts: 166
Had the same problem, so I just want to input this:
car stayed at the dealer for 2 days, they drained the old steering fluid, flushed it, and put some new dexron VI on , the noise started to diasappear...and now its ok.
the old fluid came out kind of contaminated with some kind of gray"grease"...
For me its a case of lubrication lack of pinion and rack...
Neto1978 is offline   Reply With Quote
Old 11-24-2012, 04:37 PM   #19
Macfolk
J.T.
 
Macfolk's Avatar
 
Drives: Camaro 2SS w/RS package, Imp. Blue
Join Date: Jan 2012
Location: Sarasota, FL
Posts: 379
Does anyone have the service bulletin number, etc. on this? I am in the same boat and will be taking mine in for a repair on the PDIM soon so I'd appreciate any info.

Thanks,

Jason
__________________
2011 Camaro 2SS/RS L99
Mods done: 1LE replica wheels, black tail light bezels, LED driving lights (spliced to running lights), VMax CNC ported TB, No tune Vararam, and Rx catch can
Mods planned: heritage grille, 1LE splitter, led signals, tune, and possibly LT Headers

Love this car!
Macfolk is offline   Reply With Quote
Old 06-03-2013, 10:02 AM   #20
7Seas
 
Drives: 2010 Camaro silver
Join Date: Jun 2011
Location: Glendale, CA
Posts: 7
steering noise

Mi steering nois is coming from inside the cabin, right at the steering wheel its self. Is your guys nois coming from the same loction or the noise under the hood? Thanks
7Seas is offline   Reply With Quote
Old 06-03-2013, 10:14 AM   #21
spd2612
TRI-COUNTY CAMAROS
 
spd2612's Avatar
 
Drives: Black SS2/RS LS3
Join Date: Jun 2011
Location: FT. Myers FL.
Posts: 668
Quote:
Originally Posted by 7Seas View Post
Mi steering nois is coming from inside the cabin, right at the steering wheel its self. Is your guys nois coming from the same loction or the noise under the hood? Thanks
That was what mine sounded like it transfers the noise up the steering shaft they had to replace my Rack
__________________
CAI, MGW Short Throw,Concept SMD Sidemarker lights, LED Sequential Tail Lights, MSD Digital Shift Light, LPE LNC-2000, LPE CTAP-001, 1 7/8 Long Tubes, 3 inch Stainless exhaust header back, X Pipe, Cat Delete, Solo J-Pipe Mod, Powder Coated Wheels, FSP Custom Grind Comp Cam's, VMax TB., PFADT TL, TA, SF Bushings LPW Diff Cover, DSS Axles & aluminum drive shaft, ES Diff Bushings JRE Posi Mod, Billet caps, 3:91 gears Mantic ER2 Clutch
spd2612 is offline   Reply With Quote
Old 11-22-2013, 05:38 PM   #22
Danprh427
 
Drives: 2010 Camaro
Join Date: May 2010
Location: NY
Posts: 315
same problem

I had a noise in the steering wheel when turning back and forth the dealer found it and replaced the entire rack for me. About 10 days later today they call me back and say ummm we made a mistake you have to pay for half of the service and they were actually serious i don't think I've ever heard of this before with any of the gm cars we have owned. My car was a few weeks out of warranty its a 2011 but with under 12k miles and in perfect condition garage kept and babied. Anyone else have any problems with having to pay weeks later after a warranty service has been done?
Danprh427 is offline   Reply With Quote
Old 11-22-2013, 07:26 PM   #23
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,209
Hello Danprh427,

I would be happy to speak with your dealership about this. If you could provide me with your name, address, phone number, VIN, and name of involved dealership, I can research the issue further. Thank you!

Jessica
Chevrolet Customer Care

Quote:
Originally Posted by Danprh427 View Post
I had a noise in the steering wheel when turning back and forth the dealer found it and replaced the entire rack for me. About 10 days later today they call me back and say ummm we made a mistake you have to pay for half of the service and they were actually serious i don't think I've ever heard of this before with any of the gm cars we have owned. My car was a few weeks out of warranty its a 2011 but with under 12k miles and in perfect condition garage kept and babied. Anyone else have any problems with having to pay weeks later after a warranty service has been done?
Chevrolet Customer Svc is online now   Reply With Quote
Old 11-22-2013, 08:02 PM   #24
Danprh427
 
Drives: 2010 Camaro
Join Date: May 2010
Location: NY
Posts: 315
sent you my info thank you jessica
Danprh427 is offline   Reply With Quote
Old 11-22-2013, 09:12 PM   #25
klawrencepdx
 
klawrencepdx's Avatar
 
Drives: 2011 CAMARO 2SS/RS black,CAI,RAMair
Join Date: May 2011
Location: Hillsboro
Posts: 91
Steering wheel noise

Hey everyone...............I had the same issue. Mine was inside the cabin and started as a whine sound and over a short time progressed to sound more like a zip zip when you turn the wheel.

Diagnosed as bad steering gear.........replaced. all better

Cheers from Portland
klawrencepdx is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Leather Wrapped Steering Wheel danifox 5th Gen Camaro SS LS LT General Discussions 16 06-21-2010 09:21 PM
Question about leather wrapped steering wheel... King T Cosmetics and Lighting Modification Discussions 6 01-15-2010 07:19 PM
steering wheel controls mod AdnanHfuda Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 1 01-11-2010 09:00 AM
steering wheel issue Fotowns Finest 4th Generation Camaros 2 11-03-2009 03:18 AM
QC missed something-- AC Compressor making a whining noise under engine load Kyle.Gilmour Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 12 10-09-2009 10:42 PM


All times are GMT -5. The time now is 05:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.