Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Lethal Racing
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 08-24-2010, 09:43 PM   #1
harley05
 
Drives: 2010 camaro
Join Date: Nov 2009
Location: kansas
Posts: 6
problems - transmission slipping

Ok am i the only one out here that is having issues with my new 2010 camaro???? My trans is slipping and i have been hearing a cracking noise in the engine. Whats up with this? I am starting to regret buying the first model. Is there anyone else having problems with there car?
harley05 is offline   Reply With Quote
Old 08-24-2010, 09:43 PM   #2
Sax1031


 
Drives: 2000 Mustang GT
Join Date: Jul 2009
Location: Elgin,SC
Posts: 2,707
have you taken the car to the dealer?
Sax1031 is offline   Reply With Quote
Old 08-24-2010, 09:45 PM   #3
ShnOmac


 
ShnOmac's Avatar
 
Drives: 2006 Silverado SS, 2009 G8 GT
Join Date: Aug 2008
Location: PNW
Posts: 13,408
Can you be more specific?

What do mean by the tranny sliping and a Cracking noise?
ShnOmac is offline   Reply With Quote
Old 08-25-2010, 07:34 AM   #4
clg_98ta


 
clg_98ta's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2010
Location: Austin, TX
Posts: 2,701
Yes, there are a number of issues with these 1st year cars... take a look at the "problems" forum to get a better idea what to watch for.

That's what warranties are for... if you're worried, you might look into picking up a GMPP extended warranty.
__________________
Black 2SS ordered 1/4/2010, received 2/19/2010



clg_98ta is offline   Reply With Quote
Old 08-25-2010, 08:37 AM   #5
myold88


 
myold88's Avatar
 
Drives: SUMMIT WHITE 2SS/RS CAMARO
Join Date: Feb 2008
Location: Ct.
Posts: 5,559
Overall from what I see here on camaro5 problems are few and far between. Mine is one year old and still no problems at all after 8400 miles..... Problem free car.
myold88 is offline   Reply With Quote
Old 08-25-2010, 02:39 PM   #6
Steve Dallas
Commits weekly crime
 
Steve Dallas's Avatar
 
Drives: 14 Stingray Z51 NPP MRC, AudiQ53.0T
Join Date: Nov 2009
Location: Durham, NC
Posts: 8,724
If this is really happening, take it to the dealer.

However, I suspect a troll with 1 post.
__________________
2014 LBT Stingray Z51, Mag Ride, Perf Exhst, Comp Seats
I fire up the willing engine, responding with a roar. Tires spitting gravel I commit my weekly crime.
Steve Dallas is offline   Reply With Quote
Old 08-25-2010, 02:42 PM   #7
Big Brunsy


 
Big Brunsy's Avatar
 
Drives: Silverado
Join Date: Jan 2010
Location: Le Mars, Iowa
Posts: 2,291
Quote:
Originally Posted by Steve Dallas View Post
If this is really happening, take it to the dealer.

However, I suspect a troll with 1 post.

My thoughts exactly
__________________
Big Brunsy is offline   Reply With Quote
Old 08-25-2010, 02:49 PM   #8
ga0358

 
ga0358's Avatar
 
Drives: 2010 ABM LS
Join Date: Jan 2010
Location: Acworth, Georgia
Posts: 935
Quote:
Originally Posted by Big Brunsy View Post
My thoughts exactly
x2
ga0358 is offline   Reply With Quote
Old 08-25-2010, 03:07 PM   #9
RSHugger
 
Drives: 1969 RS Camaro
Join Date: Feb 2008
Location: Albany OR
Posts: 196
^
agree... but it should be expected with any mass produced piece of machinery with thousands of mechanical and electrical parts that you will have a percentage of the cars with problems... that is reality. The real testament is how low that percentage is... and from what I understand it is quite low. Enjoy the car, take care of it, and when there are problems use your warranty.

:5thgenvert:
RSHugger is offline   Reply With Quote
Old 08-25-2010, 03:26 PM   #10
Darth_Emma
Psssssssssshhhhhhhhhhhhh!
 
Darth_Emma's Avatar
 
Drives: under contruction
Join Date: Nov 2009
Location: Marysville, Ohio
Posts: 13,151
:troll:

The guy has made one post and not responded again.
__________________
Darth_Emma is offline   Reply With Quote
Old 08-25-2010, 04:56 PM   #11
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,101
Quote:
Originally Posted by harley05 View Post
Ok am i the only one out here that is having issues with my new 2010 camaro???? My trans is slipping and i have been hearing a cracking noise in the engine. Whats up with this? I am starting to regret buying the first model. Is there anyone else having problems with there car?
If your trans is slipping, give it a beating and put that trans in another corner to work on new clientele. I hear Hooked on Phonics is helpful too.
You can only dream of owning a Camaro. Nice try troll.
ffrcobra_65 is offline   Reply With Quote
Old 08-25-2010, 05:33 PM   #12
wirebender
 
wirebender's Avatar
 
Drives: 2013 ZL1 BRM, auto sunroof
Join Date: Apr 2009
Location: Garner, NC
Posts: 585
hey, c'mon y'all....he just joined the forum 10 months ago!!!!!
auto or manual????????
V-6 or V-8???????
real (truth) or make believe (fiction)???
just now or for the whole 10 months??????
__________________
RF CAI & res,VMAX PTB,160*,NGK,LPE upper, lower pulleys & isolator,Kooks 2"LTs&cats,FAST 90# inj.,M2W,Afco HX,ATI bal.,Alky Control, DRL Harness & LEDs,LED Fogs
wirebender is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Torque Converters CamaroSpike23 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 48 08-16-2014 03:07 AM
Transmission problems anyone??? 376camaro 5th Gen Camaro SS LS LT General Discussions 3 07-14-2009 09:02 PM


All times are GMT -5. The time now is 03:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.