Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
sjm autoprod
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 08-30-2010, 11:51 PM   #1
KB2010
 
Drives: 2010 Camaro SS
Join Date: Apr 2010
Location: Canada
Posts: 45
Did I just ruin my clutch?! Help please!

Hi all, I've been reading all sorts of complaints and such about the Camaro's clutch, and other connecting parts that I have no idea about.

My Camaro: 2SS, Manual.

So I had my little cousin over, and he wanted to go for a ride. I did a hard start from 1st gear at about 5-6k RPMS. When I went to shift to second, I noticed my clutch was only coming back up half way. Now when I press the pedal, it is very soft coming up. I thought maybe I over heated it or something, so i let the car sit for a bit. When I went back, I didnt see anything leaking underneath, but when I sat inside and pressed it (car was off), it was still soft, and I could hear like a puff of air or something when the clutch came all the way back up.

Im going to call the dealer tommorow, but I want to be armed with some knowledge first to see if I can get them to replace it (which seems to be a task and half based on what I am reading here). Has this happened to anyone else? Can anyone explain to me what I may have done to the car (and if I should NEVER do that again? This was probably the first time I ever drove the car REAL hard, I babied it otherwise.) The car has about 12 000 KILOMETERS on it.


Thanks all
KB2010 is offline   Reply With Quote
Old 08-31-2010, 01:02 AM   #2
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,865
Sounds like you got the clutch hot and that got the clutch fluid hot to the point that it dos not let the pedal come back all the way back, Its normal on this car that is why some of us went to dot 4 and got a second Reservoir for the clutch, One more thing is change the clutch fluid once a month.
__________________
2SSRS@Gen5diy is offline   Reply With Quote
Old 08-31-2010, 01:04 AM   #3
KB2010
 
Drives: 2010 Camaro SS
Join Date: Apr 2010
Location: Canada
Posts: 45
Thank you so much for the reply. Will my clutch pedal get stiff again once it cools down a bit?
KB2010 is offline   Reply With Quote
Old 09-01-2010, 12:49 AM   #4
MillerTime
Blowin the doors off!
 
MillerTime's Avatar
 
Drives: A 2013 SS RS 6M SR
Join Date: Apr 2010
Location: Phoenix, AZ
Posts: 2,401
Quote:
Originally Posted by 2SSRS View Post
Sounds like you got the clutch hot and that got the clutch fluid hot to the point that it dos not let the pedal come back all the way back, Its normal on this car that is why some of us went to dot 4 and got a second Reservoir for the clutch, One more thing is change the clutch fluid once a month.
Dosn't the 2nd clutch reservoir negate having to change out the fluid?
__________________

2G1FS1EWXD9163847





MillerTime is offline   Reply With Quote
Old 09-01-2010, 08:03 AM   #5
SlingShot


 
SlingShot's Avatar
 
Drives: 2012 ZL1 - #670
Join Date: Jun 2009
Location: Seminole, Fl.
Posts: 7,058
Quote:
Originally Posted by KB2010 View Post
Hi all, I've been reading all sorts of complaints and such about the Camaro's clutch, and other connecting parts that I have no idea about.

My Camaro: 2SS, Manual.

So I had my little cousin over, and he wanted to go for a ride. I did a hard start from 1st gear at about 5-6k RPMS. When I went to shift to second, I noticed my clutch was only coming back up half way. Now when I press the pedal, it is very soft coming up. I thought maybe I over heated it or something, so i let the car sit for a bit. When I went back, I didnt see anything leaking underneath, but when I sat inside and pressed it (car was off), it was still soft, and I could hear like a puff of air or something when the clutch came all the way back up.

Im going to call the dealer tommorow, but I want to be armed with some knowledge first to see if I can get them to replace it (which seems to be a task and half based on what I am reading here). Has this happened to anyone else? Can anyone explain to me what I may have done to the car (and if I should NEVER do that again? This was probably the first time I ever drove the car REAL hard, I babied it otherwise.) The car has about 12 000 KILOMETERS on it.


Thanks all



From 5k-6k launch ... You're lucky you didn't break something ...
__________________
SlingShot is offline   Reply With Quote
Old 09-01-2010, 08:46 AM   #6
Russell James


 
Russell James's Avatar
 
Drives: '12 SS/RS LS3 IBM
Join Date: Dec 2009
Location: SE Michigan
Posts: 3,444
Quote:
Originally Posted by KB2010 View Post
Thank you so much for the reply. Will my clutch pedal get stiff again once it cools down a bit?
If it doesn't after a day or so of driving, it's going to need to be bled.

There is a procedure in the service manual and dealers have a tool to do it.

I wouldn't do that again. High rpm clutch dumps will trash everything between and including the flywheel and axles.
Russell James is offline   Reply With Quote
Old 09-01-2010, 11:30 AM   #7
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,865
Quote:
Originally Posted by MillerTime View Post
Dosn't the 2nd clutch reservoir negate having to change out the fluid?
You still need to change the fluid before and after track days.
__________________
2SSRS@Gen5diy is offline   Reply With Quote
Old 09-01-2010, 03:41 PM   #8
KB2010
 
Drives: 2010 Camaro SS
Join Date: Apr 2010
Location: Canada
Posts: 45
Thanks for the responses guys. Lesson learned on doing what I did. In any case, I took it to the dealer, and they took it for a ride...

"Everythings ok!" Is what they said

However, I know how the car FELT and how it feels now, and they are NOT the same. The clutch pedal is too soft coming back up. So can I conclude that bleeding the line is what will probably remedy the issue?

My other issue is, if any of you experienced chaps can help... The dealer is insisting it is fine, I think they gotta get down there and look. How did you guys convince them to do so? I know I can just yell and scream and have them do it, but I'd like to stay at a reasonable status with the techies at this point, just in case the damage (if there is any that is) done was my fault, they may be forgiving and warranty it.
KB2010 is offline   Reply With Quote
Old 09-01-2010, 04:05 PM   #9
Russell James


 
Russell James's Avatar
 
Drives: '12 SS/RS LS3 IBM
Join Date: Dec 2009
Location: SE Michigan
Posts: 3,444
Ask if they have any other 6 spd SS's there you could sit in and compare the clutch feel. If it feels different ask them to look this up in the Service Manual:

Clutch
Clutch Symptoms
Clutch Pedal Spongy, Low Pedal Effort, Hesitates on Return

When you go to that symptom, the first step is to bleed the hydraulic system. The manual then links you to the directions for bleeding.

If that doesn't correct it, it then lists the parts that could cause it and order they should be checked and replaced if needed.

Basically the pedal should go in and out, no odd feelings, same as the day it was new.
Russell James is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I want a new clutch, you too????? Sign here tjbusa V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 370 08-10-2013 04:27 AM
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 10:17 PM
Clutch Problem phenixdragon Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 20 08-22-2010 11:51 AM
Oil Change Ramp mjlash22 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 17 01-21-2010 11:40 PM


All times are GMT -5. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.