Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
sjm autoprod
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Reply
 
Thread Tools
Old 09-18-2010, 11:38 AM   #1
camarossrs2150

 
camarossrs2150's Avatar
 
Drives: abm2ssrs
Join Date: Apr 2009
Location: still out of my mind
Posts: 2,094
IMPORTANT coolant leak from oil cooler hose fitting please read

ive been smelling some coolant for a while now and this is what came up .
Attached Images
  
__________________
[SIGPIC]

Last edited by camarossrs2150; 09-18-2010 at 12:54 PM.
camarossrs2150 is offline   Reply With Quote
Old 09-18-2010, 02:46 PM   #2
Hicompression
Rumbly Bumble Bee
 
Hicompression's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Aug 2009
Location: DFW
Posts: 1,446
That would suck having to re-tap a hole in a brand new engine block because someone cross-threaded it at the factory!
__________________
2010 RALLY YELLOW 2SS 6M
-OBX Longtubes FTW!
Hicompression is offline   Reply With Quote
Old 11-15-2011, 02:15 PM   #3
TornadoSS
WICKDSS
 
TornadoSS's Avatar
 
Drives: 2011 1SS/RS IOM LS3
Join Date: May 2010
Location: Wichita, Kansas
Posts: 1,113
Mine was leaking also, Its a 2011 early build. Luckily got it in to dealership last week and repaired, without incident, under warranty even with all my mods. Service tech said it was just loose and teflon seal didn't look right. Re-sealed and no more problems.
__________________
2011 IOM SS/RS, M6. Look up our all generation Camaro club website at Heartland Camaros
Gforce Engineering Drivetrain, ECS 1500 Supercharger, TSP Cam, Alky Controls Meth single nozzle. 91 octane, 698 RWHP 625 rwtq. 4200#+, Tuned by Justin "Justune" Kalwei
11.57 @ 126.8 mph with a crappy 1.80 60'.....still learning to drive....M&H DR's and skinnies on 17" Welds.
TornadoSS is offline   Reply With Quote
Old 12-29-2011, 08:17 PM   #4
Awesome_SS
Jeff
 
Awesome_SS's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Feb 2010
Location: Hayes, Va
Posts: 339
I have this leak now at 16K miles. Looks like someone at the factory got sloppy with the sealant...more of it on the outside than on the thread it looks.
__________________
2010 Camaro SS - Currently: 585 HP, 485 RWHP, 430 Max. TQ. Stock: 400 HP, 339 RWHP, 349 Max. TQ. 2R Max Cam,SW LT Headers & Corsa Exh.ADM CAI & Livernois Tuned, PI 2600 TQ Converter, LPE 3.70 Gears, Eaton True Trac, Ported Heads, TB & Intake. 2012 Camaro ZL1 - Currently: All Stock
Awesome_SS is offline   Reply With Quote
Old 12-31-2011, 06:27 PM   #5
BLACK10

 
BLACK10's Avatar
 
Drives: 2010 CAMARO. 10.04@133mph, 1.4 60'
Join Date: Jul 2009
Location: Lafayette, Louisiana
Posts: 5,034
it just needs to be removed carefully and install some Teflon tape on it and re tighten. that's all that was needed to fix mine. i do recommend removing the line to be able to get to it. i used a long extension and came from the wheel area to remove it. its really just a cheap fine threaded fitting
Attached Images
  
__________________
BLACK10 is offline   Reply With Quote
Old 06-10-2015, 09:08 AM   #6
rberns


 
rberns's Avatar
 
Drives: 2011 Camaro 2SS/RS
Join Date: Apr 2011
Location: Cedar Rapids, IA
Posts: 3,101
Mine is dripping too. Took into the dealership and they were unable to get it to seal. GM has authorized a new block, but I really don't want one with all my current mods. Hoping they can figure something out using RTV sealant or maybe a Time Sert.
__________________
2011 Camaro 2SS/RS, Circle D 3200, ADM Transmission Cooler, BTR Valvetrain, Cam Motion .621 .595 228/244 113+4, ARH 1 7/8, Cold Air Inductions, Katech C5R TC, Melling HV, BTR SLR lifters, Trunion Upgrade, LS2 Dampner, LS9 head gaskets, Bo White PTB, RX CC, GFX, Subs, Tuned by Rhino79 at GPI.
rberns is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Camaro V6 Oil and Oil Filter Change azamazonqueen Camaro DIY & HOW-TO instructions & discussions 110 12-13-2014 05:03 PM
best synthetic oil to use hollywoodjose Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 130 01-26-2014 08:51 AM
First oil change? Fogey Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 27 09-18-2010 06:50 AM
synthetic motor oil? bigd1276 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 71 01-29-2009 12:28 PM
gas prices. Congoman775 General Automotive + Other Cars Discussion 65 05-28-2008 12:20 PM


All times are GMT -5. The time now is 10:46 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.