Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
HeadlightArmor
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

View Poll Results: Warranty issues
NEVER had a warranty issue 27 35.53%
SMALL issue(s) fixed while I waited 28 36.84%
MAJOR issue: car had to be towed / or kept overnight 21 27.63%
Voters: 76. You may not vote on this poll

Reply
 
Thread Tools
Old 09-18-2010, 02:49 PM   #1
SSLarry

 
Drives: 2SS LS3
Join Date: May 2010
Location: Southeast Florida
Posts: 1,408
Question Warranty Issues

Lets find out how quality and reliability are for the 2010 - 2011 Camaro.

Not scientific obviously, some have owned their cars for 18 days, others for 18 months, but just to get an idea of the percentage of forum users who had issues vs those who have not.
__________________

2010 CGM 2SS LS3, born: 4/10
SSLarry is offline   Reply With Quote
Old 09-19-2010, 09:22 PM   #2
Sc0rPs
 
Drives: 2010 2LT / RS - 2013 ZL1
Join Date: Aug 2010
Location: Vancouver
Posts: 520
Bet it will be a little high from all the spoiler paint chipping.
Sc0rPs is offline   Reply With Quote
Old 09-19-2010, 10:59 PM   #3
xpanda305x
Banned
 
Drives: Dark Knight
Join Date: Nov 2009
Location: Gunshine State
Posts: 3,162
Transmission messed up TSB. gone for almost a month or so. and had other problem caused by me supposedly. had horrible service.
xpanda305x is offline   Reply With Quote
Old 09-20-2010, 07:31 AM   #4
Hicompression
Rumbly Bumble Bee
 
Hicompression's Avatar
 
Drives: 2010 2SS Camaro
Join Date: Aug 2009
Location: DFW
Posts: 1,470
The dealer kept my car for 1.5 weeks over the rear bumper paint peel issue.
__________________
2010 RALLY YELLOW 2SS 6M
-OBX Longtubes FTW!
Hicompression is offline   Reply With Quote
Old 09-20-2010, 09:07 AM   #5
Inuyashas_Brother
 
Inuyashas_Brother's Avatar
 
Drives: '10 Camaro LS - M6
Join Date: Mar 2010
Location: Arlington, VA
Posts: 540
Quote:
Originally Posted by Hicompression View Post
The dealer kept my car for 1.5 weeks over the rear bumper paint peel issue.
same here
__________________
Inuyashas_Brother is offline   Reply With Quote
Old 09-20-2010, 09:41 AM   #6
Michael_Js
SoCal C5 Family Member
 
Michael_Js's Avatar
 
Drives: 2010 Camaro SS/RS - Black w/IOM; 6M
Join Date: Jul 2009
Location: San Diego, CA, USA
Posts: 5,317
Send a message via AIM to Michael_Js Send a message via MSN to Michael_Js
replaced clutch, etc - due to pedal sticking halfway...kept 3 days
__________________
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~
2010 Black 2SS/RS; 6M; IOM, GFX, sunroof; ADM Race CAI; Zoomers CB; Viper Alarm; Pdaft F&R sways, Adj Endlinks, Rtrailing arms, Camber kit, strut brace, Front Trailing Arm Bushing; SLP Skip-Shift Elim; Tinted lights/windows; Hurst Short-throw; LoJack; Door & Dash ABL Mods; Subthump; JBA Shorty headers; AACStyle LEDs; Stillen DS rotors, Hawk Ceramic pads; Havoc Blk Chrome wheels: 20x9s; Lingenfelter Blk Al Pedals; RevXtreme Catch Can; Goodridge SS lines; Ported TB; RK Sport hood; Hotchkis chassis brace; KW V3 coilovers;
Michael_Js is offline   Reply With Quote
Old 09-20-2010, 10:50 AM   #7
TooCool5
Resident Gearhead
 
TooCool5's Avatar
 
Drives: 2010 Camaro 1LS 3.6 LLT V6 325 HP
Join Date: May 2009
Location: Central CT
Posts: 3,569
Couple of minor re-flashes of the computer to upgrade the HVAC and air bag light to make improvements.
This car is awesome quality!
__________________
2010 Camaro Auto, Inferno Orange, Titanium Interior, Gearhead Wheels AIRAID CAI
TooCool5 is offline   Reply With Quote
Old 09-20-2010, 10:54 AM   #8
Partick

 
Partick's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Aug 2009
Location: NorCal
Posts: 976
8500 miles, HVAC reprogram and spoiler bolts otherwise as solid a new ride as I have ever had
Partick is offline   Reply With Quote
Old 09-20-2010, 11:26 AM   #9
myold88


 
myold88's Avatar
 
Drives: SUMMIT WHITE 2SS/RS CAMARO
Join Date: Feb 2008
Location: Ct.
Posts: 5,331
14 months and 8800 miles and my SS is still perfect.
__________________
myold88 is offline   Reply With Quote
Old 09-20-2010, 11:54 AM   #10
spyderbuddy


 
spyderbuddy's Avatar
 
Drives: v6 rs inferno orange/inferno orange
Join Date: Mar 2010
Location: albany, ga
Posts: 2,560
200 miles front gfx was coming off
4500 miles lite in drivers door went out
5000 miles seat rail broke and they cannot fix
now i have 9000 miles on the car seat is still not fixed and paint
on each side of black fillers in trunk area is pealing off
rear view mirror is loose
but i love the car
__________________

Heritage Grill, Manual Shifter Boot, Paddle Shifters, Led Lighting, MBRP Exhaust tips, CNC Trottle Body, Trifecta Tune, Vararam Intake/Green Filter, Chevorlet door Sills, Trunk Black out and RX Catch Can/Breather Kit
spyderbuddy is offline   Reply With Quote
Old 10-03-2010, 09:16 AM   #11
Nat's 2LT/RS
Nathan
 
Nat's 2LT/RS's Avatar
 
Drives: 2010 Camaro 2LT/RS
Join Date: Sep 2010
Location: Ann Arbor, MI.
Posts: 12
At 500mi. coolant hoses were leaking near the trans. Had them fix some Imperfections in the paint, twice. The quality of the body shop was horrible. Three days to fix the leak (one of which was just waiting on the parts). 1.5 weeks on the paint.
__________________
Yes it's the Bumblebee car, no that's not why I bought it!
Nat's 2LT/RS is offline   Reply With Quote
Old 10-03-2010, 04:28 PM   #12
The Stig
knows 2 facts about ducks
 
The Stig's Avatar
 
Drives: ...and they're both wrong
Join Date: Aug 2009
Location: The HMS Invincible
Posts: 26,690
brakes issue. Called Chevrolet -> explained -> called BBB and explained -> car deemed lemon and being replaced at dealers expense.
__________________
Click to view my build thread
The Stig is offline   Reply With Quote
Old 10-03-2010, 04:36 PM   #13
Capthowdy

 
Capthowdy's Avatar
 
Drives: 2010 2SS RS IOM
Join Date: Jun 2010
Location: Fort Lauderdale Fl
Posts: 1,048
Send a message via Yahoo to Capthowdy
going tomm for a bunch of paint work... rear spoiler chipping, front clip orange peel. roof has like black sploges under the paint, and bad swirls that where there the day I took delivery..
__________________
THE "MENACE"
Capthowdy is offline   Reply With Quote
Old 10-03-2010, 04:57 PM   #14
Merc
COTW 12/5/11
 
Merc's Avatar
 
Drives: 2010 Camaro 2SSRS IOM
Join Date: May 2009
Location: Abbotsford BC Canada
Posts: 8,261
Broke tranny output shaft. Been at dealer for a week now. Hope to know tomorrow if it's fix or replace.
Merc is offline   Reply With Quote
Old 10-05-2010, 09:40 AM   #15
pennor
 
pennor's Avatar
 
Drives: 2011 2LT - 73 Corvette 454
Join Date: Sep 2010
Location: Salem, OR
Posts: 240
It could be that these cars are just TOO complex and computerized, but mine went in at 80 miles and continues to go back in with the same problem that the dealer can't seem to fix. It runs fine, but constantly tells me to "TIGHTEN THE GAS CAP". The cap is as tight as it can be. The dealer has replaced the cap, smoke tested the fuel system, updated the software, and it still happens about every other day. If this is an omen for what I can expect for the next 100,000 miles then I may have made a huge mistake with this car. Time will tell.
pennor is offline   Reply With Quote
Old 10-05-2010, 11:00 AM   #16
CFD



 
Drives: 2SS/RS L99 BLACK
Join Date: Apr 2010
Location: MASS.
Posts: 4,813
Had it 6 months now, 14,876 miles and car has been perfect.
CFD is online now   Reply With Quote
Old 10-05-2010, 01:20 PM   #17
mad@gm
 
Drives: was a 2010 2SS/RS
Join Date: Oct 2010
Location: north carolina
Posts: 169
I dont even really want to get into what a pile of crap mine is! Pretty pile of crap but it is a pos. Ive already posted my multitude of problems in a couple of posts, and I dont hate the camaro, just the a-holes at gm and dealerships that wont fix it.
mad@gm is offline   Reply With Quote
Old 10-05-2010, 03:53 PM   #18
HaZe_X

 
HaZe_X's Avatar
 
Drives: Trailblazer SS & Camaro SS
Join Date: Nov 2009
Location: North Jersey
Posts: 759
Had mine since dec 09, 3050 miles on it now..only problem I had was the passenger side headlight needing to be replaced twice.
__________________
2010 Camaro 2SS/RS/LS3 -Black on Black - Kooks 1-7/8 Headers, Dyno Tuned, ADM Race CAI, QTP Cutouts, Hurst Short Throw, SJM Line Lock, Alpine PDX 1.1000, (2) Alpine Type R's, ...Soon to be cammed!
HaZe_X is offline   Reply With Quote
Old 10-05-2010, 08:15 PM   #19
SSLarry

 
Drives: 2SS LS3
Join Date: May 2010
Location: Southeast Florida
Posts: 1,408
Quote:
Originally Posted by mad@gm View Post
I dont even really want to get into what a pile of crap mine is! Pretty pile of crap but it is a pos. Ive already posted my multitude of problems in a couple of posts, and I dont hate the camaro, just the a-holes at gm and dealerships that wont fix it.

Wow. What kind of stuff? Drive train, cosmetic?
__________________

2010 CGM 2SS LS3, born: 4/10
SSLarry is offline   Reply With Quote
Old 10-06-2010, 07:36 AM   #20
mad@gm
 
Drives: was a 2010 2SS/RS
Join Date: Oct 2010
Location: north carolina
Posts: 169
All this is in one year, burnt through 4qts oil by 5-6k, audio reprogrammed twice and radio still will say aux jack out when its not, rear speakers loose and rattle- told operating as designed, paint coming off in multiple spots bumper to bumper told nothing we can do cause we dont know whats going on- heres a clue the paint is falling off, door speakers replaced, amp replaced, hvac reprogrammed once and still loose heat, clutch is catching at the top of the petal, Im told normal for a seated hydraulic system, trans has a bearing noise clutch release/imput shaft-dont know dealer says its not there even though every one else can hear it, tires dont like to hold air, exhaust rattles at low speed under load, 1-3 hard to upshift,1-2 downshift almost cant at times, and here recently my anti-freeze was low and the dealership says no leaks! I have been to three dealerships over this car and fought w/customer care since the end of april, the last dealership actually told me not to come back because Im trying to use them to get the lemon law, so now on to looking for #4 just to try and get my car fixed.
mad@gm is offline   Reply With Quote
Old 10-06-2010, 07:50 AM   #21
01pewterz28
Camaro Junkie
 
01pewterz28's Avatar
 
Drives: 2010 2LT/RS,Born 9/14/09 @ 11:50:57
Join Date: Aug 2008
Location: Ocoee, FL
Posts: 7,378
So far only issues are

1. Lose XM antenna after delivery (fixed and replaced with painted XM antenna)
2. TSB on distorted front speakers for the BA system (replaced)
3. Plastic on side of driver’s seat coming lose (ordered new part waiting for it to arrive)
4.Paint peeling on rear bumper (repainted), paint peeling on inner front 1/4 panel(driver side) re-painted).


So far 24k on the clock no other issues

Sean
__________________
2010 2LT/RS, 2001 Z/28, 2014 Malibu LT
01pewterz28 is offline   Reply With Quote
Old 10-06-2010, 09:22 AM   #22
SSLarry

 
Drives: 2SS LS3
Join Date: May 2010
Location: Southeast Florida
Posts: 1,408
Quote:
Originally Posted by mad@gm View Post
All this is in one year, burnt through 4qts oil by 5-6k, audio reprogrammed twice and radio still will say aux jack out when its not, rear speakers loose and rattle- told operating as designed, paint coming off in multiple spots . . . Im trying to use them to get the lemon law, so now on to looking for #4 just to try and get my car fixed.

I can see by your username that your intent on joining this forum is to deal with Camaro issues and / or to bash GM

Nothing wrong with that. I wish you luck, but I know GM usually tries to make clutch issues seem like the driver's fault. In your case however they ARE fixing the problem free of charge, you just need to find a competent dealer.
__________________

2010 CGM 2SS LS3, born: 4/10
SSLarry is offline   Reply With Quote
Old 10-06-2010, 10:38 AM   #23
cowjazz
 
Drives: 2010 2SS
Join Date: Jul 2010
Location: Frisco, TX
Posts: 154
six months, 16K miles, not a single problem.
cowjazz is offline   Reply With Quote
Old 10-06-2010, 10:55 AM   #24
mad@gm
 
Drives: was a 2010 2SS/RS
Join Date: Oct 2010
Location: north carolina
Posts: 169
No bad intentions on my joining, and Im trying my hardest to not bash gm either, but however after six months of fighting for whats right and getting blown off by customer care its becoming rather hard not to want to bash someone! I have always supported gm in the past, only owned gm cars, and currently own two other gm cars that are very good, my dad spent his whole life working for gm, and cause of gm my family had many nice things, so being said I have always supported them, but with the poor treatment, no call backs when promised, and the one simple thing I've requested being that a district rep get involved not happening please explain why I should'nt be upset, should people not know how gm has handled my problems?
mad@gm is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Will upgrading audio system void warranty? Recce Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 17 08-14-2010 12:18 PM
Warranty vinyljunkie Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 31 07-08-2010 12:59 PM
Any warranty issues after non GM spec. Diff Fluid? Ron66Vette&10SS Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 8 06-18-2010 01:32 PM
Vortech Install Thread - A&A Corvette - Follow Along Steve@AandACorvette Forced Induction - V8 157 01-05-2010 05:59 PM
brand new Camaro has warranty history and work performed??? full of days Camaro Price | Ordering | Tracking | Dealers Discussions 13 12-09-2009 10:13 AM


All times are GMT -5. The time now is 08:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.