Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
B&M
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 09-22-2010, 06:50 PM   #1
CamK18
 
CamK18's Avatar
 
Drives: 2010 1LT Vic Red
Join Date: Oct 2008
Location: Cambridge, Ontario
Posts: 158
Potential factory problem or bodyshop error...lots of pics

Ok so the story goes...

I was leaving a parking lot at school one day and mis judged a curb, which scraped my passenger side side skirt about 3 feet up and took some paint off in some spots and just scratched some spots. Needless to say i was pissed at myself.

So I took the car to GM, got a quote to just PAINT the side skirt. Their price? $680 + tax. So i literally laughed and left.

Went to a couple body shops in the area and found a decent one that seemed repuatable (came by reccomendation), so i decided to go with them for $230. This was monday.

So i called today and asked how the job was going. He asks me "Did you try to repair this yourself already".

As soon as he said this, im thinking oh shit...here we go, something broke. So i told him no, asked why, and he told me that there were 3 clips that were broken and it looked like "someone" tried to put them back on with super glue.

As well, the brackets that hold the clips in place (which are part of the skirt itself), were bent and not properly put on at the factory.

So now im pissed. very pissed. So i head down there unannounced with my camera to take pictures of said damage and he did not seem to mind at all to show me the damage.

So what do you guys think, judging by these pics, manufacturer problem or body shop error?

***Notice the blue x's indicating which clips are broken*** Factory put them there?







__________________
CamK18 is offline   Reply With Quote
Old 09-22-2010, 07:51 PM   #2
sgseward
 
sgseward's Avatar
 
Drives: 2010 IOM 2SS
Join Date: May 2010
Location: Manassas, Va
Posts: 69
Probably done by the same crew mounting spoilers that are chipping the trunk paint!
sgseward is offline   Reply With Quote
Old 09-23-2010, 10:17 AM   #3
f5journal
Senior Camaro Fanatic
 
f5journal's Avatar
 
Drives: 2011 SS/RS manual - White
Join Date: Aug 2010
Location: aiken, sc
Posts: 2,044
I think the body shop did not know how to remove them....or, the initial scrape damaged them
f5journal is offline   Reply With Quote
Old 09-23-2010, 10:36 AM   #4
Russell James


 
Russell James's Avatar
 
Drives: '12 SS/RS LS3 IBM
Join Date: Dec 2009
Location: SE Michigan
Posts: 3,442
highly doubt, probably 0% probability that happened at the assembly plant.

One guess might be someone lifted it with a hoist incorrectly one day and then tried to cover their tracks by glueing stuff back together. I suspect a dealer or any other place the car has been on a hoist.
Russell James is offline   Reply With Quote
Old 09-23-2010, 10:45 AM   #5
IcallitROOSTER
 
Drives: Black 2011Auto/v6 2LT/RS blackint
Join Date: Jul 2010
Location: long beach, mississippi
Posts: 81
what was the miles on your car before you bought it, looks like some asshole at the dealership tried to take your car for a drive while it just sat on the lot and tried to fix his boo boo! i doubt highly that that came from the factory or production line
IcallitROOSTER is offline   Reply With Quote
Old 09-23-2010, 11:04 AM   #6
BlownSS

 
BlownSS's Avatar
 
Drives: 2010 Camaro SS/RS
Join Date: Oct 2009
Location: Lincoln Nebraska
Posts: 1,759
looks like the current body shop did NOT know how to remove them and just yanked it off (dont ask them, they will deny it). at the way they are broken, you have have definitely noticed they were not fitting well if it came that way from the factory!
__________________
2010 IOM SS/RS LS3, Hennessey HPE550 Polished Magnuson TVS2300 Supercharger. 3.4 Pulley. Kooks long tube headers / high flow cats. GHL Full exhaust. ZL1 Fuel Pump/ADM FPCM. MSW Bap. JRE ZL1 Race cam with new springs/pushrods/Trunion Upgrade. FIC 850cc injectors. ZR1 Map sensor. CAI Induction. JRE Tune.
BlownSS is offline   Reply With Quote
Old 09-23-2010, 11:18 AM   #7
grizzly44
 
grizzly44's Avatar
 
Drives: Victory Red 2SS LS3
Join Date: May 2009
Location: Maryland
Posts: 7
Well, being as I work at a body shop I can tell you the mounting tabs are obviously cracked and broken, but the telling detail is the "old" look of the clear silicone used to hold the clips to the tabs. Either the dealer had a little mishap before you took delivery (most likely) or GM repaired it at the factory (doubtful). Needs a new molding (and clips) if you want to make it right, I wouldn't repair it. The tolerances are too tight and unforgiving on the new Camaros.
grizzly44 is offline   Reply With Quote
Old 09-23-2010, 11:42 AM   #8
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,101
just post a Wanted ad in this forum for a rocker panel. Likely, someone has a pair laying around after they got the GFX kit.
ffrcobra_65 is offline   Reply With Quote
Old 09-23-2010, 03:10 PM   #9
CamK18
 
CamK18's Avatar
 
Drives: 2010 1LT Vic Red
Join Date: Oct 2008
Location: Cambridge, Ontario
Posts: 158
Quote:
Originally Posted by grizzly44 View Post
Well, being as I work at a body shop I can tell you the mounting tabs are obviously cracked and broken, but the telling detail is the "old" look of the clear silicone used to hold the clips to the tabs. Either the dealer had a little mishap before you took delivery (most likely) or GM repaired it at the factory (doubtful). Needs a new molding (and clips) if you want to make it right, I wouldn't repair it. The tolerances are too tight and unforgiving on the new Camaros.
Well I took the pics that I posted here to the dealer and they want to take a look at it on wednesday so I will see what they say. This car was a factory order if any of you were wondering...im starting to think this may have been a delivery mishap. still, very frusterating
__________________
CamK18 is offline   Reply With Quote
Old 09-25-2010, 08:22 PM   #10
diamondmike
 
diamondmike's Avatar
 
Drives: 2SS/RS
Join Date: Nov 2009
Location: Destin, fl
Posts: 442
looks like the car has been repaired incorrectly.
__________________

7.83 @ 172 and 1.15 60ft 5th gen
4.93@143
diamondmike is offline   Reply With Quote
Old 09-29-2010, 06:03 PM   #11
CamK18
 
CamK18's Avatar
 
Drives: 2010 1LT Vic Red
Join Date: Oct 2008
Location: Cambridge, Ontario
Posts: 158
Just an update for you guys,

Im pleased to say GM will be giving me a new side skirt. I am very happy that they are willing to make good for a mistake made
__________________
CamK18 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
irpq11 has permagrin...updated with vids..... PQ Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 198 01-15-2014 01:23 AM
Any pics of the car being painted at the factory? Ant Camaro Photos | Spyshots | Video | Media Gallery 1 07-12-2009 09:40 PM
Oshawa Striping Facility!! Hylton Cosmetics and Lighting Modification Discussions 46 04-21-2009 01:45 PM
Official factory stripe pics (not photochop) thread seadog Camaro Photos | Spyshots | Video | Media Gallery 10 04-09-2009 08:47 PM
Pics of all factory wheels on real cars, except the steelies. bret03 Wheels and Tires Talk Sponsored by The Tire Rack 28 01-16-2009 06:11 PM


All times are GMT -5. The time now is 01:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.