Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum


Reply
 
Thread Tools
Old 03-03-2011, 10:17 PM   #290
Gene Culley
Account Suspended
 
Drives: 2013 SS
Join Date: Dec 2009
Location: Boyertown, PA
Posts: 1,374
Smile

Quote:
Originally Posted by Moorepheus View Post
OK, I have been following the PDIM threads for a while. I am taking my car in for NY Inspection, so I am going to have them, hopefully, change out the PDIM or at least order the new one. There are times where my iPhone 4, my G/F's iPhone 3GS, an iPod will work and then there are times it just won't work at all. One afternoon, it totally locked up. I mean, no matter what device I plugged in, it would not see it. Weird. Took a few hours of not plugging anything into the USB port before it would see any device again. My question is, does anyone know what PDIM version they might replace mine with? Should I wait to see if the latest one that are replacing the 2011s with will go in my 2010?

Thanks
You need the 2011 version, but it will kick back on a warranty claim for the 2010 model. If you want the 2011 version you will have to pay for it.
Gene Culley is offline   Reply With Quote
Old 03-03-2011, 11:50 PM   #291
TAG UR IT
www.Camaro5store.com
 
TAG UR IT's Avatar
 
Drives: 2014 ZL1 #705
Join Date: Jul 2006
Location: SA, Texas
Posts: 26,563
Quote:
Originally Posted by Gene Culley View Post
You need the 2011 version, but it will kick back on a warranty claim for the 2010 model. If you want the 2011 version you will have to pay for it.
Mine was taken care of under warranty. I had to push a little, but my guys are good guys. Took care of me.
TAG UR IT is offline   Reply With Quote
Old 03-04-2011, 02:39 PM   #292
shazam
 
Drives: IOM/IOM 2LT
Join Date: Feb 2010
Location: Toronto
Posts: 44
Just got my car back 5 min ago with db/db

Didn't get a chance to really play with it, but I have a 2010 and I was also able to get the db/db installed under warranty. There was a fiasco with GM cancelling the order, but be nice to your service advisor and they will take care of you.

Ping me if your in Toronto and I can send you to my guy at New Roads Chevy if you're not having luck at other places.
shazam is offline   Reply With Quote
Old 03-04-2011, 06:57 PM   #293
kmcd
1,425 hp / supercharged
 
kmcd's Avatar
 
Drives: (2010 2SS/L99) (1999 Corvette)
Join Date: Oct 2009
Location: Austin, TX
Posts: 1,101
Still no TSB?
__________________
"If it's too loud...well, you know the rest."
kmcd is offline   Reply With Quote
Old 03-04-2011, 08:09 PM   #294
Papa T
 
Papa T's Avatar
 
Drives: 2011 2LT RJT, 6A, 19" polished
Join Date: Jul 2010
Location: Vermont
Posts: 747
Quote:
Originally Posted by TAG UR IT View Post
Papa, just plug in your USB and then push in the menu button on the right and hold it. It'll tell you which version you have....not which part number, but which version.
OK I checked the other night:
  • 2011 2LT
  • Factory ordered
  • Delivered at the begining of Sept 2010
    • CC
    • CE
I have had no issues that I am aware of.
I have used a USB drive, iPod touch (4th gen), and a Droid X, all work well.

So is there a reason to upgrade??

Thanks
__________________
Papa T is offline   Reply With Quote
Old 03-04-2011, 10:30 PM   #295
Gene Culley
Account Suspended
 
Drives: 2013 SS
Join Date: Dec 2009
Location: Boyertown, PA
Posts: 1,374
Smile

I understand your service department might be able to get it put through for you, but I was just made aware that many claims are kicking due to the wrong part number used. But hey, if you can get the new one for free, that is great!
Gene Culley is offline   Reply With Quote
Old 03-05-2011, 02:35 PM   #296
kmcd
1,425 hp / supercharged
 
kmcd's Avatar
 
Drives: (2010 2SS/L99) (1999 Corvette)
Join Date: Oct 2009
Location: Austin, TX
Posts: 1,101
Quote:
Originally Posted by Papa T View Post
OK I checked the other night:
  • 2011 2LT
  • Factory ordered
  • Delivered at the begining of Sept 2010
    • CC
    • CE
I have had no issues that I am aware of.
I have used a USB drive, iPod touch (4th gen), and a Droid X, all work well.

So is there a reason to upgrade??

Thanks

I used to have that version, and my USB would not stay in "RDM" mode when I shut the power down and started back up again. It also took an inordinate amount of time to index and would sometimes lock up. A few times the radio would not even recognize the device in the USB port. But, if you're not experiencing any anomalies, I wouldn't worry about it.
__________________
"If it's too loud...well, you know the rest."
kmcd is offline   Reply With Quote
Old 03-06-2011, 02:47 PM   #297
Papa T
 
Papa T's Avatar
 
Drives: 2011 2LT RJT, 6A, 19" polished
Join Date: Jul 2010
Location: Vermont
Posts: 747
Quote:
Originally Posted by kmcd View Post
I used to have that version, and my USB would not stay in "RDM" mode when I shut the power down and started back up again. It also took an inordinate amount of time to index and would sometimes lock up. A few times the radio would not even recognize the device in the USB port. But, if you're not experiencing any anomalies, I wouldn't worry about it.
OK Thanks.

If I do start seeing issues, is this covered under warranty, or do I have to pay out of pocked to resolve???
__________________
Papa T is offline   Reply With Quote
Old 03-06-2011, 03:46 PM   #298
Chaotic73
BUMBLLB
 
Chaotic73's Avatar
 
Drives: 2010 Camaro 1LT/RS
Join Date: Jun 2010
Location: Yardville, NJ
Posts: 1,452
I just had mine installed on Friday and I have DA/DA. Not sure if this is the newest, but so far I haven't had any problems.
__________________
Chaotic73 is online now   Reply With Quote
Old 03-06-2011, 09:40 PM   #299
kmcd
1,425 hp / supercharged
 
kmcd's Avatar
 
Drives: (2010 2SS/L99) (1999 Corvette)
Join Date: Oct 2009
Location: Austin, TX
Posts: 1,101
Quote:
Originally Posted by Papa T View Post
OK Thanks.

If I do start seeing issues, is this covered under warranty, or do I have to pay out of pocked to resolve???
Nope, you're in luck. Because you have a 2011 model, you can get the latest hardware/software under warranty. Tell your service manager about your problems and make sure the PDIM they install is PN 20985421. If they don't have it, make sure they order it because it's the one with the latest software.

After they install the new PDIM, your HW/SW code will be DB/DB, and you should be good to go.
__________________
"If it's too loud...well, you know the rest."
kmcd is offline   Reply With Quote
Old 03-07-2011, 07:52 PM   #300
i007spectre

 
i007spectre's Avatar
 
Drives: 2016 2SS, blue, NPP, mag, white int
Join Date: Aug 2009
Location: Kansas
Posts: 1,619
Looks like i may be able to get the upgrade now. My usb connection indexes all my music but when i go to by artist or by album it just list every single song. Also on the radio screen it only lists the song and not artist/ album.
__________________
2016 Camaro 2SS. Hyper Blue, Ceramic White, Auto, MRC, and NPP.
1100 - 9/25
2000 - 9/28
3000 - 9/30
3100 - 10/27
3300 - 10/28
3400 - 10/29 TPW 11/09
3800 - 11/10
4300 - 11/24
4B00 - 11/25
4200 - 12/5
5000 - 12/7
6000 - 12/11
i007spectre is offline   Reply With Quote
Old 03-07-2011, 08:20 PM   #301
kmcd
1,425 hp / supercharged
 
kmcd's Avatar
 
Drives: (2010 2SS/L99) (1999 Corvette)
Join Date: Oct 2009
Location: Austin, TX
Posts: 1,101
Quote:
Originally Posted by i007spectre View Post
Looks like i may be able to get the upgrade now. My usb connection indexes all my music but when i go to by artist or by album it just list every single song. Also on the radio screen it only lists the song and not artist/ album.
:( The problem is you're driving a 2010 year model. GM still won't let you upgrade to PN 20985421 under warranty because it's a 2011 part. You can buy the part and install it yourself (that's what I did), but they won't cover it under your warranty. How do you like that B.S.?

By the way. Still no TSB?
__________________
"If it's too loud...well, you know the rest."
kmcd is offline   Reply With Quote
Old 03-08-2011, 02:12 AM   #302
2010CamRS
 
2010CamRS's Avatar
 
Drives: 2010 Camaro 2LT RS
Join Date: Jun 2010
Location: Orange County, CA & Tempe, AZ
Posts: 15
Ok so like many of you i'm having the same problem with (HW:CC SW:CE).... Been to the dealer like 7 times (not a joke) and they keep telling me that they have installed the latest module and software..... My question is that they claim to say that when they get the module and install it they have to program it with the latest software from GM... So, is this true? I have heard many members saying that they have just installed the module themselves and it works (almost like plug-n-play).... I'm thinking this is a lie.... Also to note they have installed module 20893388 whatever the hell that is... Although I have instructed and given them part number 20927509 to fix my problem. So frustrating when I have so much info to help them help me!!!
2010CamRS is offline   Reply With Quote
Old 03-08-2011, 03:19 AM   #303
kmcd
1,425 hp / supercharged
 
kmcd's Avatar
 
Drives: (2010 2SS/L99) (1999 Corvette)
Join Date: Oct 2009
Location: Austin, TX
Posts: 1,101
Quote:
Originally Posted by 2010CamRS View Post
Ok so like many of you i'm having the same problem with (HW:CC SW:CE).... Been to the dealer like 7 times (not a joke) and they keep telling me that they have installed the latest module and software..... My question is that they claim to say that when they get the module and install it they have to program it with the latest software from GM... So, is this true? I have heard many members saying that they have just installed the module themselves and it works (almost like plug-n-play).... I'm thinking this is a lie.... Also to note they have installed module 20893388 whatever the hell that is... Although I have instructed and given them part number 20927509 to fix my problem. So frustrating when I have so much info to help them help me!!!
Here's the problem: They're giving you the latest 2010 PDIM. Unfortunately, that doesn't fix the problem because they're just replacing one bogus part with another bogus part. All the 2010 PDIMs are bogus! The suits at GM need to get off their @#$%^! asses and publish a TSB that allows the 2010 owners to get their PDIMs replaced with the 2011 PDIM under warranty. That's the only thing that fixes the problem! Man, this is frustrating!!

By the way. the software comes in the PDIM. They don't have to flash it, so if that's what they're telling you, your dealer is either lying or incompetent. Actually, that may be a bit harsh. They probably just don't realize that the PDIM is plug and play. If you get the latest PDIM (PN 20985421), it will have the latest software. Your goal is to see a HW/SW code of DB/DB, but you can't get there with a 2010 PDIM. They can replace it a hundred times, and it still won't work as advertised.

I feel your pain, man. That's why I finally gave up and replaced the part myself.

Oh yeah...still no TSB?
__________________
"If it's too loud...well, you know the rest."

Last edited by kmcd; 03-15-2011 at 11:32 PM.
kmcd is offline   Reply With Quote
Old 03-10-2011, 10:55 PM   #304
sauron
Emerald Coast Camaros
 
sauron's Avatar
 
Drives: 2011 2SS/RS SGM
Join Date: Sep 2010
Location: Pensacola, FL
Posts: 88
My 2011 with DA/DX worked great since Sept. when i bought the car... so i have been following this thread. well two days ago, she finally ceased to work. looks like a trip to the dealer next week.
sauron is offline   Reply With Quote
Old 03-11-2011, 12:17 PM   #305
SummoneR
Paul
 
SummoneR's Avatar
 
Drives: '10 2SS/RS M6 "Marauder"
Join Date: Mar 2009
Location: NOR*CAL
Posts: 6,276
Send a message via Yahoo to SummoneR
This is pretty irritating when there are plenty of other cars on the road that can integrate this just fine without issues... why is GM having such a tough time with this? Are their PDIM engineers incompetent? But the technology if they have to, crap...
I have an old Pioneer deck I installed myself on my FJ that works better than the one in my Camaro and the deck is three years older...
__________________
SummoneR is offline   Reply With Quote
Old 03-12-2011, 08:39 AM   #306
zag614
 
Drives: Inferno Orange LS
Join Date: Mar 2011
Location: Columbus Ohio
Posts: 7
I am sorry but I am confused on a few things… to much information going on in this thread.
Someone please correct me.

If I am correct I want part number 20985421 and it be DB DB.?

If I buy the kit will I get that module? Or do I need to buy the kit and then buy another new module? ( I am upgrading from 2011 LS)

Where is the best place to buy the kit?

Thank you
zag614 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio/Bluetooth/PDIM FAQ UCF w00t Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 134 06-18-2015 05:30 PM
How many people will E-85 their new camaro? Speed74SS Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 57 01-03-2011 03:16 PM
* * * OnStar iPhone application - UPDATE * * * CamaroScotty 5th Gen Camaro SS LS LT General Discussions 142 08-12-2010 12:13 AM
Tire Monitoring System monevz28 Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 7 11-22-2009 04:42 PM


All times are GMT -5. The time now is 11:24 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.