Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
ADM PERFORMANCE
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 10-02-2010, 07:08 PM   #1
jordan 572

 
jordan 572's Avatar
 
Drives: none
Join Date: Jul 2008
Location: MN
Posts: 1,720
Thumbs down stinky clutch

I believe my clutch is going as my car smells horrible. This is not driver error as something has gone wrong with my car. It has been good for all 2100 miles on it then today I got in it and started driving. When the pedal is 3/4 of the way out of first gear it feels like someone is tapping out on the clutch pedel,the car starts to vibrate slightly and the shifter shakes a tiny bit. I know I am not burning it as I can do it using no gas at all it it smells even worse. Anyone else have this problem? What was the solution? Please post!!
jordan 572 is offline   Reply With Quote
Old 10-02-2010, 07:16 PM   #2
Eric Baker

 
Drives: Black/Black 2SS/RS 6M
Join Date: Mar 2010
Location: Boston MA
Posts: 952
Don't hold it partially engaged? If you're slipping it extensively, that's your smell/problem. You want to slip the clutch as little as possible, or risk overheating and doing permanent damage.
Eric Baker is offline   Reply With Quote
Old 10-02-2010, 07:36 PM   #3
retrorsss
2010 RS 2SS
 
retrorsss's Avatar
 
Drives: 2010 RS 2SS
Join Date: Aug 2010
Location: Ithaca, NY
Posts: 49
Take it to the dealer before you get stranded!!

This does not sound good, I do not dare diagnose without more info, however if it smells that bad then either you are riding the clutch badly or something is not functioning correctly. I gather by the mileage that it is not operator error so I would make a stop a the nearest dealer asap.
__________________
K&N, MBRP exh. , Hurst, PEDDERIZED with drops/bushings, Chrome bumpers, retro hood vents, ACC marker tinted marker lights, and soon to have chrome rocker trim. Working on 20" custom rally rims next, then onto the supercharger.
retrorsss is offline   Reply With Quote
Old 10-02-2010, 08:44 PM   #4
jordan 572

 
jordan 572's Avatar
 
Drives: none
Join Date: Jul 2008
Location: MN
Posts: 1,720
Quote:
Originally Posted by retrorsss View Post
This does not sound good, I do not dare diagnose without more info, however if it smells that bad then either you are riding the clutch badly or something is not functioning correctly. I gather by the mileage that it is not operator error so I would make a stop a the nearest dealer asap.
yea and i have only got better at driveing since i got it. When i first got it I would just barely burn the clutch and get a wiff but now before this started i never got any clutch smell and could drive pretty smooth, i drove it like normal today and while driving it could smell it in the car then i noticed the shaking and the strong stench when I got out. the only way I can get it not to vibrate is speed shift. There has to be something wrong with the smell it is releasing. It smells so much stronger than when I use to just barely burn the clutch. It smells like brakes but i know it isnt because the car cost like normal when i push the clutch in.
jordan 572 is offline   Reply With Quote
Old 10-02-2010, 08:49 PM   #5
Huck1974
Account Suspended
 
Drives: 2011 2SS
Join Date: Jun 2010
Location: Springfield, Mo
Posts: 833
Stock clutch sucks. Good time to upgrade. Just a Saturday in the garage and your all good.
Huck1974 is offline   Reply With Quote
Old 10-02-2010, 09:28 PM   #6
jordan 572

 
jordan 572's Avatar
 
Drives: none
Join Date: Jul 2008
Location: MN
Posts: 1,720
Quote:
Originally Posted by Huck1974 View Post
Stock clutch sucks. Good time to upgrade. Just a Saturday in the garage and your all good.
I am really think of putting in a new clutch. What are people replacing? What company are you using?
jordan 572 is offline   Reply With Quote
Old 10-02-2010, 09:36 PM   #7
Huck1974
Account Suspended
 
Drives: 2011 2SS
Join Date: Jun 2010
Location: Springfield, Mo
Posts: 833
Quote:
Originally Posted by jordan 572 View Post
I am really think of putting in a new clutch. What are people replacing? What company are you using?
Have not managed to kill mine yet. I have tried, but I'm not as good as you at killing it. Call Adam at ADM performance. He is the man. My cam he sent is awesome. He helped me with my tuning. I'm buying all of my turbo parts from him. He is on it.
Huck1974 is offline   Reply With Quote
Old 10-02-2010, 10:02 PM   #8
GQ4Life


 
Drives: 2010 Camaro SS LS3
Join Date: Aug 2009
Location: Fishkill, NY
Posts: 5,211
I just had to replace mine. Bad clutch slip at the track..
I went with ZR1 from Jannetty racing. And I am really happy with this clutch. Just finished breaking it in yesterday.

If you have no plans on mods then stay stock and try and make dealer replace before 12K miles or a year.
If you have plans for mods call Jannetty Racing 203-753-7223
__________________
C7 Stingray ordered 6-7-13 (RCHT2P) 3300 status
GQ4Life is offline   Reply With Quote
Old 10-02-2010, 10:27 PM   #9
CUPRA

 
CUPRA's Avatar
 
Drives: 2011 2SS/RS - IOM/CGM Stripes
Join Date: Jul 2008
Location: Keller, TX
Posts: 1,282
My clutch has been fine for the 2500 miles I've had it, but mine too was stinky on Thursday this week for no real explicable reason. I've driven stick for 20 years now and not had a problem like this. It made a smell on Friday as well one time, and it's been fine since.

Wondering what's going on with it.
__________________


2011 - 2SS/RS - IOM/CGM Stripes • CUPRA • Ordered: 4/10/2010 Mine: 7/1/2010 - 426BHP+CAI
CUPRA is offline   Reply With Quote
Old 10-03-2010, 09:44 AM   #10
jordan 572

 
jordan 572's Avatar
 
Drives: none
Join Date: Jul 2008
Location: MN
Posts: 1,720
Quote:
Originally Posted by CUPRA View Post
My clutch has been fine for the 2500 miles I've had it, but mine too was stinky on Thursday this week for no real explicable reason. I've driven stick for 20 years now and not had a problem like this. It made a smell on Friday as well one time, and it's been fine since.

Wondering what's going on with it.
you feel any vibration?
jordan 572 is offline   Reply With Quote
Old 10-03-2010, 10:04 AM   #11
cab2g
love. my. car.
 
cab2g's Avatar
 
Drives: 2011 2SS/RS
Join Date: Jul 2009
Location: Chicago
Posts: 3,385
ok guys, my clutch is doing the stinky thing too sometimes! When I first got the car it happened a little, but I blame that on it being a brand new car and I wasn't used to where the friction point was. I didn't have ANY clutch smell for a long time, but then just before 2k miles my car started stinking something terrible every so often when shifting.
__________________
cab2g is offline   Reply With Quote
Old 10-11-2010, 12:32 PM   #12
ITMerc
Account Suspended
 
Drives: A.R.D. 1500, LSX Twin Turbo
Join Date: Jun 2009
Location: Houston, TX
Posts: 151
Sounds like pressure plate problems causing your clutch to slip. Take it to the dealership IMMEDIATELY. A fair# of folks have had issues with pressure plate bolts coming loose which is what it sounds like with you. If the bolts came out unevenly the pressure plate would make uneven contact with the clutch plate which would cause the tapping feel you reported AND that kind of contact would cause the clutch to slip excessively during engagement... hence the smell.

Based on what I've read they should give you no flak on replacing your pressure plate AND clutch under warranty since your problem should be easy to recreate/demonstrate to the tech...

Quote:
Originally Posted by jordan 572 View Post
I believe my clutch is going as my car smells horrible. This is not driver error as something has gone wrong with my car. It has been good for all 2100 miles on it then today I got in it and started driving. When the pedal is 3/4 of the way out of first gear it feels like someone is tapping out on the clutch pedel,the car starts to vibrate slightly and the shifter shakes a tiny bit. I know I am not burning it as I can do it using no gas at all it it smells even worse. Anyone else have this problem? What was the solution? Please post!!
ITMerc is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I want a new clutch, you too????? Sign here tjbusa V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 370 08-10-2013 03:27 AM
Clutch fluid contamination problems on Vette fixed for Camaro??? LDGn63 V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) 11 05-28-2012 09:17 PM
Clutch Problem phenixdragon Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 20 08-22-2010 10:51 AM
Oil Change Ramp mjlash22 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 17 01-21-2010 10:40 PM


All times are GMT -5. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.