Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
PFYC
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro DIY & HOW-TO instructions & discussions

Reply
 
Thread Tools
Old 06-08-2015, 03:13 PM   #1
Facilio87
 
Drives: camaro 2LT/RS
Join Date: Jun 2015
Location: Lebanon
Posts: 7
HELP!! REAR TURN SIGNAL PROBELEM

Hi im new this camaro form, so plz excuse my foolishness
i live in Lebanon middle east, no real experienced mechanics here..
I have a camaro 2LT/RS 2013

i recently got a msg on the dash saying to check rear left turn signal light.
So i checked & the left inner light was off, so i changed the bulb and couple of hours later it showed the same msg again, some problem..
i double checked if the bulb was correctly in, wires, the works..

Whats the problem and whats the solution, fuse or something??

dont want to go down to the dealer ship for something that i might be able to fix by my self..

Thanks any help would be appreciated
Facilio87 is offline   Reply With Quote
Old 06-11-2015, 12:13 PM   #2
gutterball

 
gutterball's Avatar
 
Drives: 2011 1LS M6 Supercharged
Join Date: Feb 2011
Location: New Britain, Ct
Posts: 844
Send a message via AIM to gutterball
That sounds like it was just a coincidence, The only way it would keep blowing Bulbs, is if the 12V was to high. Check your Display for Batt Volt. and if it's 12- 15 V don't wory about it. iF it's higher than 16V. then you have a bad alternator.
gutterball is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:01 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.