Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
BeckyD@RodgersChevrolet
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 11-10-2010, 08:20 PM   #1
GATORSS
 
Drives: 2011 IBM 2SS/RS
Join Date: Oct 2010
Location: OLIVE BRANCH, MS
Posts: 12
HELP PLEASE!!

Just installed the Air Raid cold air kit on my car and went to take it for a test drive. Nailed the gas and the car revved up like the transmission was slipping. I didn't disconnect the negative battery cable when installing. Could this cause it. (Wife's car with 900 miles.....she's gonna whoop me if I don't figure it out)
GATORSS is offline   Reply With Quote
Old 11-10-2010, 08:26 PM   #2
Supercharged SS
Account Suspended
 
Drives: 2010 Camaro
Join Date: Feb 2010
Location: Sandy Hook, CT
Posts: 12,020
Quote:
Originally Posted by GATORSS View Post
Just installed the Air Raid cold air kit on my car and went to take it for a test drive. Nailed the gas and the car revved up like the transmission was slipping. I didn't disconnect the negative battery cable when installing. Could this cause it. (Wife's car with 900 miles.....she's gonna whoop me if I don't figure it out)

Make sure everything is good with the maf!!! Is it plugged in, in the right location, that kind of stuff. Any maf issue will play havoc, even with the trans. I've had it happen to me. My guess is that what's up. Gd luck!!
Supercharged SS is offline   Reply With Quote
Old 11-10-2010, 08:28 PM   #3
midnighter
Account Suspended
 
Drives: nothing
Join Date: Nov 2010
Location: a hole
Posts: 21,173
Sounds serious.....the woop by the wife part.
midnighter is offline   Reply With Quote
Old 11-10-2010, 09:08 PM   #4
GATORSS
 
Drives: 2011 IBM 2SS/RS
Join Date: Oct 2010
Location: OLIVE BRANCH, MS
Posts: 12
All is good(won't be sleeping on the couch...at least not tonight)! I have no idea what the deal was. I had left the key in the ignition as well as turned the TC off as I was backing out of the garage. Came home and checked all the hoses as well as MAF and it was all okay. Removed the key. Let it sit for about 5 minutes and went back out in it. Stopped, turned the TC off again and proceeded to blow the tires off it. Cold air kit and 50 degree temps means good power! Now for the headers and a tune
GATORSS is offline   Reply With Quote
Old 11-10-2010, 09:13 PM   #5
oldfriend


 
oldfriend's Avatar
 
Drives: 2010 SS BLK IO interior
Join Date: Dec 2009
Location: 32*38' 49N. 16*55'42W
Posts: 7,004
2ss

Quote:
Originally Posted by GATORSS View Post
Just installed the Air Raid cold air kit on my car and went to take it for a test drive. Nailed the gas and the car revved up like the transmission was slipping. I didn't disconnect the negative battery cable when installing. Could this cause it. (Wife's car with 900 miles.....she's gonna whoop me if I don't figure it out)
YOU ASKED FOR ,DIDN'T YOU :mad0 259:: mad0259:
__________________
2010 BLK 2SS RS IO
oldfriend is offline   Reply With Quote
Old 11-10-2010, 10:49 PM   #6
caverman


 
caverman's Avatar
 
Drives: '69 SS Convertible
Join Date: May 2009
Location: DFW, TX
Posts: 7,066
Quote:
Originally Posted by midnighter View Post
Sounds serious.....the woop by the wife part.
__________________
-2010 Camaro 2SS | M6 | VR w/White Stripes | 1 3/4" KOOKS - 3" Magnaflow | LPE 3.91 gears | ADM tuned | Halltech w/ADM Scoop | Spohn/BMR Trailing Arm/Toe Rod | BC Coilovers| Pedders FE4 ZL1 swaybars | Cradle/Diff/Radius Rod bushings | VMax TB | Morimoto Projectors | MGW shifter | Red Calipers
Build Journal
caverman is offline   Reply With Quote
Old 11-10-2010, 10:52 PM   #7
caverman


 
caverman's Avatar
 
Drives: '69 SS Convertible
Join Date: May 2009
Location: DFW, TX
Posts: 7,066
I know you said all is good now but for those adding a CAI....after install you should drive the car around normally for 5-10 min. Give the car time to learn and adjust for the new air flow. Then give it HELL!

Just for grins you might do either a fuse pull or disconnect the battery over night. Then again, drive it normally for a little bit to let the car learn and make adjustments.
__________________
-2010 Camaro 2SS | M6 | VR w/White Stripes | 1 3/4" KOOKS - 3" Magnaflow | LPE 3.91 gears | ADM tuned | Halltech w/ADM Scoop | Spohn/BMR Trailing Arm/Toe Rod | BC Coilovers| Pedders FE4 ZL1 swaybars | Cradle/Diff/Radius Rod bushings | VMax TB | Morimoto Projectors | MGW shifter | Red Calipers
Build Journal
caverman is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.