Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Nightowl LED
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 11-22-2010, 05:06 PM   #1
13 ZL1
 
13 ZL1's Avatar
 
Drives: 2013 IOM ZL1
Join Date: Nov 2009
Location: Manteca CA
Posts: 688
EBCM Connector Question

Does anyone know how to release the connector from the control module? There is a red tab that slides up but there appears to be more you have to do in order to release the connector. I did not want to try and force it.
13 ZL1 is offline   Reply With Quote
Old 11-23-2010, 05:28 PM   #2
13 ZL1
 
13 ZL1's Avatar
 
Drives: 2013 IOM ZL1
Join Date: Nov 2009
Location: Manteca CA
Posts: 688
Figured it out

I was able to undo it after taking a picture. The service manual says to make sure the ignition switch is off.

1. Pull back the Red tab to disengage from the gray plastic catch by the cable tie.
2. Push down on the ribs of the Gray plastic at the right edge of the Black plastic.
3. Pull back on the Black plastic which will eject the connector.
Attached Images
 
13 ZL1 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please EXPLAIN Stabilitrak/Traction Control, Launch Control! drtwo Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 9 09-29-2009 12:54 PM


All times are GMT -5. The time now is 09:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.