Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vitesse Motorsports
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 11-24-2010, 03:59 PM   #1
Cmlloveless

 
Drives: 2010 2SS RS
Join Date: Jul 2009
Location: Winchester, Ca
Posts: 921
Need quick help!

Can someone tell me why my engine just over heated? I replaced my heater hoses with the metal ones so that it would look better. Now I'm sittin on the side of the road with an over heated engine! I checked for leaks already and there arnt any! The radiator is still filled with fluid! I don't understand!
Cmlloveless is offline   Reply With Quote
Old 11-24-2010, 04:02 PM   #2
justa25thTA

 
justa25thTA's Avatar
 
Drives: 2011 Camaro SS/RS LS3
Join Date: Aug 2010
Location: Texas
Posts: 1,632
air bubble?
__________________
Yeah, I'll get around to it...
justa25thTA is offline   Reply With Quote
Old 11-24-2010, 04:05 PM   #3
Tonkin Chevrolet
 
Tonkin Chevrolet's Avatar
 
Drives: Camaro
Join Date: Sep 2010
Location: Portland Or
Posts: 380
Only a couple of possibilities I can think of.

1. Did you purge the air out of your system after the installation?
2. Maybe a plug was disconnected for the electric fans by accident?

It’s really hard to tell when you can’t be there and I am sure you took care of number 1.
Tonkin Chevrolet is offline   Reply With Quote
Old 11-24-2010, 04:05 PM   #4
Oldrocker
 
Oldrocker's Avatar
 
Drives: 2010 SS2/RS Victory Red
Join Date: Jul 2009
Location: Here and Now
Posts: 386
Quote:
Originally Posted by Cmlloveless View Post
Can someone tell me why my engine just over heated? I replaced my heater hoses with the metal ones so that it would look better. Now I'm sittin on the side of the road with an over heated engine! I checked for leaks already and there arnt any! The radiator is still filled with fluid! I don't understand!
Sounds like an air pocket. Air in the system will not allow proper coolant flow.
Oldrocker is offline   Reply With Quote
Old 11-24-2010, 04:16 PM   #5
Silver Ice Man
 
Silver Ice Man's Avatar
 
Drives: 2014 2SS/RS Spring limited edition
Join Date: Jul 2009
Location: Sylvan Lake, Ab
Posts: 474
Dumb question here guys, but how do you purge the coolant system??
Hope I never have to drain it, but good to know in the event that it ever happens
Thanx
__________________
2014 2SS/RS, Spring Limited Edition...
Ask yourself.....when you turn on your car..... Does it return the favor.....lol
MODS: CIA cold air intake, Oil catch can, Dynatech Cat back exhaust, more to follow....
Silver Ice Man is offline   Reply With Quote
Old 11-24-2010, 04:22 PM   #6
Cmlloveless

 
Drives: 2010 2SS RS
Join Date: Jul 2009
Location: Winchester, Ca
Posts: 921
Thnx for the quick responses! I'm thinkin maybe it was an air pocket... I let it cool down for about 45 min reopened the radiator and the fluid level has dropped and inch or two... Thought I got it all out! Guess not! Good thing I still had a lttle fluid left in my trunk to top it off with! I was hoping there wasn't something I missed when I replaced the hoses!
Cmlloveless is offline   Reply With Quote
Old 11-24-2010, 04:25 PM   #7
bigsquirrel
My car runs on acorns....
 
bigsquirrel's Avatar
 
Drives: 2010 SS RS Inferno Orange
Join Date: Feb 2010
Location: Albuquerque
Posts: 1,347
No worries same thing happened to me. I thought I had everything out but once that air pocket hits the pump... no more coolant flow.
bigsquirrel is offline   Reply With Quote
Old 11-24-2010, 04:39 PM   #8
Cmlloveless

 
Drives: 2010 2SS RS
Join Date: Jul 2009
Location: Winchester, Ca
Posts: 921
With these new cars and their computers I was waiting for someone to tell me I needed to change some perameters or something!
Cmlloveless is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
quick nitrous video MileHighSS Camaro Photos | Spyshots | Video | Media Gallery 2 09-17-2010 07:14 PM
A quick video of my car taking off after having the mufflers deleted. bumblebeecamaro Camaro Photos | Spyshots | Video | Media Gallery 6 05-16-2010 03:28 AM
Lexol Premium Protectant Quick Wipes At ProperAutoCare.com Angelo@Autopia Wash/Wax/Detailing and Cosmetic Maintenance Parts 0 02-15-2010 12:32 PM
Lexol Premium 3-in-1 Leather Care Quick Wipes At ProperAutoCare.com Angelo@Autopia Wash/Wax/Detailing and Cosmetic Maintenance Parts 0 02-15-2010 12:30 PM
How am i doing on paint care(Pics Inside) and Quick detail or Not? Jferrell88 Cosmetic Maintenance: Washing, Waxing, Detailing, Bodywork, Protection 9 06-09-2009 09:16 AM


All times are GMT -5. The time now is 10:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.