Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Fabberge
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 11-28-2010, 11:05 AM   #1
swansor
 
swansor's Avatar
 
Drives: 2010 2SS ABM
Join Date: Jul 2009
Location: Boca Raton, Fl
Posts: 375
Send a message via ICQ to swansor Send a message via Yahoo to swansor
MBRP exhaust rattle

Thought I would post this in case anyone else is having issues with the MBRP exhaust system not staying secure and causing a rattle against the cross tunnel brace.

I was able to fix this (although I consider it a temp fix) by adding a bolt to the drivers side MBRP exhuast where it clamps to the OEM exhaust below the cat. The original exhaust has a pin protruding from it that holds/allows it to latch onto the clamp and keep it from coming loose. Without the pin the butt joint clamp comes loose and causes the remaining MBRP clamps to slip and allow the exhaust to sag and hit the cross tunnel. The pin on the passenger side is reversed and is on the OEM exhaust side so the clamp can latch onto it.


Edit: I have contacted MBRP for a permanent solution and am waiting to hear back from them

Here are some pics
Attached Images
          

Last edited by swansor; 11-28-2010 at 11:19 AM.
swansor is offline   Reply With Quote
Old 11-28-2010, 04:36 PM   #2
sting808

 
Drives: 4 wheels
Join Date: Apr 2009
Location: Honolulu, Hawaii
Posts: 809
Is the OE clamp on tight? Never had that problem with mine. I used anti seize and impact to tighten.
sting808 is offline   Reply With Quote
Old 11-29-2010, 11:32 AM   #3
Dosin
 
Dosin's Avatar
 
Drives: 2010 2SS RS black ground effects
Join Date: Oct 2010
Location: St. Louis MO/Quincy IL
Posts: 175
I have this problem and added longer bolts with washers to lower the strut bar. I called MBRP because it still rattles. I am waiting to hear back from them. The rattle is so annoying that hopefully a solution will be found.
Dosin is offline   Reply With Quote
Old 11-29-2010, 11:45 AM   #4
FRANK121
 
FRANK121's Avatar
 
Drives: 2011 Camaro SS
Join Date: Sep 2010
Location: Missouri
Posts: 505
I would loosen everything up and put in about a 1" or more spacer between the frame plate and your exhaust pipes, then re-tighten everything back up, loosen the frame plate and re- tighten the plate. You should end up with 1" or mare gap then.

Thats what I did with my x-pipe install and no noises yet. I also had it welded on so nothing could come loose or leak.
__________________
2011 Victory Red 2SS/RS
630hp. and 550ft. lbs.
Black Rally Stripes
6 Speed Automatic
Whipple 2.9L
LS3 Conversion
ARH LT Headers and X-Pipe
GMMP Axle Backs
Yank 2800 Stall
RotoFab CAI
RX Performance Catch Can
VMAX Ported Throttle Body
Built by C.B.I. Streetcars
Tuned By DSX Tuning
GM Quarter Flares
Camaro Floor Mats
FRANK121 is offline   Reply With Quote
Old 11-29-2010, 12:15 PM   #5
Dosin
 
Dosin's Avatar
 
Drives: 2010 2SS RS black ground effects
Join Date: Oct 2010
Location: St. Louis MO/Quincy IL
Posts: 175
Quote:
Originally Posted by FRANK121 View Post
I would loosen everything up and put in about a 1" or more spacer between the frame plate and your exhaust pipes, then re-tighten everything back up, loosen the frame plate and re- tighten the plate. You should end up with 1" or mare gap then.

Thats what I did with my x-pipe install and no noises yet. I also had it welded on so nothing could come loose or leak.
I actually did everything you said except the welding. I have a lot of washers and loosened everything on the lift. Then I pushed it all the way up and tightened everything. Still rattles. ????????
Dosin is offline   Reply With Quote
Old 11-29-2010, 01:32 PM   #6
swansor
 
swansor's Avatar
 
Drives: 2010 2SS ABM
Join Date: Jul 2009
Location: Boca Raton, Fl
Posts: 375
Send a message via ICQ to swansor Send a message via Yahoo to swansor
Quote:
Originally Posted by sting808 View Post
Is the OE clamp on tight? Never had that problem with mine. I used anti seize and impact to tighten.
I tightened the bolts on the OE clamp with a normal ratchet at first then bought a 18" breaker bar and broke the bolts. I dont believe anti sieze compound would have helped due to the force that the motor puts on the exhuast when at WOT but I didnt try that. since making the modification I have been running fine with no rattle.

Quote:
Originally Posted by FRANK121 View Post
I would loosen everything up and put in about a 1" or more spacer between the frame plate and your exhaust pipes, then re-tighten everything back up, loosen the frame plate and re- tighten the plate. You should end up with 1" or mare gap then.

Thats what I did with my x-pipe install and no noises yet. I also had it welded on so nothing could come loose or leak.
You cant imagine how many times I loosened everything up, put in the spacer etc. It kept coming loose by the drivers side OE clamp and then eventually affecting the MBRP clamps. I read elsewhere about welding it but when I brought it to an exhaust shop they strongly recommended I didnt as it would ruin the OE clamp which by the way is not available through GM. I had the exhaust shop replace the OE bolts with hardened bolts so they wouldnt break and they cranked it down to no avail. Lasted about 4 days.

I think there is a reason GM puts the pin for the clamp in opposite directions to off set the force of the push pull effect. MBRP R/D team says my idea should work but yet they dont think their is a need for it?????


I did send a follow up email to MBRP since they didnt bother to let me know what they found out. Here is their reply:

Hi Scott sorry for the slow response time,

I did talk to the R&D department and they thought your idea of the pin should work. to date you are the only one with the system coming loose on a daily basis and R&D has decided not to change anything at this time.
Has your system gave you any trouble since your modification ?
i would be happy to let the D&R department know you fix the issues your self
please let me know
thank you

Last edited by swansor; 11-29-2010 at 01:56 PM.
swansor is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Official 1/4 Mile (V8) 2010+ Camaro Fast List Merc Dragstrip and Launch Techniques Discussion 2816 12-23-2014 12:44 PM
MBRP Catback exhaust LS3 Chrisls20 V8 - Engine, Exhaust, Bolt-Ons, Tuning Equipment 4 07-23-2010 10:01 PM
Exhaust rattle near the resonator area? jtzako Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 3 07-11-2010 07:46 PM
MBRP Exhaust System Christmas Special GmPartsDirect.com V8 Bolt-Ons & Tunes 8 04-09-2010 09:58 AM
MBRP Exhaust is awesome Coop Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 11 10-13-2009 11:51 PM


All times are GMT -5. The time now is 02:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.