Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
FLOWMASTER
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Specific Models / Packages > Camaro Convertible Forum


Reply
 
Thread Tools
Old 04-21-2016, 04:24 PM   #1
marsmann
 
Drives: 2012 2SS/RS Vert M6
Join Date: Jun 2014
Location: South East, PA
Posts: 109
Question about new top

I got a new top installed on my car back in 2014. My car is not a daily driver and I seldom take it out in the rain. What I am wondering about, and hopefully someone here works at a dealer or can confirm, is do the new replacement tops automatically have the fabric seal/protection on it?

Or do they require to be sealed and treated once installed?

I was washing my car the other day. Normally I do not wet the top. This time, I felt it was due for a cleaning. So after wetting it I noticed water wasn't beading on it. It wasn't soaked necessarily, but I expected it to bead similar to a 303 or raggtop protectant provides.

so, is there a default protectant on tops when they are shipped to dealers? Or do new tops need a protectant applied? I'm going to go ahead and do it anyway but it made me want to know. More importantly it is good to know for others who may have their tops done in the future. This way folks know to request that of dealers as part of the replacement.

thanks!
marsmann is offline   Reply With Quote
Old 04-21-2016, 10:17 PM   #2
EM1/SS
 
Drives: 11 2SS/RS M6 vert
Join Date: Dec 2010
Location: Western PA
Posts: 641
I have mine replaced and I treated as soon as it was put on. I did the same for my original top. The water on my new one still beads off, and it's 2 years old.
__________________
LSA supercharger, Borla S-Type cat back, BMR/ Pedders Suspension, Kooks stepped LT's, GM 3.91, and RDP tune.
EM1/SS is offline   Reply With Quote
Old 04-21-2016, 11:11 PM   #3
marsmann
 
Drives: 2012 2SS/RS Vert M6
Join Date: Jun 2014
Location: South East, PA
Posts: 109
Quote:
Originally Posted by EM1/SS View Post
I have mine replaced and I treated as soon as it was put on. I did the same for my original top. The water on my new one still beads off, and it's 2 years old.
So that tells me your new top didn't come treated from factory, and they require treating after install then. Interesting. I'd like to hear from others.

I guess just assumed that it would be done with the new top replacement, or when you buy the whole car new from the dealer. Kind of sucks if that is not being done as the average person may not necessarily know they need to do that.
marsmann is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:00 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.