Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Apex Paul
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 01-28-2011, 08:24 PM   #1
Jay23
 
Drives: 2012 2SS 45th, 2007 VRSCDX
Join Date: Jun 2010
Location: Olathe KS
Posts: 299
Cold air inductions install, check engine light on

Hi, I just installed a cold air inductions cai and adm scoop, now my check engine light is on. I have checked all the connectors on the maf and they seem fine. Not sure what is going on, any suggestions?

The only other mod is muffler delete.

Jason
Jay23 is offline   Reply With Quote
Old 01-28-2011, 08:30 PM   #2
livefr33ordie
Looking for new home
 
Drives: Summit White 2SS/RS
Join Date: Feb 2010
Location: Bossier City, LA
Posts: 57
I have the same mods, no light. How long have you had it installed? Have you tried disconnecting the battery to reset everything?
livefr33ordie is offline   Reply With Quote
Old 01-28-2011, 08:38 PM   #3
Jay23
 
Drives: 2012 2SS 45th, 2007 VRSCDX
Join Date: Jun 2010
Location: Olathe KS
Posts: 299
no not yet, I just installed it tonight, the light was right away
Jay23 is offline   Reply With Quote
Old 01-28-2011, 08:40 PM   #4
ron10


 
Drives: 2010 2SS IOM L99
Join Date: Jan 2010
Location: LOUISVILLE,KY..
Posts: 7,317
did you make sure you didn't put the maf on backwards?if i remember right the blue wire is the first wire on the right.if it's on the left,it's backwards.only thing i can think of that would cause your problem.
ron10 is offline   Reply With Quote
Old 01-28-2011, 08:48 PM   #5
livefr33ordie
Looking for new home
 
Drives: Summit White 2SS/RS
Join Date: Feb 2010
Location: Bossier City, LA
Posts: 57
Kinda remember someone also having this problem and there MAF was not securely fitted to the new intake tube. Those little fine threaded screw are a pain in the butt. Try getting your allen keys out again and remove the MAF and re-secure it. Ensure that the screws are ran all the way home. I don't think the MAF can be installed backward and the holes line up. I could be wrong though.

Give it a try it couldn't hurt and it is easier than the battery option as well.
livefr33ordie is offline   Reply With Quote
Old 01-28-2011, 08:55 PM   #6
Kunihiro
 
Kunihiro's Avatar
 
Drives: 2010 Charcoal Gray, 2SS/RS
Join Date: Nov 2010
Location: Upland, CA
Posts: 66
I don't have the "CAI" brand intake, but here's the previous post:

http://www.camaro5.com/forums/showth...hlight=CAI+cEL

Allen
__________________

2SS/RS, CGM, Magnaflow Exhaust, Pfadt Suspension, Airaid intake

71 RS Camaro (Sold)
Z Car (Sorry, Nissan 350Z)
Kunihiro is offline   Reply With Quote
Old 01-28-2011, 08:58 PM   #7
Tampa Tuning
Like us on Facebook!

 
Tampa Tuning's Avatar
 
Drives: C5 Corvette/ 2010 Camaro
Join Date: Oct 2010
Location: Tampa, Fl
Posts: 2,439
sometimes guys when reconnecting the MAF plugs, they bend a prong in the male end of a connection. Pull off all the connections you disconnected and take a slow good inspection at the male prongs of each connections. If you bent one prong in, you'll have to get a pair of needle nose pliers to straighten it out then slowly reconnect.
__________________

Read this:
Vendor : Cold Air Induction/Magnuson
HP Tuners Mail order tuning program
VMAX Throttle body Vendor
www.TampaTuning.com
Tampa Tuning is offline   Reply With Quote
Old 01-28-2011, 09:24 PM   #8
Fraxum


 
Fraxum's Avatar
 
Drives: 2013 TT IOM 1LE
Join Date: Jan 2010
Location: South NJ
Posts: 2,636
Send a message via AIM to Fraxum
Quote:
Originally Posted by Kunihiro View Post
I don't have the "CAI" brand intake, but here's the previous post:
http://www.camaro5.com/forums/showth...hlight=CAI+cEL
Allen
I did have a CEL after a C.A.I. cai and scoop. I had a loose MAF because the slightly hard to get at screw was not bottomed out. But I do not think that was the cause of the CEL now.

Then I bought a scanner and realized I had installed my CAGs bypass on the reverse sensor. Doh!

No codes since I fixed that. Get a scanner or go to Autozone and they will scan.

One other thing it could be if you somehow pulled off the other end of that hose that attached to the CAI.
__________________

The 1LE Inferno build thread
More Seat Time. Thinking the 1LE is a keeper.
Fraxum is offline   Reply With Quote
Old 01-29-2011, 06:13 AM   #9
Jay23
 
Drives: 2012 2SS 45th, 2007 VRSCDX
Join Date: Jun 2010
Location: Olathe KS
Posts: 299
Went out and drove to work this morning, no light. Maybe it just needed to sit for a few hours? Oh well hopefully it stays off.
Jay23 is offline   Reply With Quote
Old 01-29-2011, 06:30 AM   #10
KybheSS
 
KybheSS's Avatar
 
Drives: Black '10 2SS/RS
Join Date: Apr 2010
Location: Kentucky
Posts: 332
How do you like the set-up? I also only have a muffler delete and was looking at the CAI with scoop. Sound difference? Power difference?
KybheSS is offline   Reply With Quote
Old 01-29-2011, 06:41 AM   #11
Tampa Tuning
Like us on Facebook!

 
Tampa Tuning's Avatar
 
Drives: C5 Corvette/ 2010 Camaro
Join Date: Oct 2010
Location: Tampa, Fl
Posts: 2,439
Quote:
Originally Posted by Jay23 View Post
Went out and drove to work this morning, no light. Maybe it just needed to sit for a few hours? Oh well hopefully it stays off.
Excellent!

Nice cool morning for a ride.
__________________

Read this:
Vendor : Cold Air Induction/Magnuson
HP Tuners Mail order tuning program
VMAX Throttle body Vendor
www.TampaTuning.com
Tampa Tuning is offline   Reply With Quote
Old 01-29-2011, 07:26 AM   #12
livefr33ordie
Looking for new home
 
Drives: Summit White 2SS/RS
Join Date: Feb 2010
Location: Bossier City, LA
Posts: 57
I want to get my girl out this morning. I love a cool morning ride. My tires hate it though.
livefr33ordie is offline   Reply With Quote
Old 01-29-2011, 01:43 PM   #13
Jay23
 
Drives: 2012 2SS 45th, 2007 VRSCDX
Join Date: Jun 2010
Location: Olathe KS
Posts: 299
Quote:
Originally Posted by KybheSS View Post
How do you like the set-up? I also only have a muffler delete and was looking at the CAI with scoop. Sound difference? Power difference?

I like it now that the sensor is off lol. It has a better growl at WOT, not too much louder when just cruising. It does feel more responsive now, but sometimes I wonder if that is just in my head or if I can really feel more power?
Jay23 is offline   Reply With Quote
Old 01-30-2011, 02:20 AM   #14
kobSS
 
kobSS's Avatar
 
Drives: 2010 2SS/RS
Join Date: Mar 2010
Location: San Diego, CA
Posts: 534
Quote:
Originally Posted by Jay23 View Post
I like it now that the sensor is off lol. It has a better growl at WOT, not too much louder when just cruising. It does feel more responsive now, but sometimes I wonder if that is just in my head or if I can really feel more power?
I actually just installed my CAI Inc. Intake this weekend... Is it just me or is the growl at WOT much louder? I tried revving the engine in neutral and didnt get so much growl. But when i'm cruisin it practically shakes my dash. I actually think it sounds pretty sweet, just curious if others experience it
__________________
2010 CGM 2SS/RS:
Pfadt'ed Out Level 4, Pfadt Featherlight Coilovers, Pfadt ZL1 Sways, Pedders Radius Rod Inserts, CTS-V Brakes, Borla S-Type, Quad Tips, Forgestar 22" F14's (Show), CAI Intake w/ scoop, Rx Catch-Can, AAC Lighting, Showstopper Sidemarkers

"Information is the oxygen of the modern age"

Build Thread
kobSS is offline   Reply With Quote
Old 01-30-2011, 06:00 AM   #15
Scott@Bjorn3D


 
Scott@Bjorn3D's Avatar
 
Drives: Kami, 2013 2SS LS3 Luvin
Join Date: Oct 2008
Location: Eufaula, Alabama
Posts: 6,000
Send a message via MSN to Scott@Bjorn3D
Now go get the CNC Vmax Ported Throttle Body and you all will be real happy. I have that along with my CAI and it is awesome.
__________________
2013 2SS, GM Strut Tower Brace, CAI Intake Black, VMAX TB, Elite Catch Can, Hotchkis Chassis Brace, Hurst Shifter, 3.91 1LE Complete Rear End, NPP, 1LE Track Pack,Factory Reproductions Style 41 ZL1 Fitment Wheels 10" on all 4 corners
Scott@Bjorn3D is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Supercharger / Turbocharger Results (INFO) Thread radz28 Forced Induction - V8 231 07-10-2014 05:42 PM
g5cr cai system anybody install or looking at one "pics" camarossrs2150 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 41 07-14-2011 08:26 PM
Cold Air Inductions TVS2300 Version Installation Issue DNA Forced Induction - V8 3 10-27-2010 01:15 PM
Check engine light on Boricua Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 4 08-28-2010 01:12 AM
AirAid Cold Air Intake anyone? Flynnaz Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 12 01-01-2010 09:05 PM


All times are GMT -5. The time now is 05:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.