Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Dyno Max
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 02-04-2011, 09:39 AM   #1
Larry@Speed Inc.

 
Drives: 1997 Mystic Teal Z/28
Join Date: Sep 2009
Location: Schaumburg , IL
Posts: 73
Speed Inc. cam pkg / bolt-on results

We have Paul's 2010 SS in from Ohio for one of our cam packages with UD pulley. The car came to us with the Vararam and full exhaust.

457 rwhp/419 rwtq

LS3/T56
Si TVS blower grind for the future plans of a 2300
226/238 .570/.585 113.5
Pac 1218 springs
Comp 7.400 pushrods
SLP UD pulley
XS Power 1 7/8 headers with cats and vibrant resonators
Magnaflow catback
Vararam
MSD wires
TR55 plugs








Larry@Speed Inc. is offline   Reply With Quote
Old 02-04-2011, 10:00 AM   #2
navyblueSS
 
Drives: 2002 Camaro SS
Join Date: Jul 2009
Location: Quitman, LA
Posts: 613
Nice numbers!
__________________
2010 M6 SS/RS SW w/IOM Stripes - Futral Motorsports Custom Cam & Tune 483rwhp - 449rwtq
navyblueSS is offline   Reply With Quote
Old 02-04-2011, 10:44 AM   #3
BowlingSS
Camaro Owner Since 1987
 
BowlingSS's Avatar
 
Drives: 2011 2SS/RS L99 RJT
Join Date: Jun 2006
Location: Lawrenceville, GA
Posts: 2,035
Do you have before numbers?

Bill
__________________
2011 Camaro 2SS/RS L99 RJT
CAI, Inc. Cold Air Induction;ADM Scoop
Rx Catch Can;Rx Breather;Roto-Fab Washer Container
VMax Ported RJT Throttle Body
XSPower Headers and XSPower 3" Exhaust System
Elite Engineering Tunnel Brace,
Gorilla Wheel Lock System;
Tinted Windows 35%;EFILive Tune
BowlingSS is offline   Reply With Quote
Old 02-04-2011, 11:14 AM   #4
Larry@Speed Inc.

 
Drives: 1997 Mystic Teal Z/28
Join Date: Sep 2009
Location: Schaumburg , IL
Posts: 73
Quote:
Originally Posted by navyblueSS View Post
Nice numbers!
THANKS

Quote:
Originally Posted by BowlingSS View Post
Do you have before numbers?

Bill
sorry, but we did not get a change to pre-dyno the car
Larry@Speed Inc. is offline   Reply With Quote
Old 02-04-2011, 12:10 PM   #5
cab2g
love. my. car.
 
cab2g's Avatar
 
Drives: 2011 2SS/RS
Join Date: Jul 2009
Location: Chicago
Posts: 3,385
I would LOOOVE to cam my car. Too bad I don't have the money for it right now. In a couple years I'll probably do it though. I want it mostly for the idle though. But who knows maybe I'll start racing this summer and want a boost!
__________________
cab2g is offline   Reply With Quote
Old 02-04-2011, 12:29 PM   #6
Larry@Speed Inc.

 
Drives: 1997 Mystic Teal Z/28
Join Date: Sep 2009
Location: Schaumburg , IL
Posts: 73
Quote:
Originally Posted by cab2g View Post
I would LOOOVE to cam my car. Too bad I don't have the money for it right now. In a couple years I'll probably do it though. I want it mostly for the idle though. But who knows maybe I'll start racing this summer and want a boost!

We always have some nice specials, so email me for an estimate if your curious on costs.

larry@speedinc.com
Larry@Speed Inc. is offline   Reply With Quote
Old 02-04-2011, 01:06 PM   #7
Bad70supreme


 
Bad70supreme's Avatar
 
Drives: 2010 aqua blue SS/RS M6
Join Date: Feb 2010
Location: plainfield, IL
Posts: 2,616
Nice numbers with a blower cam...e mail sent with a few questions.
__________________
217/228 .565 cam, th400 swap with 3600 stall, headers, GPI tune, VR intake, Bo white TB
11.63@ 118.6
11.66@ 119.5
Bad70supreme is offline   Reply With Quote
Old 02-04-2011, 06:57 PM   #8
USA1SS
 
Drives: 2010 Camaro 2ss
Join Date: Oct 2010
Location: Ohio
Posts: 50
Thanks Larry and the crew from Speed Inc. I asked and you delivered. HP is right where you said it would be. I can't wait to come up and hear it run and feel the new power. It sure looks good sitting on the dyno and it would look even better with the 2300 under the hood. See you as soon as the weather permits.
USA1SS is offline   Reply With Quote
Old 02-04-2011, 07:21 PM   #9
papabearcamaro

 
papabearcamaro's Avatar
 
Drives: 2012 Chevrolet Silverado 4x4 Z71
Join Date: Dec 2009
Location: WI.
Posts: 1,749
Very nice Larry!
Wont be long until mine is there at the shop getting the heads and Maggie installed.
I highly recomend Speed Inc. for any HP mods as they have done great work on my and other peoples cars.
__________________
SOLD(Traded for 2012 Silverado Z71 4x4 and 2012 Sonic Hatch.)...2010 Camaro 1SS/RS/LS3,yellow with House of Kolor Tangerine Pearl rally stripes,manual trans.Hurst short throw shifter,4 pack rally gauges,Roto-Fab air intake,Kooks long tube headers with high-flow cats,Borla S-Type catback exhaust,Comp Cam,PRC ported heads,Maggie with 3.6 pulley and 1:1 cog drive,secondary fuel system with 65lb injectors,ADM digital A/F and Boost gauge,Pfadt trailing arms and subframe bushings.614.25rwhp/566.82rwtq on 8# of boost.

2012 Chevrolet Silverado 1500 EX.Cab 4X4 Z71.
papabearcamaro is offline   Reply With Quote
Old 02-04-2011, 08:08 PM   #10
Jcobra

 
Jcobra's Avatar
 
Drives: 2010 2ss/rs M6
Join Date: Nov 2010
Location: Il
Posts: 926
Nice numbers, is it possible to get the TQ number up without a blower.
Jcobra is offline   Reply With Quote
Old 02-04-2011, 08:17 PM   #11
mlee
H-Town Camaro Club
 
mlee's Avatar
 
Drives: Number Twenty-Three
Join Date: Oct 2008
Location: Conroe, TX
Posts: 24,513
Nice.. Probably a 50 hp gain here if it's an M6... How bout a Video... how dies it sound?
__________________
.
mlee is offline   Reply With Quote
Old 02-04-2011, 08:23 PM   #12
Jcobra

 
Jcobra's Avatar
 
Drives: 2010 2ss/rs M6
Join Date: Nov 2010
Location: Il
Posts: 926
Yeah Larry is that an m6 and I'd like to see a video too. You gave me a quote a few weeks ago I'd like to hear what his set up sounds like.
Jcobra is offline   Reply With Quote
Old 02-04-2011, 08:23 PM   #13
mikeSS


 
mikeSS's Avatar
 
Drives: 2013 E92 M3
Join Date: Nov 2009
Location: MI
Posts: 7,335
Quote:
Originally Posted by mlee View Post
Nice.. Probably a 50 hp gain here if it's an M6... How bout a Video... how dies it sound?
ya how does it sound
__________________

2010 camaro cammed- sold
2013 E92 V8 M3 DCT ZCP
C7 pending order
mikeSS is offline   Reply With Quote
Old 02-05-2011, 06:06 AM   #14
Irnwkrkev
 
Irnwkrkev's Avatar
 
Drives: 2011 SS/RS LS3
Join Date: Oct 2010
Location: Miami
Posts: 478
Speed inc. did a great job of screwing up my order when they sent me and LS2 cam sprocket. They didn't have the decency to call me back after trying to explain they weren't sure that GM made a 3 bolt sprocket for the LS3. They did send me a new crank bolt and sprocket a week later after I had already purchased both from a local dealer that had them for me the next day. The car's a daily driver and I couldn't wait

Last edited by Irnwkrkev; 02-05-2011 at 12:40 PM.
Irnwkrkev is offline   Reply With Quote
Old 02-05-2011, 07:35 AM   #15
Never Satisfied
220/221 whatever it takes
 
Never Satisfied's Avatar
 
Drives: '10 1SS/RS M6 SW
Join Date: Jun 2010
Location: Lafayette In
Posts: 998
Quote:
Originally Posted by Irnwkrkev View Post
Speed inc. did a great job of screwing up my order when they sent me and LS2 cam sprocket. They didn't have the decency to call me back after trying to explaing they weren't sure that GM made a 3 bolt sprocket for the LS3. They did send me a new crank bolt and pulley a week later after I had already purchased both from a local dealer that had them for me the next day. The car's a daily driver and I couldn't wait
Doesn't surprise me one bit....you're lucky that's all they screwed up. My lone experience with Speed was much more costly.
__________________
2010 Summit White 1SS/RS M6
479rwhp/451rwtq 12.03 @ 121.62mph (1.9 60')
Never Satisfied is offline   Reply With Quote
Old 02-05-2011, 09:48 AM   #16
Mark Myles
 
Mark Myles's Avatar
 
Drives: 2010 2SS/RS IBM / Silver Stripes
Join Date: Mar 2010
Location: Northeast Michigan
Posts: 604


M
Mark Myles is offline   Reply With Quote
Old 02-05-2011, 07:24 PM   #17
papabearcamaro

 
papabearcamaro's Avatar
 
Drives: 2012 Chevrolet Silverado 4x4 Z71
Join Date: Dec 2009
Location: WI.
Posts: 1,749
Quote:
Originally Posted by Never Satisfied View Post
Doesn't surprise me one bit....you're lucky that's all they screwed up. My lone experience with Speed was much more costly.
This is not the first time you have made a negative comment about your dealings with Speed but you seem to not be willing to tell your side of the story. Willing to share?
Keep in mind,there is always two sides to a story.
__________________
SOLD(Traded for 2012 Silverado Z71 4x4 and 2012 Sonic Hatch.)...2010 Camaro 1SS/RS/LS3,yellow with House of Kolor Tangerine Pearl rally stripes,manual trans.Hurst short throw shifter,4 pack rally gauges,Roto-Fab air intake,Kooks long tube headers with high-flow cats,Borla S-Type catback exhaust,Comp Cam,PRC ported heads,Maggie with 3.6 pulley and 1:1 cog drive,secondary fuel system with 65lb injectors,ADM digital A/F and Boost gauge,Pfadt trailing arms and subframe bushings.614.25rwhp/566.82rwtq on 8# of boost.

2012 Chevrolet Silverado 1500 EX.Cab 4X4 Z71.
papabearcamaro is offline   Reply With Quote
Old 02-05-2011, 08:43 PM   #18
EvoWake
SSTOCK
 
EvoWake's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2010
Location: Midwest
Posts: 422
Nice Larry! interesting to see a similar set-up to mine, and to see the difference of an OD vs. cutouts etc.

Also, I Will vouch for Speed Inc. Here, not enough people share good experiences, and love to gossip about bad.

I've done business with them many times, and have NEVER had a problem, and have always been more than satisfied with their work and communication. \\
__________________
2010 Camaro 2SS/RS





EvoWake is offline   Reply With Quote
Old 02-06-2011, 01:14 AM   #19
Never Satisfied
220/221 whatever it takes
 
Never Satisfied's Avatar
 
Drives: '10 1SS/RS M6 SW
Join Date: Jun 2010
Location: Lafayette In
Posts: 998
Quote:
Originally Posted by papabearcamaro View Post
This is not the first time you have made a negative comment about your dealings with Speed but you seem to not be willing to tell your side of the story. Willing to share?
Keep in mind,there is always two sides to a story.
No, you're right this is what... the second time I've approached the subject without going into details? I will say that I think this is, the first time someone has publicly asked for the story, so it's not like I've been making accusations all over the site and refusing to back them up. In fact, the previous post in which I mentioned not being happy with Speed, I was pm'd by another interested member and I shared everything with him. I am also aware that they are your "boys" and you are a vocal supporter of Speed Inc. It's funny too, because your car was in their shop while I was up there. The kid that took my debit card made mention of your car as we walked past it in the shop.

Anyway, July of last year, I ordered a set of Richmond 4.33's from Apex along with the proper install kit. At that time, I also emailed Larry at Speed for a quote on the install.
The gear install was scheduled for August 5th & 6th and was scheduled with Larry a month in advance. I explained to him that I lived 170 miles away in Lafayette Indiana and that I would drive the car up the morning of August 5th. I also explained that I had reserved a hotel room for the night and that I could pick it up the following day. I supplied all parts minus some incidentals like gear lube etc. The gears were brand new Richmond 4.33 ring & pinion with the appropriate new Richmond install kit. I also asked for a set of new Pfadt differential bushings to be installed along with a posi modification that was purchased from Ted at Jannetty Racing Enterprises. All supplied parts were also accompanied by full instructions. I exchanged several emails with Larry making sure that my expectations were understood. Things went just as planned and I picked the car up at 10 am on August 6th. On my trip home, I heat cycled the gears just as instructed. There were no noises or any reason to believe there were any problems. I do not drive my car on a daily basis. In fact, I have owned it for a year now and the odometer reads right around 3300.

Now fast forward a couple weeks to August 27th. I was out in my otherwise stock car taking my wife for a spirited drive when I suddenly felt a vibration in the drive-line. I could feel it though the floorboards. I was only a block away from my house, so I eased it home. At this point the car had no more than 500 miles on the new parts. I was distraught to say the least. I immediately emailed Larry to make him aware of what had transpired. I originally only contacted Larry for advice and to let him know the wonderful Richmond gears had most likely ended up like so many others at the time. We exchanged a number of emails, with ideas and possible scenarios on how I could troubleshoot. At no time, did I think or say that it was an install issue.
Due to the enormous cost of a flat bed ride 170 miles back to Speed Inc, I decided to put the car up on stands and remove the center section myself. Once removed, I pulled the rear cover and found three teeth broken on the ring gear. The wear pattern on the gears appeared to be wrong from what basic knowledge I have. I am mechanically inclined, but by no means an expert on gear installs. I decided at this point to have a third party inspect the damage and give me his expert opinion. I shipped the entire housing (still assembled) to a well respected Camaro5 vendor for analysis. Needless to say his findings were not good. I still have every email and all the pictures of the damage that he sent me. His findings showed the teeth had broken quite high on the ring gear. The cause of this was too much shim on the pinion. It had 0.007 too much to be exact. The backlash was checked in five spots and found to be 0.018-0.019, which is 0.014 too much. The Pinion only had 5 in lb of drag, spec for used bearings is 18 in lb. The pinion bearing was loose on the pinion and was removed by hand rather than a press. He also found metal transfer from the cap to the housing due to an improperly torqued left upper cap bolt. Now on the posi mod, it was also not done correctly, one side is correct and one side is wrong. This caused galling one one clutch plate and on one side of the housing destroying it in the process. I relayed all of this directly to Larry and he immediately denied any wrong doing. I never received any offers of compensation or anything from Speed. All I ever asked for was a refund of the roughly $745 for the labor.
Now, I will admit that I am not perfect and I should have kept my composure, as my tone in my emails to Larry began to approach that of a panic. I also should have found the courage to ship them the center section, but given what I was told, I couldn't stomach the idea of sending anything back to them. I do believe at some point I also made the mistake of threatening to get an attorney involved, even though I never followed through. I now know that was the wrong way to go about things. I have used numerous vendors all over the place and have never had an issue even remotely close to this.
I have now chalked it up as a learning experience, but that doesn't mean I'm not just a little bitter after being out $1896.02 (this is the total of my receipts for all parts and installation). Again, I never asked for new parts or the money to cover them....just wanted my install money back. I'm sure I will be flamed for something and that's fine. I am done now, and refuse to get into an back-n-forth with third parties about my experience. Take it for what it's worth......




__________________
2010 Summit White 1SS/RS M6
479rwhp/451rwtq 12.03 @ 121.62mph (1.9 60')
Never Satisfied is offline   Reply With Quote
Old 02-06-2011, 10:05 AM   #20
Bad70supreme


 
Bad70supreme's Avatar
 
Drives: 2010 aqua blue SS/RS M6
Join Date: Feb 2010
Location: plainfield, IL
Posts: 2,616
WOW that sucks... I heard alot of good things about them, but there is always a horror story too
__________________
217/228 .565 cam, th400 swap with 3600 stall, headers, GPI tune, VR intake, Bo white TB
11.63@ 118.6
11.66@ 119.5
Bad70supreme is offline   Reply With Quote
Old 02-06-2011, 09:43 PM   #21
showstopper
Showstopper Accessories

 
Drives: 2010 RS/SS
Join Date: Jul 2009
Location: Chicago
Posts: 2,949
Those are some nice numbers. Can't wait to bring my car in for the cam treatment. I am sure that just like my last car i will not even be able to tell that the car was worked on. Top notch installs over there.
__________________
showstopper is offline   Reply With Quote
Old 02-07-2011, 10:58 AM   #22
Larry@Speed Inc.

 
Drives: 1997 Mystic Teal Z/28
Join Date: Sep 2009
Location: Schaumburg , IL
Posts: 73
Quote:
Originally Posted by USA1SS View Post
Thanks Larry and the crew from Speed Inc. I asked and you delivered. HP is right where you said it would be. I can't wait to come up and hear it run and feel the new power. It sure looks good sitting on the dyno and it would look even better with the 2300 under the hood. See you as soon as the weather permits.
thanks Paul and we'll see ya soon

Quote:
Originally Posted by papabearcamaro View Post
Very nice Larry!
Wont be long until mine is there at the shop getting the heads and Maggie installed.
I highly recomend Speed Inc. for any HP mods as they have done great work on my and other peoples cars.
John we look forward to getting your monster together soon


Quote:
Originally Posted by mlee View Post
Nice.. Probably a 50 hp gain here if it's an M6... How bout a Video... how dies it sound?
Quote:
Originally Posted by Jcobra View Post
Yeah Larry is that an m6 and I'd like to see a video too. You gave me a quote a few weeks ago I'd like to hear what his set up sounds like.
yes M6



video is on our FB page and at idle with his exhaust it sounds super mild until WOT

here is a video of the same cam with SW full header back system




Quote:
Originally Posted by EvoWake View Post
Nice Larry! interesting to see a similar set-up to mine, and to see the difference of an OD vs. cutouts etc.

Also, I Will vouch for Speed Inc. Here, not enough people share good experiences, and love to gossip about bad.

I've done business with them many times, and have NEVER had a problem, and have always been more than satisfied with their work and communication. \\
thanks for the good word

Quote:
Originally Posted by Bad70supreme View Post
WOW that sucks... I heard alot of good things about them, but there is always a horror story too
We always strive to be the best, but being human things can occur. We will always work to solve an issue whatever that might be if given the chance and with Brents case we were not.

Quote:
Originally Posted by showstopper View Post
Those are some nice numbers. Can't wait to bring my car in for the cam treatment. I am sure that just like my last car i will not even be able to tell that the car was worked on. Top notch installs over there.
Pete we look forward to getting something done with your car come spring. I know you have been wanting the old school sound since day one along with some power.

thanks for the good word

BRENT : I was willing to work with you and told you we wanted the car or center back to review, but you chose not to do so. We took a lot of time with the install being it was our first ring/pinion on a 5th Gen ( which you were aware of ). We have 1 tech who has done gears for us for 9 years and many prior to that. We have never had an issue, but anything can happen and the reason I wanted to see the car or diff. The tech was confident that the ring/pinion setup was good and to spec as well as the posi mods which you had provided detailed instructions. I told you if we felt uncomfortable with the posi upgrades they would not be done.
I'm sorry this went down the road it did, but we are always willing to work with customer if an issue comes out to be sure everyone is happy in the end if given the opportunity. I'm still willing to help you on anything you might need in the future if given another opportunity.
Larry@Speed Inc. is offline   Reply With Quote
Old 02-07-2011, 11:03 AM   #23
Speed Inc

 
Drives: 2010 RS/SS Twin Turbo
Join Date: Dec 2010
Location: Chicagoland
Posts: 11
Brent, sorry about the ill feelings. The main issue is that we cannot give someone a refund based on what a competitor is telling them. Having the car or parts back for inspection would have greatly helped the situation. No one is perfect, (even considering we have more late model performance work under our belts than anyone in the area), but we always handle or "eat" the mistakes we make. I will leave it at that, and encourage you to email me if you want to.

Irnwkrkev, correct me if I am wrong....we made a shipping error, then sent you the correct part without ever receiving the incorrect sprocket back, along with a new crank bolt (no charge). Miami is almost a week shipping time. Sorry for the original error and delay, but we DID fix the mistake, and certainly could have given you a full refund if bought the sprocket locally instead of sending it.
Speed Inc is offline   Reply With Quote
Old 02-07-2011, 11:06 AM   #24
CyberPredator
50 Shades of Prey
 
Drives: TT/SS
Join Date: Oct 2010
Location: Between 10 and 20 PSI
Posts: 709
Larry did the car already have a an Underdrive pulley on it? the reason I ask is because that seems like it could be a waste of money. Once the blower goes on he's going to want the stock pulley on.
__________________
Futral Motorsports built and tuned
CyberPredator is offline   Reply With Quote
Old 02-07-2011, 11:08 AM   #25
Larry@Speed Inc.

 
Drives: 1997 Mystic Teal Z/28
Join Date: Sep 2009
Location: Schaumburg , IL
Posts: 73
Quote:
Originally Posted by CyberPredator View Post
Larry did the car already have a an Underdrive pulley on it? the reason I ask is because that seems like it could be a waste of money. Once the blower goes on he's going to want the stock pulley on.

The pulley was done with the upgrades since there was not really a time line on the next step of mods. We typically help the customer sell off items as they may change with upgrades, so not much really lost in the end.

stock or Innovators crank pulley will surely be used when the blower goes on

thanks for asking
Larry@Speed Inc. is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY: LS3 Camshaft Install (a lot of pictures, may take a moment to load) robertway Camaro DIY & HOW-TO instructions & discussions 253 09-02-2014 03:16 PM
Another L99 cam question....VVT! SS-screamer Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 90 06-28-2010 06:41 PM
ECS "DVL" Cam in the Gen V - Results and video! East Coast Supercharging Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 0 05-07-2010 09:47 AM
Texas Speed Long Tubes & Rumbler 5 Cat-Back Dyno Results! Trevor @ Texas Speed Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 47 09-06-2009 03:36 PM
BUDWEISER SHOOTOUT LINE UP CamaroScotty General Automotive + Other Cars Discussion 22 02-07-2009 07:03 PM


All times are GMT -5. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.