Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Hines Performance (HPE)
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons

Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons Bolt-Ons | Intakes | Exhaust

Reply
 
Thread Tools
Old 02-04-2011, 10:41 PM   #1
dmax86

 
dmax86's Avatar
 
Drives: 2013 ZL1 - M6
Join Date: Apr 2010
Location: TEXAS
Posts: 1,015
Texas Speed LT's and complete exhaust problem!!

A
__________________
2013 ZL1 BONE STOCK! LOL

Last edited by dmax86; 07-10-2012 at 05:49 PM.
dmax86 is offline   Reply With Quote
Old 02-04-2011, 10:50 PM   #2
IROCanSS
Account Suspended
 
Drives: 89 IROC 350
Join Date: Mar 2009
Location: Back roads, southern Ohio
Posts: 12,518
I only have about $1700 in Stainless works LTs and Flowmaster American Thunder cat back and its AMAZING. Fit and finish is PERFECT!
IROCanSS is offline   Reply With Quote
Old 02-04-2011, 11:07 PM   #3
dmax86

 
dmax86's Avatar
 
Drives: 2013 ZL1 - M6
Join Date: Apr 2010
Location: TEXAS
Posts: 1,015
Quote:
Originally Posted by jrhaus76 View Post
I only have about $1700 in Stainless works LTs and Flowmaster American Thunder cat back and its AMAZING. Fit and finish is PERFECT!

i am happy for you but your making me feel even worse.... i just spend 4 hours trying to correct it today... for the 5th time. and a chevy dealership and performance shop later....
__________________
2013 ZL1 BONE STOCK! LOL
dmax86 is offline   Reply With Quote
Old 02-04-2011, 11:25 PM   #4
JUISSD

 
JUISSD's Avatar
 
Drives: 2010 White/IOM 2SS/RS M6
Join Date: Jul 2010
Location: Houston, TX
Posts: 1,236
Sorry to hear about your problems. For some reason I thought you had a different set up on your car when I saw it at the shop. My ARH set up fits like a glove.
__________________
2010 White/IOM Camaro 2SS/RS M6


JUISSD is offline   Reply With Quote
Old 02-04-2011, 11:25 PM   #5
tjbusa
Serious Sleeper
 
tjbusa's Avatar
 
Drives: 2010 CGM 2SS/RS M6
Join Date: Nov 2008
Location: Lexington,SC
Posts: 3,171
Well its true, you get what you pay for, I wouldn't worry about the sub-frame brace, SLP instructs not to install it. Its pretty flimsy and is not much if any support.
__________________
***************************************
Drive-by

Fact of Life:

After Monday and Tuesday
even the calendar reads...
W T F
***************************************
tjbusa is offline   Reply With Quote
Old 02-04-2011, 11:31 PM   #6
dmax86

 
dmax86's Avatar
 
Drives: 2013 ZL1 - M6
Join Date: Apr 2010
Location: TEXAS
Posts: 1,015
Quote:
Originally Posted by JUISSD View Post
Sorry to hear about your problems. For some reason I thought you had a different set up on your car when I saw it at the shop. My ARH set up fits like a glove.

Yeah i want ARH and the same magnaflow i have now.... what did your exhaust run you?
__________________
2013 ZL1 BONE STOCK! LOL
dmax86 is offline   Reply With Quote
Old 02-04-2011, 11:37 PM   #7
JUISSD

 
JUISSD's Avatar
 
Drives: 2010 White/IOM 2SS/RS M6
Join Date: Jul 2010
Location: Houston, TX
Posts: 1,236
Quote:
Originally Posted by dmax86 View Post
Yeah i want ARH and the same magnaflow i have now.... what did your exhaust run you?
I bought my headers and catted xpipe used from a guy that put a turbo on his car. $1500 for them in great shape plus a basically new Fastlane CAI.
__________________
2010 White/IOM Camaro 2SS/RS M6


JUISSD is offline   Reply With Quote
Old 07-15-2011, 09:58 PM   #8
GEEo
OKCamaros
 
GEEo's Avatar
 
Drives: 4 banger Diesel
Join Date: Mar 2010
Location: Philippines
Posts: 4,602
Texas speed Headers having problems already?
GEEo is offline   Reply With Quote
Old 07-15-2011, 10:00 PM   #9
tarheel34
Go Heels!!!
 
tarheel34's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: May 2010
Location: WV
Posts: 244
Quote:
Originally Posted by GEEo View Post
Texas speed Headers having problems already?
Look at the dates of the posts. This can't be for their new 304s headers as they were released in June
__________________
Team L99

2010 Summit White 2SS/RS L99: TSP 1 7/8 LTs - Off-Road Pipes | Tuned By BLUECAT | CAI Cold Air Intake | ADM Race Scoop | SLP UD Pulley | VMAX Throttle Body | Magnaflow X-Pipe | Muffler Delete | SLP 160* T-Stat | MSD Wires
tarheel34 is offline   Reply With Quote
Old 07-15-2011, 10:05 PM   #10
GEEo
OKCamaros
 
GEEo's Avatar
 
Drives: 4 banger Diesel
Join Date: Mar 2010
Location: Philippines
Posts: 4,602
Quote:
Originally Posted by tarheel34 View Post
Look at the dates of the posts. This can't be for their new 304s headers as they were released in June
I hope not.
GEEo is offline   Reply With Quote
Old 07-15-2011, 10:35 PM   #11
Bay Area SS
 
Bay Area SS's Avatar
 
Drives: 2010 rs/2ss
Join Date: Mar 2011
Location: ca bay area
Posts: 669
Xs power complete system 650 bucks. Great quality sounds wicked,
Bay Area SS is offline   Reply With Quote
Old 07-15-2011, 10:58 PM   #12
DietCoke
Slow Turtle
 
DietCoke's Avatar
 
Drives: 2011 1SS
Join Date: Jun 2011
Location: Richmond Hill, GA
Posts: 1,119
Send a message via AIM to DietCoke
MY TSP stuff fit(s) great.
DietCoke is offline   Reply With Quote
Old 07-15-2011, 11:38 PM   #13
faSSt
**Sold n' Sad**
 
faSSt's Avatar
 
Drives: 11 F150 Supercrew FX4 5.0
Join Date: Nov 2010
Location: Cabot AR.
Posts: 280
Quote:
Originally Posted by DietCoke View Post
MY TSP stuff fit(s) great.
just installed my TSP 304 LT's with zero fitment issues.
__________________
2011 Camaro 2SS, SIM, 6M, HUD, 10% tint, black out lenses, SS emblems, TSP 304 LT's, Roto-Fab, MGW shifter, gto res, 8K BFXENON, HP Tuners, Redline Fluids. ***Sold*** Now in an 11' F150 supercrew FX4.
Still addicted to the this forum
faSSt is offline   Reply With Quote
Old 07-15-2011, 11:49 PM   #14
rjdapilmoto
DAP-ONE [COTW - 12/23/13]
 
rjdapilmoto's Avatar
 
Drives: 2010 - 2SS/RS IOM
Join Date: Jul 2009
Location: San Antonio, TX
Posts: 2,924
These are what you want....
Attached Images
 
rjdapilmoto is offline   Reply With Quote
Old 07-16-2011, 10:52 AM   #15
dmax86

 
dmax86's Avatar
 
Drives: 2013 ZL1 - M6
Join Date: Apr 2010
Location: TEXAS
Posts: 1,015
glad to hear guys! unfortunately my experience was not the same. after taking the whole system off and putting an air hammer to it i have massaged it enough to prevent any contact and vibration, especially where my tunnel brace is.
__________________
2013 ZL1 BONE STOCK! LOL
dmax86 is offline   Reply With Quote
Old 07-16-2011, 09:01 PM   #16
Jason 98 TA


 
Drives: Camaro
Join Date: Apr 2009
Location: Texas
Posts: 1,435
I've put on lots of sets with no issues at all. You have to put everything on and then locate the system correctly before tightening any clamps. The installer determines how good or bad the system fits. If you don't have it on correctly and tighten it down it will absolutely hit. It's all about taking your time and adjusting it.

The system is cnc bent, the product is very consistent.
Jason 98 TA is offline   Reply With Quote
Old 07-16-2011, 09:02 PM   #17
Jason 98 TA


 
Drives: Camaro
Join Date: Apr 2009
Location: Texas
Posts: 1,435
Bring the car to our shop and I'll adjust it for free for you.
Jason 98 TA is offline   Reply With Quote
Old 07-17-2011, 02:13 AM   #18
Bad70supreme


 
Bad70supreme's Avatar
 
Drives: 2010 aqua blue SS/RS M6
Join Date: Feb 2010
Location: plainfield, IL
Posts: 2,618
I am pretty sure its nothing but an adjustment issue... you may need to trim some pipe some were or something that is being overlooked.
__________________
217/228 .565 cam, th400 swap with 3600 stall, headers, GPI tune, VR intake, Bo white TB
11.63@ 118.6
11.66@ 119.5
Bad70supreme is offline   Reply With Quote
Old 07-17-2011, 10:05 AM   #19
stock00ss
 
stock00ss's Avatar
 
Drives: 2011 Camaro SS
Join Date: Feb 2011
Location: Birmingham
Posts: 173
I also have the tsp kit, I put it on my self and it went on perfect with no issues. Sounds great to.
stock00ss is offline   Reply With Quote
Old 07-17-2011, 10:09 AM   #20
GEEo
OKCamaros
 
GEEo's Avatar
 
Drives: 4 banger Diesel
Join Date: Mar 2010
Location: Philippines
Posts: 4,602
Quote:
Originally Posted by DietCoke View Post
MY TSP stuff fit(s) great.
Quote:
Originally Posted by faSSt View Post
just installed my TSP 304 LT's with zero fitment issues.
Thats good that you guys have good experience with TSP.

I've been lookin on getting one my self. but cant seem to decide on which to get. lol

Cant wait to see the results of that new 2".
GEEo is offline   Reply With Quote
Old 07-17-2011, 11:44 AM   #21
blk5genss
 
blk5genss's Avatar
 
Drives: 2010 Camaro 1SS/RS
Join Date: Jan 2011
Location: San Anonio, Texas
Posts: 574
I installed the complete TSP system with cats and had no issues what so ever! Jason is right though, if you tighten everything up too soon then you will have problems! Good luck!! I have ps 1 3/4 headers but plan on swapping them for. Set of tsp 1 7/8 headers in nov!!
__________________
TSP Cam 231/236 112 LSA,TSP UD,Fast 102 w/Ported TB,AirAid CAI,1 7/8 catted Stainless Power LT,3 IN MBRP 3 in Exhaust/180*,Spohn LTA's,Toe Links, Drag Bar,Diff bushings,Hurst shifter,Hendrix/DSS 1400HP Axles,Nitto NT555R's,Lethal Performance Custon Tune 480 RWHP 454 RWTQ!! Best run so far is 11.94@121 LPE 3.91's Coming soon NW 102, and DSS DS, then car should be complete!!!
blk5genss is offline   Reply With Quote
Old 07-17-2011, 06:05 PM   #22
dmax86

 
dmax86's Avatar
 
Drives: 2013 ZL1 - M6
Join Date: Apr 2010
Location: TEXAS
Posts: 1,015
Believe me I have done all that. Of course i put it all on loose then tightened. I just got mad and got the air hammer out. I dented it clear the drivers side of the rear end and clear my tunnel brace.
__________________
2013 ZL1 BONE STOCK! LOL
dmax86 is offline   Reply With Quote
Old 07-17-2011, 10:08 PM   #23
tvwilkes
 
tvwilkes's Avatar
 
Drives: 2014 AG 2SS
Join Date: Aug 2009
Location: Rainbow City,Al
Posts: 277
I ran this system on my 2010 camaro SS with zero issues. I am now going to install the 304 SS system on my 2011. The TSP kit is a great exhaust system, regardless of the cost.
__________________
2014 Camaro 2SS Ashen Gray
tvwilkes is offline   Reply With Quote
Old 07-18-2011, 12:00 AM   #24
dmax86

 
dmax86's Avatar
 
Drives: 2013 ZL1 - M6
Join Date: Apr 2010
Location: TEXAS
Posts: 1,015
Quote:
Originally Posted by Jason 98 TA View Post
Bring the car to our shop and I'll adjust it for free for you.

i appreciate the offer! i got it working for now. not trying to hate just wondering if i was the only unfortunate one.... :(
__________________
2013 ZL1 BONE STOCK! LOL
dmax86 is offline   Reply With Quote
Old 07-18-2011, 09:42 AM   #25
Jason 98 TA


 
Drives: Camaro
Join Date: Apr 2009
Location: Texas
Posts: 1,435
No not at all. The systems are all very consistent. It all depends on how it's aligned & then clamped together.
Jason 98 TA is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Texas Speed exhaust NOS2GO Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 3 01-02-2011 11:20 AM
Tuning required for LTs, CAI, exhaust sixty9fordkiller Tuning / Diagnostics -- engine and transmission 23 01-26-2010 08:50 AM


All times are GMT -5. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.