Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Rick@Livernois
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro DIY & HOW-TO instructions & discussions

Camaro DIY & HOW-TO instructions & discussions All DIY projects & discussions

Reply
 
Thread Tools
Old 01-26-2013, 05:42 PM   #1
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
HUD help?

So I am installing HUD right now and I am trying to put the dash back in but it won't line up. It is about an inch away from fitting perfectly and no matter what I do it will not line up. Any help, advice or does anyone know what to do. I am on a time crunch so any help is very appreciated
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 06:36 PM   #2
dkp2LT


 
dkp2LT's Avatar
 
Drives: '10 2LT/RS, '13 GT/CS, '10 Flex
Join Date: Feb 2012
Location: Kansas City, MO & Del Mar, CA
Posts: 2,502
Sorry no exact help but I remember on mine that I had the same issue and I just wiggled and played with until it basically just snapped into place.

And then I had to pull it out because I had to redo one thing - and I had to wiggle it again. The second time took longer of course.
dkp2LT is offline   Reply With Quote
Old 01-26-2013, 07:03 PM   #3
camaro2lt
 
camaro2lt's Avatar
 
Drives: 2010 Camaro 2lt VR/RS CGM Rally's
Join Date: May 2009
Location: palmyra pa
Posts: 5,255
lift up then in make sure you tie the alarm harness too a string
__________________
camaro2lt is online now   Reply With Quote
Old 01-26-2013, 07:07 PM   #4
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
We have been at it for about an hour and a half just trying to get this damn dash back in. The harness is tied to a string, it doesn't seem as if there is anything blocking it and it just wont go in. Its a 2012 dash being retrofitted into a 2010 2LT
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 08:55 PM   #5
camaro2lt
 
camaro2lt's Avatar
 
Drives: 2010 Camaro 2lt VR/RS CGM Rally's
Join Date: May 2009
Location: palmyra pa
Posts: 5,255
Quote:
Originally Posted by Aubrey64 View Post
We have been at it for about an hour and a half just trying to get this damn dash back in. The harness is tied to a string, it doesn't seem as if there is anything blocking it and it just wont go in. Its a 2012 dash being retrofitted into a 2010 2LT
i retrofited mine and it went in fine make sure the dash is level.....i noticed when we put mine back it it need to be level and i think the drivers side is suppose to be in first!
__________________
camaro2lt is online now   Reply With Quote
Old 01-26-2013, 09:01 PM   #6
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Ok so here is the problem that I am having. So I started the install of the HUD/2012 dash and everything was going great! the disassembly was long/tedious but nothing went wrong and I got everything out without any problems. I installed the HUD into my 2012 dash (that I bought off a salvaged car that had 4 miles on it), and I was then ready to put the dash back in. Me, and a mechanic that was helping me out, we got the dash in, and it wouldn't fit. I didn't get a picture, but the dash looked as if it was about 1 inch too far out, especially around the area of the hood latch below the steering wheel. Me and a few other people tried working the dash in but we just could not get it to fit perfectly. So then we started questioning whether it was something that has to do with the 2012 dash that isn't working. Their are very slight difference both visual and measurement wise that I have noticed about the 2 dashes but nothing that I think would cause that much of an issue. Does anyone have any ideas what could be wrong? I am stopping for the night and I'll finish it up tomorrow. The guy I was working with said that my only option may be to use my 2010 dash, which i REALLY do not want to do as I spent the money on a 2012 one. I'll post some pictures of the 2 dashes to see if anyone can notice any problems. If anyone can help me out I would very much appreciate it as i HAVE to have my car drivable by tomorrow.
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 09:03 PM   #7
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Here is the inside of the 2012 Dash
Attached Images
 
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 09:03 PM   #8
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
the 2010 Dash that came out of my car
Attached Images
 
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 09:04 PM   #9
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
here is a side by side, the 2012 is the one with the airbag in it.
Attached Images
 
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 09:21 PM   #10
01pewterz28
Camaro Junkie
 
01pewterz28's Avatar
 
Drives: 2010 2LT/RS,Born 9/14/09 @ 11:50:57
Join Date: Aug 2008
Location: Ocoee, FL
Posts: 7,392
Quote:
Originally Posted by Aubrey64 View Post
here is a side by side, the 2012 is the one with the airbag in it.
If I recall we had the same issue with mine it was the plastic vent getting caught we think we pulled it back out made sure all was level and put the drivers side in 1st then the passenger side and all was good.

The 2010 and 2012/13 dash are designed the same so no issues with installing the 12 into your 10. Since you have called it a night you will be more relaxed tomorrow she will fit in like a glove.
__________________
2010 2LT/RS, 2001 Z/28, 2014 Impala 2LT
01pewterz28 is offline   Reply With Quote
Old 01-26-2013, 09:26 PM   #11
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Quote:
Originally Posted by 01pewterz28 View Post
If I recall we had the same issue with mine it was the plastic vent getting caught we think we pulled it back out made sure all was level and put the drivers side in 1st then the passenger side and all was good.

The 2010 and 2012/13 dash are designed the same so no issues with installing the 12 into your 10. Since you have called it a night you will be more relaxed tomorrow she will fit in like a glove.

Thanks for the input, I really hope so. I sure would hate the have to go back to the 2010.
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 09:33 PM   #12
dkp2LT


 
dkp2LT's Avatar
 
Drives: '10 2LT/RS, '13 GT/CS, '10 Flex
Join Date: Feb 2012
Location: Kansas City, MO & Del Mar, CA
Posts: 2,502
I wish I could help but I'm interested in how this ends. I kept the 2010 dash but I am thinking about replacing with a '12 or newer dash in a year or so when there are more available.
dkp2LT is offline   Reply With Quote
Old 01-26-2013, 09:41 PM   #13
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Quote:
Originally Posted by dkp2LT View Post
I wish I could help but I'm interested in how this ends. I kept the 2010 dash but I am thinking about replacing with a '12 or newer dash in a year or so when there are more available.
yeah, I am interested in how it ends too! but I'll post the end result tomorrow. I am really hoping that it was just me putting it in wrong and me already being pretty tired. I did the entire disassembly on my own, and only got help with moving the dash, so by the time i ran into some problems, I was already tired and irritated. So hopefully all goes well tomorrow. But if anyone else has input, I would love to hear it.
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 09:52 PM   #14
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Also the guys who where helping me put in the dash, they said that it was possible the dash got distorted during shipment, while it being taken off of the original car, or by the company I got it from. But I just can't see why that would cause the issue. The dash fits, but the alignment, and fitment is slightly off, like something is blocking it from going all the way in. Don't know if this makes a difference, but I wanted to include it in case it gave anyone some ideas.
__________________
Aubrey64 is offline   Reply With Quote
Old 01-26-2013, 09:54 PM   #15
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,625
You have my # call in the AM i will try to help, i am done for the day was plying cop in the rain at the meet, so cant think right now.
__________________
2SSRS@Gen5diy is offline   Reply With Quote
Old 01-26-2013, 09:58 PM   #16
2SSRS@Gen5diy
Salt & Pepper 2014 Z/28

 
2SSRS@Gen5diy's Avatar
 
Drives: 2010 2SS IOM ,2014 Z/28, 66 Nova
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 11,625
And take a pic of this spot for me and closer.
Attached Images
 
__________________
2SSRS@Gen5diy is offline   Reply With Quote
Old 01-26-2013, 10:25 PM   #17
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
here is a closer view, I can take a clearer one tomorrow
Attached Images
 
__________________
Aubrey64 is offline   Reply With Quote
Old 01-27-2013, 12:26 PM   #18
Cal's bee
 
Cal's bee's Avatar
 
Drives: 2010 Camaro 2LT
Join Date: Mar 2011
Location: Chandler, Texas
Posts: 298
I had the same problem putting my dash in. The top lines up perfect and the bottom was about an inch off. I also stopped for the night, called and told me just make sure it was straight going in. I spent probably 45 minutes the next morning. Just pay attention to the mounts on the left and right side of the dash. They will show if the alignment is right. PM me if you have any question.
Cal's bee is offline   Reply With Quote
Old 01-27-2013, 05:55 PM   #19
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
The dash and HUD is installed!! It took a very long time to get the job done and everything is working great! My phone won't let me post pictures but i will post some pictures as soon as I get home. Thanks to everyone who helped me out with this, if it wasn't for y'all I couldn't have finished the install, just one of the many reasons why I love this site!
__________________
Aubrey64 is offline   Reply With Quote
Old 01-27-2013, 07:06 PM   #20
camaro2lt
 
camaro2lt's Avatar
 
Drives: 2010 Camaro 2lt VR/RS CGM Rally's
Join Date: May 2009
Location: palmyra pa
Posts: 5,255
congrats post up some pics when you get a chance
__________________
camaro2lt is online now   Reply With Quote
Old 01-27-2013, 07:21 PM   #21
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Here are some pictures of the install, man it was scary seeing my car look like this, but it was well worth it.
Attached Images
  
__________________
Aubrey64 is offline   Reply With Quote
Old 01-27-2013, 07:23 PM   #22
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
The new dash, the lighting isn't great so I'm gonna take some better ones when it is lighter tomorrow, but this give you a good idea what it looks like!
Attached Images
  
__________________
Aubrey64 is offline   Reply With Quote
Old 01-27-2013, 07:27 PM   #23
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Lastly the HUD, and when people tell you picutres don't do this justice, they are not lying! The HUD looks WAY better in person, there is no comparison.

All in all the install was very long and very tedious but it wasn't too hard. A lot of patience, and a lot of time but that is really it. The job can be done by one person as I did 90 percent of it by myself, but it would be a lot easier with a partner, just because it makes things go by faster and whenever you get frustrated you can have someone there to take over.
Attached Images
  
__________________
Aubrey64 is offline   Reply With Quote
Old 01-27-2013, 07:35 PM   #24
dkp2LT


 
dkp2LT's Avatar
 
Drives: '10 2LT/RS, '13 GT/CS, '10 Flex
Join Date: Feb 2012
Location: Kansas City, MO & Del Mar, CA
Posts: 2,502
Really like the new dash. Wish I could have scored one when I did my install. Was your new one a HUD dash? Cutting was the worst/scariest part IMO.
dkp2LT is offline   Reply With Quote
Old 01-27-2013, 07:52 PM   #25
Aubrey64


 
Aubrey64's Avatar
 
Drives: 2010 Camaro LLT/RS
Join Date: Apr 2012
Location: Plano, TX
Posts: 2,694
Quote:
Originally Posted by dkp2LT View Post
Really like the new dash. Wish I could have scored one when I did my install. Was your new one a HUD dash? Cutting was the worst/scariest part IMO.

No mine wasn't an HUD dash, the salvage yard I got mine from didn't have a HUD one, and so I just cut it myself. But yeah, the cutting for sure was nerve-racking, but it is one of those things that as long as you don't rush, you're good
__________________
Aubrey64 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.