Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Nickey Chicago
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls

Camaro Issues / Problems | Warranty Discussions | TSB and Recalls Report, discuss and diagnose any issues and problems with your Camaro, including warranty discussions.

Reply
 
Thread Tools
Old 07-01-2013, 05:56 PM   #126
Secret Squirrel
 
Secret Squirrel's Avatar
 
Drives: 2010 Black 2SS/RS SOLD
Join Date: Jan 2012
Location: Temecula, Ca
Posts: 465
Thieves at the dealership want to charge me $1700 to replace an oil pump that they know was already faulty. Unbelievable. I just made an appointment at the best performance shop in town here to have it replaced with a ported pump for $600 out the door.
__________________
Secret Squirrel is offline   Reply With Quote
Old 07-04-2013, 05:24 PM   #127
Secret Squirrel
 
Secret Squirrel's Avatar
 
Drives: 2010 Black 2SS/RS SOLD
Join Date: Jan 2012
Location: Temecula, Ca
Posts: 465
So here's a question...What if it isn't the sensor, and it isn't the pump? What other possibilities?
__________________
Secret Squirrel is offline   Reply With Quote
Old 07-14-2013, 02:48 AM   #128
Gen5SS
 
Drives: 2010 SS/RS 6 Spd Manual IOM
Join Date: Aug 2009
Location: North Las Vegas
Posts: 145
Add me to the list, happened on startup in the garage thankfully.
__________________
2010 2SS/RS, 417 stroker, 4.0 Callies crank and rods, JRE pistons w/hellfire nitrous top rings, Kooks 1 7/8 LT, Kooks 3" Exhaust, CAI Intake and Scoop, Cam SullivanGM W/ Hardened PR, Stock Heads. Dual Springs, Mcleod RXT Clutch, Hurst LL W/ Cruise Momentary, GM 3.91 gears, Nitrous Outlet direct port 200 shot, Dedicated Fuel Cell(C16), LNC2000 and NOS Mini controller, BMR suspension w/Bushings, Pfadt Drop, Pfadt Diff Bushings, 1400hp DSS Axles, DSS driveshaft, Solid Engine Mounts, Razzi Body Kit, Speedhut Gauges,T-REX Phantom Grills (Black) 533RWHP/500RWTQ N/A, 724RWHP/816RWTQ 200 Shot
Gen5SS is offline   Reply With Quote
Old 07-16-2013, 09:54 PM   #129
Gen5SS
 
Drives: 2010 SS/RS 6 Spd Manual IOM
Join Date: Aug 2009
Location: North Las Vegas
Posts: 145
I installed the melling 10296 and I now have better oil pressure than I did before, they really should fix the sticking pressure relief valve issue on these pumps.
__________________
2010 2SS/RS, 417 stroker, 4.0 Callies crank and rods, JRE pistons w/hellfire nitrous top rings, Kooks 1 7/8 LT, Kooks 3" Exhaust, CAI Intake and Scoop, Cam SullivanGM W/ Hardened PR, Stock Heads. Dual Springs, Mcleod RXT Clutch, Hurst LL W/ Cruise Momentary, GM 3.91 gears, Nitrous Outlet direct port 200 shot, Dedicated Fuel Cell(C16), LNC2000 and NOS Mini controller, BMR suspension w/Bushings, Pfadt Drop, Pfadt Diff Bushings, 1400hp DSS Axles, DSS driveshaft, Solid Engine Mounts, Razzi Body Kit, Speedhut Gauges,T-REX Phantom Grills (Black) 533RWHP/500RWTQ N/A, 724RWHP/816RWTQ 200 Shot
Gen5SS is offline   Reply With Quote
Old 11-03-2013, 12:22 PM   #130
Chupacabra
 
Drives: 2010 Camaro SS
Join Date: Nov 2013
Location: Baton Rouge
Posts: 1
Just happened to my 2010 Camaro SS for the third time friday. First two times it said no oil pressure it was under warranty, now this third time it is doing the exact same thing, but I'm past the bumper to bumper warranty. I hope they do the right thing and repair it free of charge as this is a known issue. Fingers crossed, I'll find out Monday morning.
Chupacabra is offline   Reply With Quote
Old 11-03-2013, 01:53 PM   #131
POWERFREAK
I.AM.
 
POWERFREAK's Avatar
 
Drives: 2010 2SS/RS/M6
Join Date: Oct 2008
Location: NY
Posts: 2,360
Quote:
Originally Posted by Chupacabra View Post
Just happened to my 2010 Camaro SS for the third time friday. First two times it said no oil pressure it was under warranty, now this third time it is doing the exact same thing, but I'm past the bumper to bumper warranty. I hope they do the right thing and repair it free of charge as this is a known issue. Fingers crossed, I'll find out Monday morning.
It should be covered under your drivetrain warranty.
__________________
2010 R6P-2SS/RS/LS3 - IBM w/ silver rally stripes / UNDER CONSTRUCTION.

NY5thgen.com
POWERFREAK is offline   Reply With Quote
Old 11-03-2013, 06:12 PM   #132
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,659
Quote:
Originally Posted by Chupacabra View Post
Just happened to my 2010 Camaro SS for the third time friday. First two times it said no oil pressure it was under warranty, now this third time it is doing the exact same thing, but I'm past the bumper to bumper warranty. I hope they do the right thing and repair it free of charge as this is a known issue. Fingers crossed, I'll find out Monday morning.
Chupacabra,

Apologies to hear of the oil pressure concerns with your Camaro. I'd appreciate any updates you can provide regarding your service visit. If additional assistance is needed, feel free to let me know.

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
Old 04-19-2014, 10:44 PM   #133
tonyG
 
Drives: 2011 2SS/RS
Join Date: Sep 2013
Location: Kentucky
Posts: 24
I'm here to join the failed oil pump club! Really can't believe that at 12,500mi I'm already having problems. First the steering pump at 10k miles, now the oil pump issue. My car is stuck at a friends house and I won't be able to do anything until Monday morning. Drove it all day and seemed fine (although I wasn't laying attention to the oil psi) came home for about an hr started it up and I get the message "low oil pressure shut off engine" turned it off checked the oil and it was fine so I started it again and it ran fine but it seemed like the oil psi was slighter lower than normal. Got to my friends house, hung out for a few hrs and when I started it it gave me the message to shut down again. Left it alone and got a ride home...
tonyG is offline   Reply With Quote
Old 04-20-2014, 09:13 AM   #134
Genersis 1000
 
Drives: 2010 LS black
Join Date: Apr 2014
Location: winslow maine
Posts: 1
what engines are having oil pump problem. Is it the V6
Genersis 1000 is offline   Reply With Quote
Old 04-20-2014, 12:35 PM   #135
tonyG
 
Drives: 2011 2SS/RS
Join Date: Sep 2013
Location: Kentucky
Posts: 24
Quote:
Originally Posted by Genersis 1000 View Post
what engines are having oil pump problem. Is it the V6
I believe mainly the v8s. Based on a majority of post 10-11' models seem to be the issue I believe
tonyG is offline   Reply With Quote
Old 04-22-2014, 01:10 AM   #136
WHAMMO

 
WHAMMO's Avatar
 
Drives: LS2 Fbody
Join Date: Apr 2012
Location: Canada
Posts: 945
They all have this problem; 2010-2013!! Corvette and Camaro. I read on a couple of forums ans bunch of 2013' had the no oil pressure issue. Its a serious problem. Melling oil pump FTW!!!
__________________
4th Gen SS/LS2 SB/LS3 heads/N20
WHAMMO is offline   Reply With Quote
Old 08-20-2014, 12:50 AM   #137
Teamradrz1
 
Teamradrz1's Avatar
 
Drives: 2012 2SS/RS
Join Date: Jan 2012
Location: Gresham, OR
Posts: 414
So my car has the same issue, (2012 LS3 46K miles) was at the coast on a Camaro get together and went over to a friends that morning for BF before heading back home was there for about an hour came out started the car and before getting out of the driveway "DING DING DING" Low oil pressure shut engine off. Shut it down checked the oil it was fine checked for leaks didn't see any. Started it back up maybe a gauge misread, the gauge pack said 0 OP. Shut it back off got a flash light to see if I could see oil pumping to the top end started it up and started "ticking" quickly shut it back off and called the tow truck. So I call the local dealer as I'm back home over 3.5 hours from my car and he says I was 2 quarts low and after he topped it off my oil pressure came back up. I told him I checked the oil when the alarm went off he said looks like an oil consumption problem. I said ok for arguments sake let's say I read the dipstick wrong even 2 quarts low there is enough oil in the pan to have oil pressure, he agreed but said seems fine now and for me to come get my car and should follow up with my local dealer for further inspection. I agree would be nice to have my car closer to home, I asked well what if it drops to zero again on the way home and it damages the engine? Well it would be covered under the powertrain warranty he said.
__________________
Mods: Synergy series edition added by dealer(GFX, striping, hertiage grill, dove tail spoiler, ambient light kit, Hurst short throw shifter)
Showstopper side markers, Phoenix Gold system, MBRP Catback exhaust, Factory Strut tower brace, CAI intake, Hydro graphics, carbon fiber door panel inserts, 20% tint, clear bra, Plasma DRL, AAC scanner bar & Grill LEDs, int-trunk-license plate swapped for LEDs.
Teamradrz1 is offline   Reply With Quote
Old 08-23-2014, 02:12 AM   #138
Pink Lady
 
Pink Lady's Avatar
 
Drives: 2010 pink and black 2lt
Join Date: Aug 2014
Location: Dickson, Tennessee
Posts: 12
I have a video of my 07 cobalt doing this exact problem. It does it all the time and impalas are doing it too from what ive read. its not the sensor nor is it throwing a code and its mainly when you let off the gas n rpms are btw 1500 and 2000 for me. But yet the dealership said I can not replicate the problem... which im not surprised because it is so sporadic.
This problem is the reason i bought my camaro. I would love to know the fix for this because its alarming to see the low oil pressure light flash at you and this car is my dd.
Pink Lady is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GM's OLM & synthetic oils. duder4thgen Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 1 03-24-2010 11:37 AM
The BEST Break for a new car. "very long" Darin Morgan General Automotive + Other Cars Discussion 346 02-04-2010 06:49 PM
Stock Injectors vs Magnuson Kit Injectors Mark-HD Forced Induction - V8 24 01-27-2010 08:04 PM
Camaro ls3 news...true or false? Dark Knight Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 74 06-05-2008 05:29 PM


All times are GMT -5. The time now is 11:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.