Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Nightowl LED
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V6

Forced Induction - V6 V6 Supercharger, turbo, nitrous discussions

Reply
 
Thread Tools
Old 04-16-2011, 02:14 PM   #1
Pt_killa
 
Pt_killa's Avatar
 
Drives: Black 2010 Camaro V6
Join Date: Apr 2010
Location: VA
Posts: 417
Remote Turbo Sizing?

I finished a remote turbo setup for my car using a master power T60 otrim turbine .68ar. The T60 uses a 60-1 compressor in a large t04s housing. It still needs to be fine tuned but it runs. Does anyone know the size of the turbo and specs of the turbo used on the STS kit?

The reason I'm asking is because even though my car runs, its much slower then stock unless I'm at full boost. I went to the track yesterday and I ran a 16.2 when I usually run high 13's stock. The car bogs at low rpm and when I throttle too much. I think my turbo may be too small but it could also be the tune running too rich(gets to 10:1 afr at part throttle).
Pt_killa is offline   Reply With Quote
Old 04-16-2011, 08:43 PM   #2
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: `12 LFX/`11 EB F-150/`13 Sonic RS
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 5,766
Sounds like you are too rich. I believe that is a bigger turbo than the STS. I would think you shouldn't have trouble spooling it up, though, so start with the tune.

Glad to see you are back on the horse!
__________________
EFR Twin Turbo LFX-GPI Tune-ZL1 fuel pump-10:1 CR forged pistons-3.45 gear-Meth Injection-BMR Trailing Arms, Bushings & Sway Bars-CircleD 4000 Stall-GPI Fuel Enrichment System
647 RWHP & 726 RWTQ @18.5 psi on 93 Octane (locked converter)
1/8 mile -- 7.158 @ 102.10 (20psi); old build
Build Thread
GretchenGotGrowl is online now   Reply With Quote
Old 04-16-2011, 09:33 PM   #3
Pt_killa
 
Pt_killa's Avatar
 
Drives: Black 2010 Camaro V6
Join Date: Apr 2010
Location: VA
Posts: 417
Quote:
Originally Posted by GretchenGotGrowl View Post
Sounds like you are too rich. I believe that is a bigger turbo than the STS. I would think you shouldn't have trouble spooling it up, though, so start with the tune.

Glad to see you are back on the horse!
hahaha nowhere near rich, ebay and craigslist are my friends. I've been reusing parts from my first supercharger build and twin turbo build and selling off the residuals to buy new parts. I'm probably down net 1k from changing my setups in the past 7-8 months. Also, the remote mount build only took a day after using all of the knowledge I gather during the previous builds! Hows your car holding up? How do your afr's look at idle and under throttle? When Vince gets back from his vacation I'l get him to check out my datalogs.
Pt_killa is offline   Reply With Quote
Old 04-16-2011, 10:19 PM   #4
Pt_killa
 
Pt_killa's Avatar
 
Drives: Black 2010 Camaro V6
Join Date: Apr 2010
Location: VA
Posts: 417
Also, do any of you turbo guys get compressor surge when you let off the throttle at low boost? I hear that turkey gobble sound everytime im in boost an let off the throttle.
Pt_killa is offline   Reply With Quote
Old 04-17-2011, 02:25 PM   #5
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: `12 LFX/`11 EB F-150/`13 Sonic RS
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 5,766
Quote:
Originally Posted by Pt_killa View Post
hahaha nowhere near rich, ebay and craigslist are my friends. I've been reusing parts from my first supercharger build and twin turbo build and selling off the residuals to buy new parts. I'm probably down net 1k from changing my setups in the past 7-8 months. Also, the remote mount build only took a day after using all of the knowledge I gather during the previous builds! Hows your car holding up? How do your afr's look at idle and under throttle? When Vince gets back from his vacation I'l get him to check out my datalogs.
Sorry, misunderstanding there. I mean you are running rich at 10.1. Mine was 10.0 the run after putting the boost controller on and trying 4.5 psi. A quick fix from Vince and I was back at 11.4 and hit 345 hp.

The skid plate is done but I haven't had a chance to clean all the oil out of the pipes. Hopefully I can do that next weekend. Then I'll give her a nice long drive and make sure we have the oiling issue fixed. I'm debating sending them back to Percision and have the seals replaced just in case all that high pressure damaged them. Just waiting for them to get back with me.

Edit: Missed the AFR. At idle it and decel it is about 15.6-16.3. While cruising it fluctuates between 14.3-14.4 (too rich and probably why my MPG went down). At full boost It's at 11.4.
__________________
EFR Twin Turbo LFX-GPI Tune-ZL1 fuel pump-10:1 CR forged pistons-3.45 gear-Meth Injection-BMR Trailing Arms, Bushings & Sway Bars-CircleD 4000 Stall-GPI Fuel Enrichment System
647 RWHP & 726 RWTQ @18.5 psi on 93 Octane (locked converter)
1/8 mile -- 7.158 @ 102.10 (20psi); old build
Build Thread
GretchenGotGrowl is online now   Reply With Quote
Old 04-17-2011, 02:26 PM   #6
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: `12 LFX/`11 EB F-150/`13 Sonic RS
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 5,766
Quote:
Originally Posted by Pt_killa View Post
Also, do any of you turbo guys get compressor surge when you let off the throttle at low boost? I hear that turkey gobble sound everytime im in boost an let off the throttle.
My turkeys may be oiled and smoked, but no gobble so far. Could your BOV be stuck closed?
__________________
EFR Twin Turbo LFX-GPI Tune-ZL1 fuel pump-10:1 CR forged pistons-3.45 gear-Meth Injection-BMR Trailing Arms, Bushings & Sway Bars-CircleD 4000 Stall-GPI Fuel Enrichment System
647 RWHP & 726 RWTQ @18.5 psi on 93 Octane (locked converter)
1/8 mile -- 7.158 @ 102.10 (20psi); old build
Build Thread
GretchenGotGrowl is online now   Reply With Quote
Old 04-17-2011, 08:51 PM   #7
Z Madness
 
Z Madness's Avatar
 
Drives: 2010, 2000, 1971 Camaros
Join Date: May 2010
Location: Hawaii
Posts: 532
The surge is common for the remote mounts, another thing I don't care for on the design. STS says it should be an issue but we will see if anything develops over time. And STS uses 60-1.
Z Madness is offline   Reply With Quote
Old 04-17-2011, 09:52 PM   #8
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: `12 LFX/`11 EB F-150/`13 Sonic RS
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 5,766
Quote:
Originally Posted by Z Madness View Post
The surge is common for the remote mounts, another thing I don't care for on the design. STS says it should be an issue but we will see if anything develops over time. And STS uses 60-1.
Didn't know about the surge or the 60-1. Did they say what called the surge?
__________________
EFR Twin Turbo LFX-GPI Tune-ZL1 fuel pump-10:1 CR forged pistons-3.45 gear-Meth Injection-BMR Trailing Arms, Bushings & Sway Bars-CircleD 4000 Stall-GPI Fuel Enrichment System
647 RWHP & 726 RWTQ @18.5 psi on 93 Octane (locked converter)
1/8 mile -- 7.158 @ 102.10 (20psi); old build
Build Thread
GretchenGotGrowl is online now   Reply With Quote
Old 04-18-2011, 10:01 AM   #9
Pt_killa
 
Pt_killa's Avatar
 
Drives: Black 2010 Camaro V6
Join Date: Apr 2010
Location: VA
Posts: 417
I'm guessing that since the intercooler piping is so long it could be a factor in surge. When I ran the twins I did not get any compressor surge using the same bov but I did run 8-10psi. Maybe the spring is too stiff in the BOV. Gretch and Z, do you have any compressor surge from releasing the throttle?

Its funny that i managed to use the same turbo that sts uses. I just check your thread Z and it seems you have the larger 64mm P-trim turbine but the smaller t04e housing while I have the smaller 58mm O-trim turbine with the larger t04s housing. Should be interesting to see the differences.
Pt_killa is offline   Reply With Quote
Old 04-18-2011, 10:10 AM   #10
GretchenGotGrowl


 
GretchenGotGrowl's Avatar
 
Drives: `12 LFX/`11 EB F-150/`13 Sonic RS
Join Date: Sep 2010
Location: Little Rock, AR
Posts: 5,766
I get no compressor surge. My BOV has an 11 lb spring. It seems to open the second I get off the throttle.
__________________
EFR Twin Turbo LFX-GPI Tune-ZL1 fuel pump-10:1 CR forged pistons-3.45 gear-Meth Injection-BMR Trailing Arms, Bushings & Sway Bars-CircleD 4000 Stall-GPI Fuel Enrichment System
647 RWHP & 726 RWTQ @18.5 psi on 93 Octane (locked converter)
1/8 mile -- 7.158 @ 102.10 (20psi); old build
Build Thread
GretchenGotGrowl is online now   Reply With Quote
Old 04-18-2011, 01:21 PM   #11
Pt_killa
 
Pt_killa's Avatar
 
Drives: Black 2010 Camaro V6
Join Date: Apr 2010
Location: VA
Posts: 417
Quote:
Edit: Missed the AFR. At idle it and decel it is about 15.6-16.3. While cruising it fluctuates between 14.3-14.4 (too rich and probably why my MPG went down). At full boost It's at 11.4.
Thanks for the info gretchen, It seems like I am running rich then, but I wish I was the other type of rich though lol! My idle flucates between 13-15 and cruise with any bit of gas is from 10-14. Off throttle decel is from 15-17. Full throttle buries the wideband on the rich side and just shows 10.0.

Quote:
I get no compressor surge. My BOV has an 11 lb spring. It seems to open the second I get off the throttle.
I have an 11lb spring also, I guess I need to check out the bov internals unless your pulling a different vac then mine. I get between -15 and -18hg at most.
Pt_killa is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Modifying for " Dummies" Dr Jkel Tuning / Diagnostics -- engine and transmission 209 06-18-2012 12:24 AM
Gran Turismo 5 November 24th, 2010 Nezacant Gaming Lounge 562 04-21-2011 10:23 PM
STS Remote Mount Turbo Kit for V6 ZNOLMT Forced Induction - V6 102 06-09-2010 01:18 PM
STS Twin Turbo Kits On Sale! tbyrne Forced Induction 26 02-08-2010 08:31 AM


All times are GMT -5. The time now is 06:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.