Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Fabberge
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions

5th Gen Camaro SS LS LT General Discussions General 5th generation Camaro topics not covered by other subforums.

Reply
 
Thread Tools
Old 05-20-2011, 06:33 PM   #1
CraziGuy
CallMeCrzyButILuvV6s312HP
 
CraziGuy's Avatar
 
Drives: 2011 Camaro 2LS 2005 Cobalt SS
Join Date: Mar 2011
Location: Austin, TX
Posts: 186
Malfunction indicator lamp came on

As my title says the malfunction indicator lamp just came on all of the sudden today. I have done no mods to my car so far. The only thing done to the car was its first oil change about 50 miles ago. Anybody have any idea why this would happen? And yes I know what the light means. The car only has 3500 miles on her. Im gonna take it to the dealership tomorrow.
__________________
CraziGuy is offline   Reply With Quote
Old 05-20-2011, 06:49 PM   #2
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,101
You said you know what the light means, what does the light mean? Hard to almost impossible to answer your question on the internet........ when your car is all stock, we haven't nothing to base anything on. Dealer will know, hopefully.
ffrcobra_65 is offline   Reply With Quote
Old 05-20-2011, 06:53 PM   #3
upflying


 
upflying's Avatar
 
Drives: '86 Monte Carlo SS
Join Date: Nov 2010
Location: Antioch, Ca
Posts: 3,125
Plug in a scan tool and you will know what it means. Port is under the dash.
upflying is offline   Reply With Quote
Old 05-20-2011, 07:02 PM   #4
CraziGuy
CallMeCrzyButILuvV6s312HP
 
CraziGuy's Avatar
 
Drives: 2011 Camaro 2LS 2005 Cobalt SS
Join Date: Mar 2011
Location: Austin, TX
Posts: 186
On my way to autozone as I type this.
__________________
CraziGuy is offline   Reply With Quote
Old 05-20-2011, 07:46 PM   #5
dmginc


 
dmginc's Avatar
 
Drives: 01 Jeep/11 HHR/14 Camaro 1LS
Join Date: Mar 2011
Location: Freeville, NY
Posts: 2,895
Quote:
Originally Posted by CraziGuy View Post
On my way to autozone as I type this.
texting and driving is bad mmmmk?
dmginc is offline   Reply With Quote
Old 05-20-2011, 07:52 PM   #6
CraziGuy
CallMeCrzyButILuvV6s312HP
 
CraziGuy's Avatar
 
Drives: 2011 Camaro 2LS 2005 Cobalt SS
Join Date: Mar 2011
Location: Austin, TX
Posts: 186
Troubleshooting number P0627

Definition- Fuel pump relay control circuit
Probable cause- 1. Open or short circuit condition
2. Failed fuel pump relay

This really sux. Not only did I have surgery this week but now my car has to be fixed up too. Going to the dealership first thing in the morning.
__________________
CraziGuy is offline   Reply With Quote
Old 05-20-2011, 07:53 PM   #7
CraziGuy
CallMeCrzyButILuvV6s312HP
 
CraziGuy's Avatar
 
Drives: 2011 Camaro 2LS 2005 Cobalt SS
Join Date: Mar 2011
Location: Austin, TX
Posts: 186
I was at a long red light.
__________________
CraziGuy is offline   Reply With Quote
Old 05-20-2011, 09:22 PM   #8
Zach
66ford pickup
 
Zach's Avatar
 
Drives: Still lookin for a camaro
Join Date: Apr 2011
Location: Tempe
Posts: 97
u check ur fuses? or any electronic readers around were it is telling you to look at?
__________________


1966 F100
352 V8
white/blue
Zach is offline   Reply With Quote
Old 05-20-2011, 11:27 PM   #9
fbodfather


 
fbodfather's Avatar
 
Drives: Camaros................
Join Date: Oct 2006
Location: Grosse Pointe Farms, MI (suburban Detroit)
Posts: 4,350
Open the fuel fill door - and turn the fuel cap clockwise until it clicks......if you don't do this - it will throw a code........
__________________
fbodfather is offline   Reply With Quote
Old 05-21-2011, 12:21 AM   #10
ffrcobra_65
Account Suspended
 
Drives: SuperCharged 2SS/RS IOM MN6
Join Date: May 2009
Location: CA
Posts: 5,101
i recommend u stop troubleshooting and trying to fix it yourself and leave it to get fixed under warranty. Don't take a chance u make things worse. You said yourself, ur car is all stock.............
ffrcobra_65 is offline   Reply With Quote
Old 05-21-2011, 12:24 AM   #11
Alfieboy
Madman
 
Alfieboy's Avatar
 
Drives: White 2014 ZL1
Join Date: Jun 2009
Location: RICHMOND VA
Posts: 1,280
true, but it could be as simple as the gas cap...

as mentioned above....try removing cap,reinstalling to 1 click..
Alfieboy is offline   Reply With Quote
Old 05-21-2011, 06:54 AM   #12
CraziGuy
CallMeCrzyButILuvV6s312HP
 
CraziGuy's Avatar
 
Drives: 2011 Camaro 2LS 2005 Cobalt SS
Join Date: Mar 2011
Location: Austin, TX
Posts: 186
I tried the gas cap and it didn't help. I agree I don't want to hurt my car anymore so to the dealership I go...
__________________
CraziGuy is offline   Reply With Quote
Old 05-21-2011, 08:52 AM   #13
CraziGuy
CallMeCrzyButILuvV6s312HP
 
CraziGuy's Avatar
 
Drives: 2011 Camaro 2LS 2005 Cobalt SS
Join Date: Mar 2011
Location: Austin, TX
Posts: 186
Dealership told me there was a recall for a failure in the electrical system. Will take a complete day to fix. Should be getting my car back Monday around 4pm.
__________________
CraziGuy is offline   Reply With Quote
Old 05-21-2011, 09:15 AM   #14
clg_98ta


 
clg_98ta's Avatar
 
Drives: 2010 Camaro 2SS
Join Date: Jan 2010
Location: Austin, TX
Posts: 2,701
Quote:
Originally Posted by CraziGuy View Post
Troubleshooting number P0627

Definition- Fuel pump relay control circuit
Probable cause- 1. Open or short circuit condition
2. Failed fuel pump relay

This really sux. Not only did I have surgery this week but now my car has to be fixed up too. Going to the dealership first thing in the morning.

This is not related to the evap system, so tightening the gas cap won't help. You may just have a bad sensor, but if the control circuit is malfunctioning your fuel pump could shut off (stranding you) or burn up (stranding you)... so you want to get it checked before driving it very far.
__________________
Black 2SS ordered 1/4/2010, received 2/19/2010



clg_98ta is offline   Reply With Quote
Old 03-28-2013, 11:23 PM   #15
Chevy girl 13
 
Chevy girl 13's Avatar
 
Drives: 2013 Camaro
Join Date: Jan 2013
Location: CA
Posts: 10
Malfunction indicator lamp

Quote:
Originally Posted by CraziGuy View Post
As my title says the malfunction indicator lamp just came on all of the sudden today. I have done no mods to my car so far. The only thing done to the car was its first oil change about 50 miles ago. Anybody have any idea why this would happen? And yes I know what the light means. The car only has 3500 miles on her. Im gonna take it to the dealership tomorrow.
Can you keep me posted what happens. The same thing happened to me and I just had it at the dealers last week and oil changed. Everything tested fine.

I have never posted before so sorry if I did it wrong. Wow you have low miles on your car.
Chevy girl 13 is offline   Reply With Quote
Old 03-29-2013, 08:20 AM   #16
hrpiii
AKA "Beefcake"
 
hrpiii's Avatar
 
Drives: CGM w/Black stripes
Join Date: Oct 2009
Location: Indy
Posts: 4,068
Quote:
Originally Posted by Chevy girl 13 View Post
Can you keep me posted what happens. The same thing happened to me and I just had it at the dealers last week and oil changed. Everything tested fine.

I have never posted before so sorry if I did it wrong. Wow you have low miles on your car.
did you check to make sure the gas cap was secure, clicks when tightened. If you have not made any changes to the car, return to the dealer and let them see what code the car is throwing. It's all under warranty, so you should be okay on whatever needs 'fixin'.
__________________
Pfadt Suspension, Supercharged, Showstopper 'bling', Pedderized by Bruce and Tuned by Mike Norris Motorsports
hrpiii is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater seater malfunction automatic shut off SoTHavok Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 1 03-13-2011 01:18 PM
malfunction indicator lamp EricVerdunII Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 35 12-05-2010 04:38 PM
HELP! Fuel malfunction code after CAI install scomaro22 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 35 01-17-2010 05:19 AM
Tire Monitoring System monevz28 Camaro Issues / Problems | Warranty Discussions | TSB and Recalls 7 11-22-2009 03:42 PM
Skip shift function, or malfunction? AMERICANMADE 5th Gen Camaro SS LS LT General Discussions 53 09-18-2009 08:38 PM


All times are GMT -5. The time now is 04:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.