Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
JUICEDMOTORSPORTS
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-27-2011, 06:20 PM   #1
spyrollinc
 
Drives: 2011 CGM SS/RS
Join Date: Aug 2010
Location: Keller / Southlake TX
Posts: 73
Blown engine

Well the oil pump on my 2011 SS decided to blow up. No warning or anything. Engine is gone. Everyone at Classic Chevy in Grapevine has been great. Unfortunately engine had a tune because of the long tubes. So I'm afraid repair won't be covered under warranty. Hoping I can work something out with Classic and GM. Great way to start my Memorial day weekend
spyrollinc is offline   Reply With Quote
Old 05-27-2011, 06:23 PM   #2
LittleMT
user bann'd
 
LittleMT's Avatar
 
Drives: Chevy SS
Join Date: May 2009
Location: Hepcat City
Posts: 1,463
oh crap...tough break.... I hope they work with you...if they don't, and if you have to foot the entire bill, I'd get a upgraded engine with forged internals....if you are going to have to spend the money, get some more power!
__________________

Chantilly Lace, the 2011 Rockabilly Jukebox..ADM built..617rwhp, geared A6.
LittleMT is offline   Reply With Quote
Old 05-27-2011, 06:28 PM   #3
mlee
Charter Circle Member
 
mlee's Avatar
 
Drives: Number Twenty-Three
Join Date: Oct 2008
Location: Conroe, TX
Posts: 27,699
Good luck... let us know how it turns out. Tune shouldn't have any affect on an oil pump, but it may take them a while to make sure nothing other than a tune and headers was done. Sucks this happened to you...
__________________
.
mlee is offline   Reply With Quote
Old 05-27-2011, 06:31 PM   #4
acowherd

 
acowherd's Avatar
 
Drives: 2010 2ss/RS 4l80. 2009 2500 HD
Join Date: Mar 2009
Location: Mid MO
Posts: 1,825
I hope everything works out for you!!
__________________
Follow along as we build and race this 2010 Camaro!

https://www.facebook.com/pages/FNSS-...75028626000379


FNSS Racing!
acowherd is offline   Reply With Quote
Old 05-27-2011, 06:33 PM   #5
ZenitramSS
 
ZenitramSS's Avatar
 
Drives: 2011 2SS
Join Date: Dec 2010
Location: Surprise AZ
Posts: 181
Don't worry, they have to prove that the tune and the headers caused the damage. You should be fine.
__________________
2011 2SS Imperial Blue - Volant CAI - SLP Ceramic Coated Long Tube Headers - SLP Hi Flow Cats - Flowmaster Cat Back - SLP Line Lock - Full Hotchkis Race Pack Suspension - LS3 Conversion - Wild Comp Cam - Circle D Converter - Edlebrock E Force Supercharger - Weld Racing Wheels - M&H Drag Radial Tires -
ZenitramSS is offline   Reply With Quote
Old 05-27-2011, 06:36 PM   #6
spyrollinc
 
Drives: 2011 CGM SS/RS
Join Date: Aug 2010
Location: Keller / Southlake TX
Posts: 73
Yeah it truly sucks. I spoke with someone from GM and she has contacted my service manager at Classic. Just waiting to hear back from her. Its going to be a long weekend. In the meanwhile I will be shopping for a new motor. Classic has an LS3 ready to go in, but if I have to foot the bill. Might as well go big. I will keep you guys updated on my progress. I miss Camaro.
spyrollinc is offline   Reply With Quote
Old 05-27-2011, 06:44 PM   #7
2010SLVRBULIT


 
2010SLVRBULIT's Avatar
 
Drives: G5(LLT) & C6(LS3)
Join Date: Apr 2009
Location: MARS
Posts: 7,414
think the oil pump has a faulty recall/TSB..sux that it happened after the AM stuff.
2010SLVRBULIT is offline   Reply With Quote
Old 05-27-2011, 06:49 PM   #8
spyrollinc
 
Drives: 2011 CGM SS/RS
Join Date: Aug 2010
Location: Keller / Southlake TX
Posts: 73
Yeah I've seen the TSB about the faulty pump. Hopefully they honor the warranty since it is a known issue. $7k is a lot of money.
spyrollinc is offline   Reply With Quote
Old 05-28-2011, 08:18 AM   #9
Eric Baker

 
Drives: Black/Black 2SS/RS 6M
Join Date: Mar 2010
Location: Boston MA
Posts: 971
Is your engine actually blown? How long was it run after you saw the message/had no oil pressure? If you caught it in time, you may just need to replace the pump. Sorry to hear either way.
Eric Baker is offline   Reply With Quote
Old 05-28-2011, 08:25 AM   #10
68/2010
Emerald Coast Camaros
 
68/2010's Avatar
 
Drives: 2010 2SS Rally Yellow
Join Date: Feb 2009
Location: TALLAHASSEE,FL
Posts: 4,099
Sorry to hear about your car. But, it will all work out for ya. I believe that
__________________
68/2010 is offline   Reply With Quote
Old 05-28-2011, 08:46 AM   #11
camaro1

 
camaro1's Avatar
 
Drives: 550+RWHP 2010 camaro
Join Date: Sep 2007
Location: wisconsin
Posts: 1,588
any engine or major drivetrain work requires the service manager to send in the calibration CVN #'s before gm will authorize a new engine replacement

doesnt even matter if there is a known issue with the oil pumps

also, we see many farm/work trucks with the same style Ls engines and the same oil pump issues and most of these are driven to the shop with the low oil pressure light on and every one has been fixed with a new pump,, its almost seems that when the pump pressure valve sticks the pump doesnt make any pressure but there must still be some flow because all these trucks engines have been fine,, even checked the bearings on some of the first ones to fail and they were still like new after being driven on a bad pump
__________________
415ci stroker, TVS 2300 Magnacharger, cnc heads, cam, yank ss3200 converter, Kooks long tubes, Bwoody true cold air kit, ZL1 Pump, magnaflow 3" cat-back, lowering springs,BMR control arms and tie rod bars, 3.73 gears, diff mounts, RX can, ADM fuel controller
camaro1 is offline   Reply With Quote
Old 05-28-2011, 11:37 AM   #12
ssummit camaro

 
ssummit camaro's Avatar
 
Drives: 2013 1LE on order TPW 12/31
Join Date: Jan 2010
Location: El Paso, Texas
Posts: 883
where do i fine the tsb for this
Quote:
Originally Posted by 2010SLVRBULIT View Post
think the oil pump has a faulty recall/TSB..sux that it happened after the AM stuff.
__________________
ssummit camaro is offline   Reply With Quote
Old 05-28-2011, 11:47 AM   #13
KnightRiderSS
Voodoo Medicine Man
 
KnightRiderSS's Avatar
 
Drives: Black 2SS with RS package
Join Date: Jul 2010
Location: IL
Posts: 917
How many miles did you have on her?
__________________
KnightRiderSS is offline   Reply With Quote
Old 05-28-2011, 03:54 PM   #14
SGOS252382


 
SGOS252382's Avatar
 
Drives: 2010 Camaro 2SS/RS
Join Date: Mar 2008
Location: S.W. Florida
Posts: 6,300
That sucks
Keep us posted.

If you have to get a new engine check with the classifieds. You might be able to put up a slightly used LS3 for pretty cheap. I've seen some for real good prices.
SGOS252382 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shno's House of Z Number 3 Camaro Z/28 Forum - Z/28 Specific Topics 16685 05-27-2016 02:56 PM
BREAKING: 2012 CAMARO ZL1 - 6.2L LSA Supercharged - 6MT Revealed! Tran Camaro ZL1 Forum - ZL1 Specific Topics 756 05-01-2013 06:22 AM
Acronyms? KEEP RT Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 20 03-11-2011 08:57 PM
LS3 engine specifications Tran Wiki 3 10-06-2010 10:56 PM
L99 engine specifications Tran Wiki 0 10-19-2008 11:40 AM


All times are GMT -5. The time now is 02:22 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.