Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 05-31-2012, 11:23 AM   #18
DeAdMiKe187
 
Drives: Black 2012 2LT
Join Date: Apr 2012
Location: Brooklyn, NY
Posts: 210
Wow, sorry to hear about all of these issues. I keep my AC fan speed on 1, and sometimes it feels too cold (and I like the cold), so I have to take the temperature off of Max. One thing that I have noticed, is that I occasionally start the car and the AC light is off, or the AC and Recirculation light is off. I can't recall if this is only when I turn the AC off (by turning the fan speed down all the way), or if it happens even without doing that. I'll try to pay attention to that next time.
DeAdMiKe187 is offline   Reply With Quote
Old 05-31-2012, 01:06 PM   #19
MustangKiller
 
MustangKiller's Avatar
 
Drives: 2013 2ss/rs A6 yellow !!!!!
Join Date: Nov 2011
Location: Woodbine Maryland
Posts: 498
My ac also sucks and too think i traded my 10 on this
MustangKiller is offline   Reply With Quote
Old 06-01-2012, 01:59 AM   #20
azrickster
 
azrickster's Avatar
 
Drives: 2010 Camaro 2SS/RS CGM 6M #38916
Join Date: Jul 2009
Location: Tualatin, Oregon
Posts: 90
I live in Phoenix, AZ. My AC blows cold and keeps up with the heat. But my AC blower motor seems to variations, especially noticable when I'm idling. I have Flowmasters, so hearing the blower variations is impossible. Could this be due to something simple like reprogramming? Perhaps a weak alternator or battery? I don't see anything online regarding this issue...
azrickster is offline   Reply With Quote
Old 06-06-2012, 04:18 PM   #21
bigbob11
 
bigbob11's Avatar
 
Drives: 2012 2SS
Join Date: May 2012
Location: NJ
Posts: 259
Is it normal for the recirculation light to stay on even if the AC is off
bigbob11 is offline   Reply With Quote
Old 06-06-2012, 04:24 PM   #22
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,971
Quote:
Originally Posted by bigbob11 View Post
Is it normal for the recirculation light to stay on even if the AC is off

On page 8-2 in the owner's manual it states:

(Recirculation): Press to turn on the recirculation. An indicator light comes on. Air is recirculated inside the vehicle. It helps to quickly cool the air inside the vehicle or prevent outside air and odors from entering. Operation in the recirculation mode while the air conditioner is off increases humidity and may cause the windows to fog. Recirculation is not available in the defrost or defog modes. To improve fuel efficiency and to cool the vehicle faster, recirculation may be automatically selected in warm weather. The recirculation light will not come on. Press the little recirculate button to select recirculation; press it again to select outside air.

I hope this information was helpful.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is online now   Reply With Quote
Old 06-09-2012, 12:58 PM   #23
azrickster
 
azrickster's Avatar
 
Drives: 2010 Camaro 2SS/RS CGM 6M #38916
Join Date: Jul 2009
Location: Tualatin, Oregon
Posts: 90
Quote:
Originally Posted by azrickster View Post
I live in Phoenix, AZ. My AC blows cold and keeps up with the heat. But my AC blower motor seems to variations, especially noticable when I'm idling. I have Flowmasters, so hearing the blower variations is impossible. Could this be due to something simple like reprogramming? Perhaps a weak alternator or battery? I don't see anything online regarding this issue...
UPDATE
Got the Camaro back from the Dealer. Turns out there was nothing wrong with any of the mechanical components. The issue was related to a simple reprogram of the AC system. We're back up and running like new.
azrickster is offline   Reply With Quote
Old 06-10-2012, 03:03 AM   #24
Nessal


 
Drives: Lotus Exige
Join Date: Jun 2011
Location: CA, Bay Area
Posts: 2,308
The AC SUCKS in these cars. I never had a car with such bad AC.

I brought my car in for the AC fix because I noticed that the AC would not shut off even when I turn it off. Ever since I brought it in, the AC would shut off when I turn it off but the air is never as cold as it should be. The air is cool, but not cold.
Nessal is offline   Reply With Quote
Old 06-10-2012, 05:57 AM   #25
craigd853
 
Drives: 199 SS Camaro
Join Date: Oct 2008
Location: MD
Posts: 125
Quote:
Originally Posted by edgehead2000 View Post
I just traded in my '11 and noticed that the AC does blow, literally. Took it to the dealer and he said to start using the recirculation button. After that, this OKC heat was tolerable.

The new '12 I traded for has the same issue. Use recirculation and it helps. The '11 Buick Lacrosse loaner that they gave me had an awesome AC, though so I'm wondering what Chevy forgot to do that has us griping about it.
You should always use the recirc whenever possible. The car gets better gas mileage and the air is much colder because it's not cooling air from the outside and brining it into the car. It recirculates the cooler air inside the vehicle making the A/C run less and improving mileage and cold air at the same time.
craigd853 is offline   Reply With Quote
Old 06-12-2012, 11:02 AM   #26
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,971
Quote:
Originally Posted by Nessal View Post
The AC SUCKS in these cars. I never had a car with such bad AC.

I brought my car in for the AC fix because I noticed that the AC would not shut off even when I turn it off. Ever since I brought it in, the AC would shut off when I turn it off but the air is never as cold as it should be. The air is cool, but not cold.
I can look into this further if you would like. I can certainly understand that you have a concern with it not as cold as you would like it to be. Please send me your first and last name, address, phone number, VIN, mileage, and involved dealership and I will be able to set up a case to contact your dealership. I look forward to your PM.

Brandon
Chevrolet Customer Service
Chevrolet Customer Svc is online now   Reply With Quote
Old 03-27-2013, 03:34 PM   #27
hzdj2c
 
Drives: 2010 Camaro 2SS
Join Date: Mar 2013
Location: Florida
Posts: 2
I own a 2010 2SS. In February while traveling the east to west coasts of Florida I noticed the temperature in the car increasing. Placing the AC at MAX cold and full fan did not change anything. I could feel cold air but very little air and a lot of vapors. In addition there was a whining sound. The 1st trip to the dealership resulted in "no trouble found". After having a dealer service rep ride with me on the FL Turnpike he agreed there was an issue. The 2nd stay at the dealership resulted in them replacing the air compressor which they stated had been over charged. Other than oil changes the dealership was the only hands that touched my Camaro. They had no record at the dealership of having charged the system. Nonetheless the new compressor did not change the issue. The 3rd trip to the dealership resulted in "everything is normal". Funny that it was not "normal" the 1st 18 months that I owned the card. Again a dealer rep road with me on the turnpike with similar results. The car is now at the dealership for the 4th time. They said that a code was generated and that the was a failure of one modue; an intermittent failure of another module; and, a short. I am hoping to pick up the car tomorrow. And by the way he also were working with GM reprogramming modules prior to replacing the compressor. Obviously all of that was in vain. If you are having trouble with your dealership over an AC issue I would encourage you to contact GM in Detroit (866-790-5700). Open a problem ticket with them and leave it open until either the car is fixed or they escalate to the GM District representative. I could not take advantage of the Florida Lemon Law because even though my Camaro is under warranty it is over 24 months old. Dealerships do not like hearing from Detroit or the GM District representative so put on the pressure. Don't let them tell you that you don't have a problem. Also even if you are a couple of miles within your warranty expiration once you report it to GM and have an incident record your car will be repaired for that issue even when the warranty expires. I hope this info helps. I will post another message as soon as I get the replacement part numbers and confirm that the issue has been resolved.
hzdj2c is offline   Reply With Quote
Old 03-27-2013, 04:01 PM   #28
hzdj2c
 
Drives: 2010 Camaro 2SS
Join Date: Mar 2013
Location: Florida
Posts: 2
Angry AC issue 2010 Camaro 2SS

I own a 2010 2SS. In February while traveling the east to west coasts of Florida I noticed the temperature in the car increasing. Placing the AC at MAX cold and full fan did not change anything. I could feel cold air by touching the vents but very little air and a lot of vapors were entering the car. In addition there was a whining sound which is apparant when shifting gears until you reach your cruising speed. The whining at that point is just annoying. The 1st trip to the dealership resulted in "no trouble found". Two days later after having a dealer service rep ride with me on the FL Turnpike he agreed there was an issue. The 2nd stay at the dealership resulted in the dealership working with GM reprogramming modules and replacing the air compressor. They stated the compressor had been over charged. Other than oil changes the dealership was the only hands that touched my Camaro. Of course they had no record of having charged the system. Nonetheless the new compressor did not change the issue. The 3rd trip to the dealership resulted in "everything is normal". Funny that it was not "normal" the 1st 18 months that I owned the car. Once again a dealer rep road with me on the turnpike with similar results to observe the loss if AC and the whining sound. Incidently when you turn off the control for the fan speed the whining stops. Turn it back on the the whining continues. The car is now at the dealership for the 4th time. They said that a code was generated and that there was a failure of one modue; an intermittent failure of another module; and, a short. By the way they were also working with GM reprogramming modules prior to replacing the compressor. Obviously all of that was in vain. If you are having trouble with your dealership over an AC issue I would encourage you to contact GM in Detroit (866-790-5700). Open a problem ticket with them and leave it open until either the car is fixed or they escalate to the GM District representative. I could not take advantage of the Florida Lemon Law because even though my Camaro is under warranty it is over 24 months old. Dealerships do not like hearing from Detroit or the GM District representative so put on the pressure. Don't let them tell you that you don't have a problem. Also even if you are a couple of miles within your warranty expiration once you report it to GM and have an incident record your car will be repaired for that issue even when the warranty expires. I hope this info helps. I will post another message as soon as I get the replacement part numbers and confirm that the issue has been resolved. I am to pick up the car tomorrow. I'm keeping my fingers crossed.
hzdj2c is offline   Reply With Quote
Old 05-10-2013, 08:34 AM   #29
rreale
 
Drives: 2013 Camaro 2SS
Join Date: Mar 2013
Location: Albany, ny
Posts: 19
I used my ac on my 2013 last week, not that cold. Back in the day you used to measure the temp coming out of the vents, i remember getting 39 degrees in my old ponitac gran prix, but that was R11 or 12. i know the new refrigerant isnt as cold. is there a temp on should be getting out of the vents. yes i have recric on
rreale is offline   Reply With Quote
Old 05-12-2013, 05:39 AM   #30
S.Chung
 
Drives: 2013 camaro ss
Join Date: Feb 2013
Location: Sacramento, ca.
Posts: 14
2013 ss is anyone else having a problem with the ac is not becoming cold?
S.Chung is offline   Reply With Quote
Old 07-18-2013, 03:44 PM   #31
AKA-22

 
AKA-22's Avatar
 
Drives: ELLE-1
Join Date: Jul 2011
Location: Farmington ,mo
Posts: 1,173
sub
__________________
AKA-22 is offline   Reply With Quote
Old 07-18-2013, 06:47 PM   #32
NYblack1le
 
Drives: 2013 2SS RS 1le
Join Date: Dec 2012
Location: NY
Posts: 75
Have been having a problem with the temperature of my a/c, also get a loud whining noise. Sounds like a compressor problem.
NYblack1le is offline   Reply With Quote
Old 07-18-2013, 07:25 PM   #33
Chevrolet Customer Svc


 
Chevrolet Customer Svc's Avatar
 
Drives: GM Vehicles
Join Date: Jun 2010
Location: Michigan
Posts: 8,971
Quote:
Originally Posted by NYblack1le View Post
Have been having a problem with the temperature of my a/c, also get a loud whining noise. Sounds like a compressor problem.
NYblack1le,

Sorry to hear about your A/C concerns. I'd be happy to research any recalls regarding this on your vehicle if you send me your VIN. Have you also contacted your local dealer?

William R.
Chevrolet Customer Care
Chevrolet Customer Svc is online now   Reply With Quote
Old 08-05-2013, 01:55 PM   #34
jesse10
 
jesse10's Avatar
 
Drives: 2010 camaro 2SS
Join Date: Jul 2013
Location: ft worth
Posts: 41
my 2010 2ss ac does not come out COLD either, just cool. Its annoying bcuz I get into any friends car and quickly notice the ice cold air coming out their ac system.I know if I go to the dealership, they will say its "normal" since it is coming out cool....just not cold.
jesse10 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
K&N AirCharger and Typhoon System | Best Prices | Free Shipping! JDP Motorsports V8 Bolt-Ons & Tunes 175 09-04-2012 03:40 PM
High IAT's vs. PERFORMANCE M6HuggerSS Forced Induction - V8 29 08-30-2011 02:19 PM
CAI cold air induction with E-Force gearhead440 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 9 08-16-2011 09:16 AM
g5cr cai system anybody install or looking at one "pics" camarossrs2150 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 41 07-14-2011 09:26 PM
Tuning for dummies Milk 1027 Tuning / Diagnostics -- engine and transmission 43 03-17-2010 09:06 AM


All times are GMT -5. The time now is 03:45 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.