Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6)

V8 and V6 Transmissions / Driveline (6L80 / 6L50 / TR6060 / AY6) Driveshafts | Differentials | Gears | Rearends | Clutch | Shifters

Reply
 
Thread Tools
Old 09-05-2011, 01:44 PM   #1
Pollock
LS3 M6
 
Pollock's Avatar
 
Drives: 2011 2SS/RS
Join Date: Nov 2010
Location: Bloomington, IN
Posts: 553
Cranked my engine over by hand and the clutch made some noise?

During my header install I had the plugs out so I decided to crank the engine over by hand. In the same spot every time I cranked the motor over I hard a chattery sound from the bell housing for a brief second then it would stop. Is it normal for the clutch to make these noises? The car drives fine and the clutch works fine.

Some pressure plates have weights and such attached to them that can fall and make noise.

Or do I need the ZR1 clutch sooner than later. I had 1350 miles at the time.

I am assuming this was the clutch.
__________________
JRE 470 RWHP Cam, UD pulley, Kooks 1 7/8 Headers w/high flow cats, PCV catch can, Black CAI, ADM racing Scoop, Flowmaster AT Cat Back, VMax TB, BMR Trailing Arms
Pollock is offline   Reply With Quote
Old 09-05-2011, 03:41 PM   #2
Nessal


 
Drives: Lotus Exige
Join Date: Jun 2011
Location: CA, Bay Area
Posts: 2,270
I heard that there were issues with the pressure plate from factory that weren't torqued down correctly.
Nessal is offline   Reply With Quote
Old 09-08-2011, 06:47 PM   #3
Parag

 
Drives: 2010 camaro 2SS LS3
Join Date: Aug 2011
Location: Denver
Posts: 1,335
sounds odd but i wouldnt worry about it if the area seems clean, excessive wear makes bell housing dusty, like brake dust on wheels.
Parag is offline   Reply With Quote
Old 09-09-2011, 12:31 AM   #4
JDP Tech

 
JDP Tech's Avatar
 
Drives: 2010 CGM Camaro 2SS/RS 429 LSX/F1X
Join Date: Aug 2011
Location: Sandy, UT
Posts: 427
I think every LS3 I've turned by hand makes that noise.
Then again, never hurts to have a ZR1 clutch
JDP Tech is offline   Reply With Quote
Old 09-09-2011, 01:17 PM   #5
Pollock
LS3 M6
 
Pollock's Avatar
 
Drives: 2011 2SS/RS
Join Date: Nov 2010
Location: Bloomington, IN
Posts: 553
Quote:
Originally Posted by Tech@JDP View Post
I think every LS3 I've turned by hand makes that noise.
Then again, never hurts to have a ZR1 clutch
I don't want to buy the clutch until I have to. Glad to hear I am not the only one.
__________________
JRE 470 RWHP Cam, UD pulley, Kooks 1 7/8 Headers w/high flow cats, PCV catch can, Black CAI, ADM racing Scoop, Flowmaster AT Cat Back, VMax TB, BMR Trailing Arms
Pollock is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.