Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Kraft Werks
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Tuning / Diagnostics -- engine and transmission

Tuning / Diagnostics -- engine and transmission Tune and diagnostics for engines and auto transmission.

Reply
 
Thread Tools
Old 09-26-2011, 05:47 PM   #1
PSU SS
 
Drives: 2010 SS
Join Date: Jan 2011
Location: State College, PA
Posts: 26
CEL - P1682

Today I jumped in my car, after sitting for about a day, and it took a noticeable amount of cranks for the engine to turn over. After a short drive and a stop and start, normal amount of cranks, the CEL came on and Onstar told me it was code P1682 ignition switch. Has anyone dealt with this and can give me any insight on what I'm dealing with?

Thanks
PSU SS is offline   Reply With Quote
Old 09-26-2011, 08:52 PM   #2
steeleshark2


 
steeleshark2's Avatar
 
Drives: 2010 Transformer 1SS Camaro
Join Date: Nov 2009
Location: Kingsland, Ga
Posts: 2,558
Probably low battery volts when trying to crank the car. How long was it when you last start the car?

P1682 Control Module Performance - Ignition Circuit

Last edited by steeleshark2; 09-26-2011 at 10:24 PM.
steeleshark2 is offline   Reply With Quote
Old 09-28-2011, 07:13 PM   #3
PSU SS
 
Drives: 2010 SS
Join Date: Jan 2011
Location: State College, PA
Posts: 26
It was less than a day
PSU SS is offline   Reply With Quote
Old 09-28-2011, 07:42 PM   #4
steeleshark2


 
steeleshark2's Avatar
 
Drives: 2010 Transformer 1SS Camaro
Join Date: Nov 2009
Location: Kingsland, Ga
Posts: 2,558
Did the check engine light clear? If so, did it come back?
steeleshark2 is offline   Reply With Quote
Old 09-29-2011, 07:27 PM   #5
PSU SS
 
Drives: 2010 SS
Join Date: Jan 2011
Location: State College, PA
Posts: 26
It just cleared today, we'll see what happens.
PSU SS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Diablosport Predator Tune + JBA 2.5" high flow cats = CEL P0430 The Stig Tuning / Diagnostics -- engine and transmission 17 11-12-2011 07:44 AM
Long tube's and CEL bmorecam Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 26 03-09-2011 08:17 PM
Cure for the CEL ?! 5thGENv6 Camaro V6 LLT Engine, Exhaust, and Bolt-Ons 27 02-12-2011 07:13 AM
One possible solution to CEL P0430 w/ JBA midpipes Goliath Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 0 01-10-2011 07:55 PM
Another LT Headers and CEL for Emissions kauffjd3 Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons 7 10-29-2010 02:54 PM


All times are GMT -5. The time now is 02:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.